vaapi problems

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #61
awesome. Purging the ppa took me back to an earlier stable driver which seem to work great. I'm gonna run your git code again and check it out as i'm sure it will work. The va info is a little earlier than the one i had, but only a little. I will post my findings as soon as it is compiled and look forward to posting a positive kodi log for you to look at. Smile
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #62
awesome, with your optimised code and reverting to the current stable drivers, your video was smooth and buttery. as i'm sure you suspected. Kodi Log http://pastebin.com/V5Y6ZpQw . Just a quick test with a couple of video's. I Will test with some blu ray and video i have converted asap. Thanks again bud. tought me more about the drivers. Smile
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #63
Once again thanks bud. kodi log http://pastebin.com/dp01GiqV . Just showing working with blu ray as promised. Everything is playing without a hitch. Flawlessly. I'm Assuming that once the Helix final is out if i compile again following your instructions, as the branch is newtest/Helix, will that compile me the helix final?
find quote
fritsch Offline
Team-Kodi Developer
Posts: 8,451
Joined: Aug 2011
Reputation: 195
Location: Karlsruhe
Post: #64
Yes - it will.

I need to rewrite it a bit for v15. Might find time tomorrow.

"Your most vocal users are not reflective of your userbase" J.M.

Audio Engine: SPDIF has only 2 pcm channels. DTS, AC3 are encoded via those 2 channels. It's obviously clear that you are not able to change Speaker Layout when running via SPDIF.
No help without a proper Debug Log No answer yet? http://www.catb.org/esr/faqs/smart-questions.html
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #65
nightmare, all video is now starting to revert to stuttering again and i noticed in the debug log :-

00:34:32 T:140037324789504 DEBUG: CVideoReferenceClock: Setup failed, falling back to GLX method

Is this the problem?

Debug log http://pastebin.com/fHMbkXca

Also it was compiled earlier so i was wondering is there something new been added to the source code which makes your patch ineffective?
(This post was last modified: 2015-03-25 03:04 by Mancuser.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 8,451
Joined: Aug 2011
Reputation: 195
Location: Karlsruhe
Post: #66
No idea ... it seems you have severe issues to keep your system in a running / working configuration. Disable Sync Playback to Display completely until you decide not to fuck it up again every day.

"Your most vocal users are not reflective of your userbase" J.M.

Audio Engine: SPDIF has only 2 pcm channels. DTS, AC3 are encoded via those 2 channels. It's obviously clear that you are not able to change Speaker Layout when running via SPDIF.
No help without a proper Debug Log No answer yet? http://www.catb.org/esr/faqs/smart-questions.html
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #67
lol
find quote
fritsch Offline
Team-Kodi Developer
Posts: 8,451
Joined: Aug 2011
Reputation: 195
Location: Karlsruhe
Post: #68
:-)

"Your most vocal users are not reflective of your userbase" J.M.

Audio Engine: SPDIF has only 2 pcm channels. DTS, AC3 are encoded via those 2 channels. It's obviously clear that you are not able to change Speaker Layout when running via SPDIF.
No help without a proper Debug Log No answer yet? http://www.catb.org/esr/faqs/smart-questions.html
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #69
just a brief word to let you know. After your last comment i decided to try kodibuntu. Alas this also has no vaapi support with playback (without sync) being jerky and unwatchable. I suppose I must accept defeat and realise kodi doesn't offer HW acceleration for my generation of GPU Sad What should have been simple turned into the kobayashi maru.
(This post was last modified: 2015-03-26 09:10 by Mancuser.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 8,451
Joined: Aug 2011
Reputation: 195
Location: Karlsruhe
Post: #70
No ... nothing needs defeating here. Turn of your Sync Playback to Display which is your only issue. If I read through that test there are at least 5 posts where it is working excellent for you.

I think you should go back to windows. You are one of those guys that clicks on every .exe and afterwards wonder why you end up with a bluescreen and then do a reinstall.

Good luck with whatever way you choose :-)

Btw. I have heard OpenBSD is also an option ...

"Your most vocal users are not reflective of your userbase" J.M.

Audio Engine: SPDIF has only 2 pcm channels. DTS, AC3 are encoded via those 2 channels. It's obviously clear that you are not able to change Speaker Layout when running via SPDIF.
No help without a proper Debug Log No answer yet? http://www.catb.org/esr/faqs/smart-questions.html
find quote
Mancuser Offline
Junior Member
Posts: 45
Joined: Feb 2015
Reputation: 0
Post: #71
even if i turn off Sync playback to display i can not get vaapi to provide smooth playback, i'm sorry, the problem is i thought it was working properly, but after around 15-20 mins it breaks and starts stuttering. My previous claims for it to work were wrong, hence the constant fiddling. If i try a clean install of xubuntu using the distros packages vaapi stutters. If i use the official packages from 01.org, vaapi stutters. Even kodibuntu with vaapi enabled stutters, and I thought that that would not need any configuring. I'm not sure what to do at the min to be honest but I wish you and the rest of the kodi team all the best and good luck in the future.
find quote
Post Reply