playback issue with OSMC

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
buffering Offline
Junior Member
Posts: 3
Joined: Sep 2015
Reputation: 0
Post: #1
Hi,

I use the SiO2 skin on OSMC.
Having updated to the current osmc release a couple of issues have been noticed.
I have cross posted this at the osmc forum here: https://discourse.osmc.tv/t/playback-bei...ded/7456/9

When playing videos (the first video played works fine) the second video played gets "backgrounded" ie osmc reports the video as playing and you hear audio, the skin however never leaves the navigation menu.
On the main menu a "fullscreen" button appears, selecting this takes you to the video though often the image is frozen with running audio.
This is 100% reproducable.
Reports show other skins may also be affected, the default OSMC skin works fine.

I manually updated to the work in progress skin - same issue.

logs at:

http://paste.osmc.io/upazuwugex

thanks
find quote
fastcolors Offline
Skilled Skinner
Posts: 757
Joined: Sep 2012
Reputation: 25
Location: the Matrix
Post: #2
I have no idea what OSMC is, why not use Kodi ??

http://www.wirelesshack.org/openelec-vs-...-kodi.html

seems kodi (openelec) is better anyways ;-)

I will try to look into it but not having an OSMC copy at hand it's hard to test...

one question. where do you start the videos from? Shelf ? or from the movie page?

if you start from shelf, the issue might be with the data provider addon, which many skins on kodi rely on...

http://forum.kodi.tv/showthread.php?tid=210063

hope you solve it.

[Image: icon.png] [Image: bannersio2.png]
Did I Help? Add to my reputation
find quote
buffering Offline
Junior Member
Posts: 3
Joined: Sep 2015
Reputation: 0
Post: #3
I start my videos from: videos -> files

Was tempted to tray openelec but the osmc (former xbmc) distie is a bit more complex and has a full underlying OS so you can get creative.
It is kodi based, just prebuilt for raspberry Pi.
find quote
danial.aw Offline
Junior Member
Posts: 8
Joined: Jan 2013
Reputation: 0
Post: #4
I have the same issue with openelec as well Sad.

running openelec 6 on raspberry pi.... using a keyboard i know it is Tab key to go full screen but for using it on tv ... there is no easy way to full screen it using the remote.

really want to know if anyone knows how to fix this and always pop up full screen video (happens to me on all addons)
find quote
Dilligaf Offline
Posting Freak
Posts: 971
Joined: Dec 2008
Reputation: 44
Post: #5
(2015-09-02 21:10)fastcolors Wrote:  I have no idea what OSMC is, why not use Kodi ??

OSMC is running Kodi. OSMC is the Operating system, OpenElec is an Operating system, they both run Kodi which is a program running on the OS.

If I have been of help, please add to my reputation as a way of saying thanks, it's free.
find quote
fastcolors Offline
Skilled Skinner
Posts: 757
Joined: Sep 2012
Reputation: 25
Location: the Matrix
Post: #6
(2015-12-04 19:11)Dilligaf Wrote:  
(2015-09-02 21:10)fastcolors Wrote:  I have no idea what OSMC is, why not use Kodi ??

OSMC is running Kodi. OSMC is the Operating system, OpenElec is an Operating system, they both run Kodi which is a program running on the OS.

apparently not and I quote from OSMC website:

"OSMC (Open Source Media Center) is a free and open source media player based on Linux and founded in 2014 that lets you play back media from your local network, attached storage and the Internet. OSMC is the leading media center in terms of feature set and community and is based on the Kodi project."

anyway I wasn't asking "what it is" It was more a statement like "I never heard of that build."

since the kodi wiki points only to kodibuntu and openelec

see HERE

I'm using Openelec 6 on a cuboxi and everything works fine. It's hard to look for the issue not having an hardware on which to replicate the same issue...

I think it might be a core issue, since I can't seem to find anything and the PLAY call is made by kodi itself.. not by the skin!

Is there any general thread on this? Try and post on the OSMC / OPENELEC forums or in general help here.

I'm lost at trying to find what the problem might be. (and highly doubt is skin related)

cheers and thanks for using sio2!

[Image: icon.png] [Image: bannersio2.png]
Did I Help? Add to my reputation
find quote
Sam.Nazarko Offline
Posting Freak
Posts: 1,081
Joined: Dec 2009
Reputation: 41
Location: London
Post: #7
Hi,

(2015-09-02 21:10)fastcolors Wrote:  I have no idea what OSMC is, why not use Kodi ??

We try and keep it on the down low -- it's a well kept secret Wink

OSMC is, as Dilligaf says, an operating system, or Linux distribution to be exact. Kodi is the application used, and this is much akin to running Kodi on Windows, Mac or OpenELEC. The underlying application is the same, but the OS is rather different.

To help users discern the difference between OSMC and Kodi, and the different work we do, we've made it clear here in our FAQ.

Quote:http://www.wirelesshack.org/openelec-vs-...-kodi.html

seems kodi (openelec) is better anyways ;-)

That's an interesting article. It says it was written in June, but there are comments from April and our extremely early skin (from January 2015) is used, and we updated that in March and June, which seems odd. I'd suggest a revisit now if you're using OSMC targetted hardware.

Quote:since the kodi wiki points only to kodibuntu and openelec

Thanks for the heads up, I'll make sure that's updated.

Now, the user's issue Smile

I can see some slight synchronisation issues in your log. Does this happen with all videos, or just some? It would be good if you could try on a couple of different videos.

I doubt this is a skin issue -- do you remember when this issue first occurred?

Cheers

Sam
find quote
fastcolors Offline
Skilled Skinner
Posts: 757
Joined: Sep 2012
Reputation: 25
Location: the Matrix
Post: #8
(2015-12-05 00:52)Sam.Nazarko Wrote:  I can see some slight synchronisation issues in your log. Does this happen with all videos, or just some? It would be good if you could try on a couple of different videos.

I doubt this is a skin issue -- do you remember when this issue first occurred?

Cheers

Sam

Thanks!!

[Image: icon.png] [Image: bannersio2.png]
Did I Help? Add to my reputation
find quote
buffering Offline
Junior Member
Posts: 3
Joined: Sep 2015
Reputation: 0
Post: #9
(2015-12-05 00:52)Sam.Nazarko Wrote:  Now, the user's issue Smile

I can see some slight synchronisation issues in your log. Does this happen with all videos, or just some? It would be good if you could try on a couple of different videos.

I doubt this is a skin issue -- do you remember when this issue first occurred?

Cheers

Sam

Happens with all videos and is easily reproduced.
The issue started when OSMC updated to a newer version of Kodi (around the time of my original post).
Since all skins are affected I suspect it is something in Kodi..
find quote