Release - Surveillance Room - Your IP Camera Companion with extra Foscam HD Support

  Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
xrapidx Offline
Junior Member
Posts: 14
Joined: Dec 2011
Reputation: 0
Post: #316
No body know Sad

Sent from my Redmi 4A (typie typie)
find quote
sepulchre Offline
Junior Member
Posts: 20
Joined: Jul 2016
Reputation: 0
Post: #317
(2017-05-13 17:10)sepulchre Wrote:  
(2016-11-22 18:57)jasems Wrote:  1.) Has anyone had success with these 2? Basically need something to put in the MPEG stream (have tried several including ones from the manufacturer website).

Great plugin either way even if I can't get preview working. It will be sweet to just hit a button and open a camera when I hear something at the door! Smile

2.) I am also looking at grabbing some new cameras and would actually get some of the Foscam ones based on this plugin alone (you should contact Foscam for some proceeds!). Does anyone have a recommendation for a decent doorway camera and possibly a moving camera that works well w/this plugin from Foscam?

Did you find out how to map a button to show the preview?

Did you find a door cam, I'm looking for one myself, has to be wifi and weatherproof but I'm not having any luck without spending mucho £££

OK well I got the preview to work using a combination of info here and Keymap editor.

For anyone who's interested, I mapped a button on my remote to Surveillance room with keymap editor, this gave me the key number, I then used info here to modify the action.

I ended up with this which works perfectly Smile

<keymap><global><keyboard><key id="61667">RunPlugin(plugin:// room?action=show_preview&camera_number=1)</key></keyboard></global></keymap>
find quote
rhodges Offline
Junior Member
Posts: 39
Joined: Dec 2015
Reputation: 0
Post: #318
(2017-04-16 01:18)japhule Wrote:  Thanks for sharing kash777.

For some reason kodi still won't show anything in preview or all camera modes. Only the fullscreen stream. I know the snapshot urls are working in a browser, just not in kodi. Kinda stumped as to whats causing my issues.

Same issue. I haven't looked at the entire thread. Are you on v17? I know this worked for me when I was running SPMC (a v16 fork)

I see this in my logs: (v17.1 on Windows 10 with MJPEG from a HikVision camera that works in VLC)

21:10:57.019 T:11400  NOTICE: v1.2.3: REQUEST  :: Params: {'action': 'all_cameras'}
21:10:57.043 T:11400   DEBUG: Alignment of external buffer is not suitable for ffmpeg intrinsics - please fix your malloc
21:10:57.097 T:36716   DEBUG: Previous line repeats 14 times.
21:10:57.097 T:36716   ERROR: v1.2.3: ### ERROR ### : No connection adapters were found for 'rtsp://USER:[email protected]:554/Streaming/Channels/2'

Nevermind. I think it was because I was trying to use an RSTP url and not an HTTP url.
(This post was last modified: 2017-05-23 04:31 by rhodges.)
find quote
Post Reply