EPG search timer arriving

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
FernetMenta Offline
Team-Kodi Developer
Posts: 6,148
Joined: Jul 2010
Reputation: 139
Location: Munich
Post: #1
For those who want to test it, here is the initial version for EPG based search timers:
https://github.com/FernetMenta/vdr-plugi...tree/timer

vnsi addon:
https://github.com/kodi-pvr/pvr.vdr.vnsi/pull/80

VDR version >= 2.3.1 is required.

EPG search string supports wildcard * in the same way you would seach files from the command line. (under the hood it uses regex but that would be hard to edit with only a remote control)
Duplicate episodes are not recoded a 2nd time.
find quote
hre1 Offline
Member
Posts: 56
Joined: Jun 2012
Reputation: 0
Post: #2
Thank you very much for the new feature! Does ..."VDR version >= 2.3.1 is required."... mean that i can't compile the vnsiserver plugin against vdr 2.2.0? I get some warnings and the compile process end with an error:

*** Plugin vnsiserver:
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -std=c++11 -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"vnsiserver"' -DVNSI_SERVER_VERSION='"1.5.0"' -I/stripe/drbd/src/vdr-2.2.0/include -o vnsiclient.o vnsiclient.c
vnsiclient.c: In member function ‘bool cVNSIClient::processTIMER_GetTypes(cRequestPacket&)’:
vnsiclient.c:1954:16: error: no matching function for call to ‘cResponsePacket::add_U32()’
resp.add_U32();
^
vnsiclient.c:1954:16: note: candidate is:
In file included from streamer.h:38:0,
from vnsiclient.c:31:
responsepacket.h:55:8: note: bool cResponsePacket::add_U32(uint32_t)
bool add_U32(uint32_t ul);
^
responsepacket.h:55:8: note: candidate expects 1 argument, 0 provided
make[1]: *** [vnsiclient.o] Error 1

*** failed plugins: vnsiserver

make: *** [plugins] Error 1
(This post was last modified: 2016-05-10 20:36 by hre1.)
find quote
Karl23 Offline
Junior Member
Posts: 16
Joined: May 2011
Reputation: 3
Post: #3
I found a fix for compiling for vdr-2.2.0 here https://github.com/FernetMenta/vdr-plugi.../issues/53
find quote
hre1 Offline
Member
Posts: 56
Joined: Jun 2012
Reputation: 0
Post: #4
Thanks Karl23, that did the trick! Blush
find quote
loggio Online
Posting Freak
Posts: 994
Joined: May 2010
Reputation: 17
Post: #5
Hi there,

I've just started using vdr and notices there was no guide based series recording.
It was a relief to see this post!

I'm using libreelec and installed vdr using their official addon repositories on a spare RPi I had.

Do you have a timeline for when this will be officially available?

Cheers,
Loggio.
(This post was last modified: 2016-05-15 22:58 by loggio.)
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 6,148
Joined: Jul 2010
Reputation: 139
Location: Munich
Post: #6
It requires Kodi v17, hence it will be "official" with Kodi v17 getting released.
(This post was last modified: 2016-05-25 10:45 by FernetMenta.)
find quote
guyrichie Offline
Junior Member
Posts: 27
Joined: Dec 2011
Reputation: 1
Post: #7
Hello All,

I'm having trouble getting this to work! I have Kodi v17 Beta (nightly) along with the latest vnsi addon. I have complied 2.3.1 vdr and the latest git pull of vnsiserver plugin (the only plugin I have running).

I can't add a timer from the EPG grid, an information dialogue box pops up saying the addon does not support this. I managed to manually create an "EPG search" in the Timer rules, however it fails to create any timers from this rule. I did some more testing (playing, poking and prodding) and VDR encounterd a segmentation fault then closes. After a a clean of the vdr source tree and re-building vdr comes back to life.

Any ideas?

Many thanks,
Guy.
find quote
hoppel118 Offline
Senior Member
Posts: 261
Joined: Jul 2011
Reputation: 4
Location: Germany
Post: #8
Sorry, I don't use vdr 2.3.1. I use vdr 2.2.0. So I can't really help you, but I am following the threads regarding to series timer recordings.

Did you see the following thread?

http://forum.kodi.tv/showthread.php?tid=...pid2413312

@ksooo wrote that you need pvr.vdr.vnsi 2.6.5 addon for kodi. Yes, you wrote that you use the latest krypton nightly...

Greetings Hoppel

frontend software - android7 | libreelec | win10 | kodi krypton
frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral 5.1 | samsung le40a789

backend software - debian8 | kernel4.4 | proxmox | omv3 | zfs | emby | vdr | vnsi | fhem
backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | dd cine s2 v6.5​​
(This post was last modified: 2016-09-12 23:55 by hoppel118.)
find quote
Spirou Offline
Member
Posts: 94
Joined: Feb 2016
Reputation: 0
Post: #9
Looking at https://launchpad.net/%7Eteam-xbmc/+arch...&start=150 it seems the the laest nightly build has only version 2.6.1 of pvr.vdr.vnsi included. Not sure if it gets updated after installation.
find quote
guyrichie Offline
Junior Member
Posts: 27
Joined: Dec 2011
Reputation: 1
Post: #10
Hello All,

Blush Yep, I've gone and assumed that Kodi nightly has the latest addon pvr.vdr.vnsi Will build the latest from source tomorrow and report back.

Many thanks,
Guy
find quote
Spirou Offline
Member
Posts: 94
Joined: Feb 2016
Reputation: 0
Post: #11
I pulled vnsi client version 2.6.5 off a deb package from one of the rare ppa's that have it.
Now with everything updated to the latest release (Kode Krypton beta 1, VDR 2.3.1, pvr.vdr.vnsi 2.6.5) it seems to work Smile Still seeing Kodi occasionally crash, but most of the time running stable.
(This post was last modified: 2016-09-14 13:28 by Spirou.)
find quote
guyrichie Offline
Junior Member
Posts: 27
Joined: Dec 2011
Reputation: 1
Post: #12
Hello All,

I still seem to be getting vdr segmentation faults. I have verified all the latest software:

vdr - v2.3.1
vdr-plugin-vnsiserver - master branch of https://github.com/FernetMenta/vdr-plugi...server.git
kodi - v17 Beta 3
pvr.vdr.vnsi - v2.6.5

Viewing syslog, the error before segmentation is:

Sep 21 14:35:39 ubuntu-desktop vdr: [5279] timer 0 (51 1928-2010 'EastEnders') set to event Thu 22.09.2016 19:30-20:00 'EastEnders'
Sep 21 14:35:39 ubuntu-desktop kernel: [ 1242.165346] VNSITimers[5279]: segfault at 0 ip 00007f5e56e96e16 sp 00007f5e515eaae8 error 4 in libc-2.23.so[7f5e56d49000+1c0000]

The Timer Rule/EPG Search I have created is called "EastEnders". If I delete the Timer Rule, vdr encounters no issues. Is this "libc" causing the issue?

Running kernel 4.4.0-36-generic (Ubuntu 16.04 LTS)

Many thanks,
Guy
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 6,148
Joined: Jul 2010
Reputation: 139
Location: Munich
Post: #13
Would you have exact steps to reproduce?
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 6,148
Joined: Jul 2010
Reputation: 139
Location: Munich
Post: #14
fixed in master branch
find quote
guyrichie Offline
Junior Member
Posts: 27
Joined: Dec 2011
Reputation: 1
Post: #15
Hello FernetMenta,

Sorry for not getting back sooner. Re-tested just now after the above update - all working fantastic. Thank you so much.

Many thanks,
Guy
find quote
Post Reply