audio DSP for CarPc

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #1
Hello,

I am using kodi in my car with spdif external (optical) to my dsp sound processor Helix.

And Audio DSP and others (bisquad....) are not available. i activated them but no one appeared in the menu.

On my laptop, i can use them, but i use directsound. Confluence is the theme which used.

I just need to pre processing. Later, i will go for 5.1 system.

Someone can help me please ?Huh
find quote
Rjsachse Offline
Fan
Posts: 475
Joined: Sep 2015
Reputation: 16
Location: Australia
Post: #2
What system are you using? Windows, Linux, Android ect...

Aussie, Aussie, Aussie, Oi, Oi, Oi

Don't forget the Thank User button if i have helped!
|
V
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #3
I am using windows 8 and kodi 16.1.
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #4
Post a debug log please.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #5
(2016-05-31 22:30)wisler Wrote:  Post a debug log please.

Sorry for being late ....

http://pastebin.com/5cb2GdT8
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #6
Did you really enable all adsp add-ons?
So far I can't see any entries in your debug log file.

It's a long time that I used Kodi 16.1 with Confluence. So please be patient when my instructions are not entirly correct.

You have to go to System --> Settings --> Add-ons --> My Add-ons --> All or Audio DSP --> your add-on e.g. Biquad Filters --> Enable
If it is not available please check your install directory. In the addon folder have to be e.g. adsp.biquad.filters with the corresponding dll. if not your installation is broken and you have to reinstall Kodi with adsp addons.

Make sure that your "Settings level" is configured as "Exper".
After that go to Settings --> System --> Audio output --> Enable audio DSP processing --> Audio DSP manager ...
Now active your processing modes.
E.g. activating adsp.biquad filters is done with these steps.
Open Audio DSP manager select the "4. Post-processing". Click on "Biquad Filters: Parametric EQ" and select enable.
Now you should be able to use the EQ from adsp.biquad.filters.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #7
(2016-06-08 21:42)wisler Wrote:  Did you really enable all adsp add-ons?
So far I can't see any entries in your debug log file.

It's a long time that I used Kodi 16.1 with Confluence. So please be patient when my instructions are not entirly correct.

You have to go to System --> Settings --> Add-ons --> My Add-ons --> All or Audio DSP --> your add-on e.g. Biquad Filters --> Enable
If it is not available please check your install directory. In the addon folder have to be e.g. adsp.biquad.filters with the corresponding dll. if not your installation is broken and you have to reinstall Kodi with adsp addons.

Make sure that your "Settings level" is configured as "Exper".
After that go to Settings --> System --> Audio output --> Enable audio DSP processing --> Audio DSP manager ...
Now active your processing modes.
E.g. activating adsp.biquad filters is done with these steps.
Open Audio DSP manager select the "4. Post-processing". Click on "Biquad Filters: Parametric EQ" and select enable.
Now you should be able to use the EQ from adsp.biquad.filters.

I take some pictures to show u. all setting are enabled except audio DSP MANAGER. I am sorry for the language used (french) :

https://goo.gl/photos/XyDSsxzHnXZtZ8WT7

https://goo.gl/photos/9dvQxzrhAtYffQNK8

https://goo.gl/photos/Ar2xUqaeBdARXRv39

https://goo.gl/photos/nZJyMLfyWhzoqGsr9

https://goo.gl/photos/XmYpo51ojL8W8T6n7

https://goo.gl/photos/5a2sGdMc8HPvaZqB6


In my netbook, i can use dsp manager :

https://goo.gl/photos/sc8MxQrNFcc2jh5J9

https://goo.gl/photos/oWyJvx3QfzGqYJWf6


How can i enable it on my car audio ? do u think there is no option for spdif ?
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #8
I have the same issue when I select SPDIF as audio sink. When I select a other sink and restart Kodi AudioDSP is visible. Is this also the case when you use a other sink?

So far I don't know why this happend and will do firther tests, but I can't garuentee that I can fix it or if it is possible to use SPDIF as audio sink. If SPDIF is available on your Windows machine as a normal soundcard then it should he possible. Maybe it's a bug in Kodi.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #9
I talked to one of our devs.

If you remove this line adsp will available in the settings when SPDIF as a sink is selected. But I don't know if it will work. Currently I don't own a optical cable.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #10
(2016-06-11 11:41)wisler Wrote:  I talked to one of our devs.

If you remove this line adsp will available in the settings when SPDIF as a sink is selected. But I don't know if it will work. Currently I don't own a optical cable.

Thank you,

I try this, and nothing happens... Sad

I remove the line, nothing... I switch spdif to directsound and the page stay the same...

I only use spdif sink, and windows use it for output sound. I hav a zotac which have spdif output.
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #11
You have to restart Kodi if ypu switch to direct sound.

Also passthrough should be disabled. Please post all audio settings as screenshots, but in english please I'm not capable of reading the settings in french.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #12
i restart kodi and disable passthrough, nothing happens...

i think i cant use dsp manager because of audio ouput devise : digital connections.

This page explains with analog connections, i can use 2.1 systems. and "audio DSP basic processor" works for 2.1 systems...number of speakers
Then, i am using spdif, it is the number of PCM channels that the audio connection supports.

https://goo.gl/photos/w1fTYyzrGWwETiQQA

https://goo.gl/photos/TycUKhmE2uHoe8TY8

https://goo.gl/photos/S39Efnf8D62KJwEi8

https://goo.gl/photos/j828JMv2Ciqh1iKN6
(This post was last modified: 2016-06-11 18:41 by DkSasukE971.)
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #13
So far I don't know what is wrong on your system.

Can you test latest nightly build?
http://mirrors.kodi.tv/nightlies/win32/

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
DkSasukE971 Offline
Junior Member
Posts: 7
Joined: May 2016
Reputation: 0
Post: #14
yes, i installed KodiSetup-20160610-536fa3c-gettext.exe and DSP manager is not available.

I hav uninstalled all folders and restarted windows. I did a new installation.

https://goo.gl/photos/bSvx2UusMePfr5aK9

https://goo.gl/photos/aEEssmRS3cqnZkbz9

https://goo.gl/photos/F9UK9GKZnxVsvvZS6

Then, i cant use dsp manager with spdif output.

I will say u later, when i could purchase my external soundcard USB. I will try and post a new reply.

So, i am very happy with that build, it looks so sweet, and better to use in car.
find quote
AchimTuran Offline
Team-Kodi Member
Posts: 541
Joined: Jan 2014
Reputation: 13
Location: Germany
Post: #15
Hi,
I'm looking forward to your tests. Currently I do not own a PC with only SPDIF output. But if you can play audio through SPDIF with normal windows players it should be possible with AudioDSP. Maybe it's a bug in the skin.

I know the skin estuary is very awesome and I do not have the motivation to backport stuff for Jarvis add-ons Blush

We use it dayly in our living room. Very awesome and much nicer than Confluence.

Maybe this is interesting for you: Jarvis Skin Showcase.

Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
find quote
Post Reply