Kodi 18 - LibreELEC Testbuilds for x86_64 (Kodi 18.0)

  Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #586
(Yesterday 23:26)jan-g Wrote:  @milhouse
lost SMB to my win8.1 machine with #0322
NOT using samba.conf
SMB from Win8.1 to LibreElec is fine.

Can you post a debug log when accessing your windows machine from Kodi. Also, can you enable SMB component debug logging, thanks.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #587
New LibreELEC.tv Leia build #0323: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.10.5 #1 SMP Thu Mar 23 21:04:31 GMT 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170323210311-#0323-ga339aa7 [Build #0323]

# Kodi version
(18.0-ALPHA1 Git:badda83). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (a339aa7a, changelog) and tip of XBMC master (bae219a8, changelog) with the following modifications:
  • Includes latest kodi-platform master (36fb4937)
  • Includes latest libcec master (8563411d, ahead +11)
  • Includes latest libnfs master (d501dc8a, ahead +55)
  • Includes latest p8-platform master (2d90f986)
  • Includes latest addons: inputstream.adaptive (aa0d5113), inputstream.rtmp (6c1af46a), peripheral.joystick (b4642600, +2), pvr.argustv (7135b279, +1), pvr.demo (1606b612, +1), pvr.dvblink (7296c5b5, +1), pvr.dvbviewer (13c6e5e7, +1), pvr.filmon (e026519d, +1), pvr.hdhomerun (98cb8d40), pvr.hts (819129d5), pvr.iptvsimple (53d63cce), pvr.mediaportal.tvserver (d4dad613, +1), pvr.mythtv (08d609b2, +1), pvr.nextpvr (bb21826b, +1), pvr.njoy (1ce9aba1, +1), pvr.octonet (8549a31c), pvr.pctv (e3b2b845, +1), pvr.stalker (0466af9d, +1), pvr.vbox (4215450f, +1), pvr.vdr.vnsi (9ede401c), pvr.vuplus (12930650, +1), pvr.wmc (5aa3b1ca, +1)
  • Include [env] compare: linux: update to linux-4.10.5
  • Include [env] patch: tvheadend42: fix ffmpeg
  • Include [env] patch: iwlwifi-firmware: update to iwlwifi-firmware-ba301aa
  • Include [env] patch: rapidjson: drop yajl, add rapidjson
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: linux: enable in-tree rtl8192cu for RPi/RPi2
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: Add kodi binary addons (pvr, adsp, other)
  • Include [env] PR:1431: scripts/mkimage: align partitions to 4MiB
  • Include [env] PR:1459: support for ip advanced router and add multiple tcp congestion algorithms
  • Include [env] PR:1465: Package updates: update kodi, ffmpeg, libcec
  • Include [env] PR:1469: samba: update to samba-4.6.0
  • Include [env] PR:1474: scripts: revert changes that led to accumulation of old packages
  • Include [env] PR:1477: config/path: addons need kodi
  • Include [env] PR:1478: userconfig: overwrite our sample files
  • Include [pkg] PR:56: bluetooth: add missing 'Connect' option when device is Trusted (service.libreelec.settings)
  • Include [pkg] PR:62: #change smbd and nmbd location (service.libreelec.settings)
  • Include [pkg] PR:8008: JSON: replace YAJL with RapidJSON
  • Include [pkg] PR:11668: FFmpegImage: Document and change alignment
  • Include [pkg] PR:11879: [PVR] Guide window: Fix selection after channelgroup switching
Build Highlights:
  1. New 4.10.5 kernel
  2. [PVR] Guide window: Fix selection after channelgroup switching
Build Details:
  1. LibreELEC.tv:
  2. XBMC:
    • [docs] Update README.android (PR:11854, 1 commit, 1 file changed)
  3. peripheral.joystick:
    • [sdl] Fix hang when rescanning for joysticks (PR:92, 1 commit, 1 file changed)
    • Bump peripheral.joystick to v1.3.2 for SDL fix (PR:93, 1 commit, 1 file changed)
  4. pvr.argustv:
    • Fix path to CMakeLists.txt (PR:63, 1 commit, 1 file changed)
  5. pvr.demo:
    • Fix path to CMakeLists.txt (PR:41, 1 commit, 1 file changed)
  6. pvr.dvblink:
    • Fix path to CMakeLists.txt (PR:80, 1 commit, 1 file changed)
  7. pvr.dvbviewer:
    • Fix path to CMakeLists.txt (PR:55, 1 commit, 1 file changed)
  8. pvr.filmon:
    • Fix path to CMakeLists.txt (PR:66, 1 commit, 1 file changed)
  9. pvr.mediaportal.tvserver:
    • Fix path to CMakeLists.txt (PR:61, 1 commit, 1 file changed)
  10. pvr.mythtv:
    • Fix path to CMakeLists.txt (PR:107, 1 commit, 1 file changed)
  11. pvr.nextpvr:
    • Fix path to CMakeLists.txt (PR:55, 1 commit, 1 file changed)
  12. pvr.njoy:
    • Fix path to CMakeLists.txt (PR:34, 1 commit, 1 file changed)
  13. pvr.pctv:
    • Fix path to CMakeLists.txt (PR:43, 1 commit, 1 file changed)
  14. pvr.stalker:
    • Fix path to CMakeLists.txt (PR:86, 1 commit, 1 file changed)
  15. pvr.vuplus:
    • Fix path to CMakeLists.txt (PR:55, 1 commit, 1 file changed)
  16. pvr.wmc:
    • Fix path to CMakeLists.txt (PR:49, 1 commit, 1 file changed)
  17. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: linux: update to linux-4.10.5
    • Added: [env] PR:1474: scripts: revert changes that led to accumulation of old packages
    • Added: [env] PR:1477: config/path: addons need kodi
    • Added: [env] PR:1478: userconfig: overwrite our sample files
    • Added: [pkg] PR:11879: [PVR] Guide window: Fix selection after channelgroup switching

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
john.cord Online
Fan
Posts: 653
Joined: Jan 2007
Reputation: 7
Location: Vienna
Post: #588
SMB is broken, trying to access my NAS crashes Kodi with a total freeze.

Gesendet von meinem mobilen Fusionsreaktor mit Tapatalk

Asus Chromebox M077U 4GB RAM 128GB m2 SSD - Harmony Elite BT, Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT,
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
find quote
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #589
(Today 00:45)john.cord Wrote:  SMB is broken, trying to access my NAS crashes Kodi with a total freeze.

Gesendet von meinem mobilen Fusionsreaktor mit Tapatalk
Crashlog if Kodi is crashing, or a debug log if kodi is freezing.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
jan-g Offline
Junior Member
Posts: 35
Joined: Mar 2014
Reputation: 1
Post: #590
(Yesterday 23:38)Milhouse Wrote:  
(Yesterday 23:26)jan-g Wrote:  @milhouse
lost SMB to my win8.1 machine with #0322
NOT using samba.conf
SMB from Win8.1 to LibreElec is fine.

Can you post a debug log when accessing your windows machine from Kodi. Also, can you enable SMB component debug logging, thanks.

here you go: http://sprunge.us/eFEQ

trying to access two shares in file mode (getting screen to enter user and psw) and trying to play a tv show in library mode (getting file no longer exists)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #591
(Today 00:50)jan-g Wrote:  
(Yesterday 23:38)Milhouse Wrote:  
(Yesterday 23:26)jan-g Wrote:  @milhouse
lost SMB to my win8.1 machine with #0322
NOT using samba.conf
SMB from Win8.1 to LibreElec is fine.

Can you post a debug log when accessing your windows machine from Kodi. Also, can you enable SMB component debug logging, thanks.

here you go: http://sprunge.us/eFEQ

trying to access two shares in file mode (getting screen to enter user and psw) and trying to play a tv show in library mode (getting file no longer exists)

The log shows permission failures when accessing smb://JAN-PC/Complete/

About the only thing I can suggest right now is to try:
Code:
sed /usr/config/samba.conf.sample -e 's/name resolve order.*/& wins/' >/storage/.config/samba.conf
then reboot and see if it's any better (I'm not really expecting it to help as it's the server config, but this is samba so who knows).

I've been testing this updated samba server and client against Windows 7 Pro without any issues so far.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #592
(Today 00:50)jan-g Wrote:  (getting screen to enter user and psw)

Can you enable SMB component debug logging, try to access the share, then post your debug log.

It might also be worth restarting your server.

Have you tried adding a passwords.xml?

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
jan-g Offline
Junior Member
Posts: 35
Joined: Mar 2014
Reputation: 1
Post: #593
(Today 01:49)Milhouse Wrote:  
(Today 00:50)jan-g Wrote:  
(Yesterday 23:38)Milhouse Wrote:  Can you post a debug log when accessing your windows machine from Kodi. Also, can you enable SMB component debug logging, thanks.

here you go: http://sprunge.us/eFEQ

trying to access two shares in file mode (getting screen to enter user and psw) and trying to play a tv show in library mode (getting file no longer exists)

The log shows permission failures when accessing smb://JAN-PC/Complete/

About the only thing I can suggest right now is to try:
Code:
sed /usr/config/samba.conf.sample -e 's/name resolve order.*/& wins/' >/storage/.config/samba.conf
then reboot and see if it's any better (I'm not really expecting it to help as it's the server config, but this is samba so who knows).

I've been testing this updated samba server and client against Windows 7 Pro without any issues so far.

No, doesn't help (it did create a "samba.conf)
Fired up my Win7 Ultimate machine and this shows the same behavior as Win8.1
I'm not using user/psw on my shares , and I share with "everyone" with full access.

edit: restarted the server and SMB component debug logging was enabled.
(This post was last modified: Today 02:45 by jan-g.)
find quote
Magoo32 Online
Member
Posts: 62
Joined: Sep 2015
Reputation: 0
Post: #594
Samba not working for me either, on my Win7 machine instead of libreelec i get %h and asks for a login and password!
find quote
Milhouse Offline
Team-Kodi Member
Posts: 11,742
Joined: Jan 2011
Reputation: 569
Post: #595
It seems to be a problem with the Guest (Everyone) accounts.

If you use a normal non-guest account with a password, it's working fine.

Hmm.

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
conca Offline
Junior Member
Posts: 17
Joined: Mar 2015
Reputation: 0
Post: #596
Same problem for me ... no guest connection
find quote
Magoo32 Online
Member
Posts: 62
Joined: Sep 2015
Reputation: 0
Post: #597
Debug Log, don't think it shows to much though.

http://sprunge.us/VQIF

Also wanted to mention I was running a custom Samba config.

Windows 7

[Image: FBXXXwq.png]


Deleted my samba.conf and hostname came back and everything seems ok!
(This post was last modified: Today 21:04 by Magoo32.)
find quote
Magoo32 Online
Member
Posts: 62
Joined: Sep 2015
Reputation: 0
Post: #598
Trying to edit the samba.conf in /etc/samba, but I'm not quite sure how to get around the read-only file system? Smile

Thanks!
find quote
Post Reply