ServerWMC Guide Data

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bac80 Offline
Junior Member
Posts: 3
Joined: Dec 2016
Reputation: 0
Post: #1
I'm running Kodi on a few Nvidia Shield boxes with ServerWMC running on my old WMC box and it's all working great, however after a day or two guide data starts becoming sparse and it's like half my guide is missing data. Exiting Kodi and going back in fixes it and all missing guide data is refreshed and reappears, I've set it to refresh data every 15 mins why do I need to exit and reopen Kodi for this guide data to show up after a couple of days? The longer I leave it the more guide data starts missing. Is there a fix for this so I don't have to exit/reopen Kodi all the time?
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #2
I haven't heard of this problem, but I wouldn't see it myself since we close kodi when we aren't using it. Since you set kodi to download every 15 min do you see it actually doing the download from serverwmc on this interval? Which version of Kodi are you running?

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
bac80 Offline
Junior Member
Posts: 3
Joined: Dec 2016
Reputation: 0
Post: #3
I'm running Kodi 16.1 on one box and the latest version of SPMC from the Google play store on the others, both seem to do it. I checked and the guide data is full until Wednesday the 28th. After that a few shows are appearing with no data which is normal that far out but if I leave it until tomorrow without a restart shows will be missing data already. Yes, it appears to be doing the download. Is there an add-on or something that can close and re-open Kodi each day by itself, remember this is a shield box and not a PC. This would probably solve my issues.
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #4
I don't know of an addon that does that. I will try to reproduce the problem.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
jdlive Offline
Senior Member
Posts: 101
Joined: Dec 2013
Reputation: 2
Post: #5
I've seen this happening on one of my Win7 HTPCs where I leave Kodi running all the time. Even reloading the DB from Kodi doesn't fix the problem, have to exit out and restart. For me it seems to be certain channels just lose the data. Haven't reported it up until now because I've been busy and hadn't collected any logs. I've also disabled the setting to keep guide data in the local cache, didn't seem to make any difference. Will try to grab logs the next time it happens.
find quote
fabd Offline
Senior Member
Posts: 106
Joined: Jan 2015
Reputation: 1
Post: #6
same problems for me since several months.

Restart kodi sometime or do nothing and get back to epg data for some channel...
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #7
I so far haven't been able to reproduce the problem.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
happpyg Offline
Junior Member
Posts: 6
Joined: May 2013
Reputation: 0
Post: #8
Following this thread as I too have this problem on my Raspberry Pi's running OSMC. They are left on 24x7 and after an initial restart guide data is all there as OP describes and then it falls away. A restart fixes it straight away. Haven't tried leaving Kodi running on my Windows PC yet to see if it does the same but will now.
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #9
I will try again to reproduce it. If you can see if it happens on pc that would be useful too.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
happpyg Offline
Junior Member
Posts: 6
Joined: May 2013
Reputation: 0
Post: #10
(2017-01-13 07:17)krustyreturns Wrote:  I will try again to reproduce it. If you can see if it happens on pc that would be useful too.

I'll leave a windows machine going all weekend and see what happens.
Are there any logs or extra information I can get you from the Pi's?
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #11
When you find it happening save the serverwmv log, if that is the cause the answer should be there. But it would be easier to interpret if only one client is online.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
happpyg Offline
Junior Member
Posts: 6
Joined: May 2013
Reputation: 0
Post: #12
(2017-01-13 08:36)krustyreturns Wrote:  When you find it happening save the serverwmv log, if that is the cause the answer should be there. But it would be easier to interpret if only one client is online.

Will do. This is from the WMC machine with ServerWMC running yes? Not the client's themselves.
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #13
Well.... I've decided to try the same thing by leaving my devel machine on for the weekend. I can't do the experiment with my client/server machines because I can't control what the rest of the family does (at least not without catching some grief). My devel machine is a windows client/server, so I'll be able to generate that data myself. So if its all the same to you, it might be better to get me non-windows client data (but still the serverwmc log is what I want). Thanks.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
krustyreturns Offline
Moderator
Posts: 3,055
Joined: Aug 2012
Reputation: 77
Location: Springfield Heights, CA
Post: #14
Also, let me know if any of your kodi settings - with regards to guide data - are set to anything other then kodi's default values.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
find quote
happpyg Offline
Junior Member
Posts: 6
Joined: May 2013
Reputation: 0
Post: #15
Well after monitoring for the last few days I have not been able to get it to fault again like it did every few days before. The only change I did make was to change the Days to display from 3 to 5 and I hit "Clear Data", everything else is default. Once it refreshed the guide it has not played up since. I'll monitor and report back if it does it again.

Thanks!
find quote
Post Reply