Green screen instead of video with ATI/AMD graphics

  Thread Rating:
  • 3 Votes - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
einal Offline
Junior Member
Posts: 24
Joined: Oct 2007
Reputation: 0
Sad  Green screen instead of video with ATI/AMD graphics
Post: #1
Hi,

I'm having the same problem as discussed here: http://forum.xbmc.org/showthread.php?tid=28863 but my problem appears to be different in that I have been using AMD's Catalyst 7.11 driver for some time without issues until I updated XBMC. Doesn't matter what rendering method I choose and I've tried turning TexturedVideo and VideoOverlay on and off in xorg.conf without any change.

Apart from the green screen everything seems to work, I can hear the sound and the debug output shows 2 fps. Mplayer works flawlessly.

Any opinions?
find quote
notdenizen Offline
Junior Member
Posts: 10
Joined: Dec 2007
Reputation: 0
Post: #2
Have you checked your Deinterlacing settings? I've had my screen go green/corrupted when my interlacing settings were set incorrectly.

I'm assuming you get the green screen when playing back video, but the XBMC UI works fine.
find quote
Roughack Offline
Junior Member
Posts: 1
Joined: Dec 2007
Reputation: 0
Post: #3
Same here, tried changing the interlacing-settings but nothing helped.

Some info:
Compiled 23h ago. (updated from SVN)
Ati radeon 9700pro
VLC with openGL works
some stuff from the log
Code:
14:44:38 T:3071280960 M: 83783680   DEBUG: GL: Shader compilation log:
14:44:38 T:3071280960 M: 83783680   DEBUG: Vertex shader was successfully compiled to run on hardware.
14:44:38 T:3071280960 M: 83783680   DEBUG: GL: Shader compilation log:
14:44:38 T:3071280960 M: 83783680   DEBUG: Fragment shader was successfully compiled to run on hardware.
14:44:38 T:3071280960 M: 83783680   DEBUG: GL: Shader compilation log:
14:44:38 T:3071280960 M: 83783680   DEBUG: Vertex shader was successfully compiled to run on hardware.
14:44:38 T:3071280960 M: 83783680   DEBUG: GL: Shader compilation log:
14:44:38 T:3071280960 M: 83783680   DEBUG: Fragment shader was successfully compiled to run on hardware.
14:44:38 T:3071280960 M: 83709952   ERROR: GL ERROR: invalid value
14:44:38 T:3071280960 M: 83709952   ERROR: In file:LinuxRendererGL.cpp function:RenderMultiPass line:2122


14:45:19 T:2807028624 M: 79519744 WARNING: GetImage - Timeout waiting for texture 0
14:45:19 T:2807028624 M: 79519744  NOTICE: Calling ATI FlipPage

Got a few days older version on my laptop(ati7500mobility) and that works flawlessly
find quote
Nick8888 Offline
Fan
Posts: 716
Joined: Jan 2007
Reputation: 0
Post: #4
First thing I'd do is a reinstall. Next try an older version. If its still not working then state detailed information of your problem on here. you cant expect the svn to work flawlessly in every instance.
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #5
It's possible that the recent video renderer optimizations might have broken the ATI renderer.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #6
Those of that have ATI cards, please try changing line 187 in xbmc/cores/VideoRenderers/RenderManager.cpp from CLinuxRendererATI(true) to CLinuxRendererGL() and see if that helps the green screen issue. If it does please report back and I'll commit it.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
cleanrock Offline
Junior Member
Posts: 3
Joined: Dec 2007
Reputation: 0
Post: #7
green video here on my ATI card
i guess the following from xbmc.log can help you identify the problem :

Code:
13:54:42 T:2607807376 M:322695168 WARNING: GetImage - Timeout waiting for texture 0

i tried the change in RenderManager.cpp with no luck (core dump)
find quote
tsint Offline
Member
Posts: 74
Joined: Dec 2007
Reputation: 0
Location: Sweden
Post: #8
Same problem with my ATI-card.

I've also tried to change CLinuxRendererATI(true) to CLinuxRendererGL() but my screen turns then white instead of green.
find quote
d4rk Offline
Team-XBMC Developer
Posts: 499
Joined: May 2007
Reputation: 1
Location: Albuquerque
Post: #9
The ATI renderer is still broken, it will probably be fixed in the next few days.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Please read and follow the forum rules.
For troubleshooting and bug reporting, please make sure you read this first.


[Image: badge.gif]
find quote
cleanrock Offline
Junior Member
Posts: 3
Joined: Dec 2007
Reputation: 0
Post: #10
still green video on my ATI card, at least the framerate is ok now .. it was 2 fps before
any news about this "green video" problem ?
find quote
molten_universe Offline
Junior Member
Posts: 18
Joined: Aug 2007
Reputation: 0
Post: #11
Yesterday still green on my 2400XT Sad

...still got my xbox Smile
find quote
chadoe Offline
Team-XBMC Developer
Posts: 630
Joined: Nov 2003
Reputation: 0
Location: Home
Post: #12
This somewhat works:
-do the CLinuxRendererATI(true) to CLinuxRendererGL() change in RenderManager.cpp
-then in CLinuxRendererGL::ValidateRenderTarget() change the last parameter of m_pBuffer = new CSurface(...) to true (the pbuffer one).

Very unstable though on my Radeon 9600 mobility, crashes either when I stop the video or when I try to play another video. Would be better if someone who actually knows what he's doing takes a look Wink

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
paokouran Offline
Junior Member
Posts: 2
Joined: Jan 2008
Reputation: 0
Smile  same bug for me ati 8.44
Post: #13
hi

first of all very big thanks to put xbmc on linux Smile vas a great news for me ...

so i have this green bug too (damn ati linux) with latest 8.44

i modified the ClinuxRendererGL ok

but :

then in CLinuxRendererGL::ValidateRenderTarget() change the last parameter of m_pBuffer = new CSurface(...) to true (the pbuffer one)

where is it ?? same file? or any news on this atirender?

thanks again, keep good works

(and sorry for my poor english)
find quote
paokouran Offline
Junior Member
Posts: 2
Joined: Jan 2008
Reputation: 0
Post: #14
ok i found where it is the rebuilded xbmc

still green screen and show me fps 2.0

in the log file

error is there now:

xbmc.log

01:59:50 T:2712128400 M:565846016 NOTICE: Calling ATI FlipPage
01:59:50 T:3068745536 M:565587968 NOTICE: GL: Selecting YUV 2 RGB Progressive Shader
01:59:51 T:2712128400 M:564383744 WARNING: GetImage - Timeout waiting for texture 0

repeated ... if it can help...

thanks
find quote
ajje Offline
Junior Member
Posts: 38
Joined: Nov 2007
Reputation: 0
Post: #15
FYI
I too have problem with ATI and solid green screen when playing movie.
Just to test i removed ATI's restricted drivers and installed Xfree's open ATI 3d driver.
And now i see the movie but everything is in shades of green instead, not solid green anymore, and the fps is normal again, not locked on 2fps.
Still unwatchable but a small step in the right direction...
My build is from 2008-01-07
Xubuntu7.10 + Ati x300
Any progress with Ati renderer, d4rk ?
find quote
Post Reply