Dvblink PVR Windows no dolby digital

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jjhtpc Offline
Member
Posts: 63
Joined: Dec 2013
Reputation: 2
Post: #1
I can only get stereo through the windows PVR. I know the server is working properly as I can get Dolby digital on a firetv with pass through.

Pass through is working properly for all other items. Has anyone else experienced something similar?
find quote
nickr Offline
Team-Kodi Member
Posts: 17,638
Joined: May 2009
Reputation: 355
Location: Christchurch NZ
Post: #2
If you are using Krypton then passthrough is disabled for all live TV.

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
jjhtpc Offline
Member
Posts: 63
Joined: Dec 2013
Reputation: 2
Post: #3
Really? Is this a bug? I know this was working with Jarvis, but didn't know if it was specific to dvblink or Krypton.
find quote
nickr Offline
Team-Kodi Member
Posts: 17,638
Joined: May 2009
Reputation: 355
Location: Christchurch NZ
Post: #4
No it is a deliberate decision by the devs. There are plenty of threads on it, I'll let you find and read them.

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
goodton Offline
Senior Member
Posts: 118
Joined: Dec 2016
Reputation: 3
Location: Finland
Post: #5
I had also understood from various discussions, that bitstreaming for Live-TV in Krypton is disabled, the arguments were understandable. I was very surprised couple of days ago that when I was watching TV in Kodi, the Dolby Digital-logo was shining on my AV-receiver. As I´m using Kodi 17 RC3, this should not be possible, so I started to investigate more. Seems that certain settings and channel switching method triggers this phenomenom. In Audio-settings the Output Configuration -> Optimized and of course the Bitstreaming need to be enabled. The final trigger here is that the channel need to be changed using the channel number only, if the channel is changed from the EPG or from the Channel List, audio output will remain in stereo-mode.

So if this a bug, please don´t fix it Smile
find quote
fab4272 Offline
Junior Member
Posts: 41
Joined: Jun 2015
Reputation: 0
Post: #6
This is really disappointing. Why not let users select the option they would prefer (ie 2.0 or passthrough) under the TV settings. This is a step backwards, as there is a lot of live tv broadcast with 5.1 audio these days.
find quote
goodton Offline
Senior Member
Posts: 118
Joined: Dec 2016
Reputation: 3
Location: Finland
Post: #7
It seems that this strange issue of working Dolby Digital in Live-TV in my case is related to time shifting, which is (of course) activated on Dvblink-addon. Probably Kodi does not see this time shifted Live-TV as a real-time material and therefore the passthrough is possible. Just a theory, of course.

Another possible option to get 5.1-sound for Live-TV in Krypton is to trigger the AC3-transcoding ON in Kodi passthrough-settings.
find quote