Windows - TvServer tunes the channel, but Kodi does not play it

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
solidservo Offline
Junior Member
Posts: 26
Joined: Nov 2012
Reputation: 0
Exclamation  TvServer tunes the channel, but Kodi does not play it
Post: #1
I am currently running MP 1.16, where the TVServer is installed on a W10 PC.

I have installed:
- the latest MP PVR plugin on the TVServer
- allowed the plugin to create the shares for recordings and TSBuffer
- installed Kodie 17 (on another W10 PC - TvServer and Kodie are not on the same PC's)
- installed the PVR MP plugin in Kodie

What works:
- I get TVChannels and Guide data inside Kodi

What does not work:
When I try to tune a channel then the spinning blue "busy" icon appears and then goes away.
Inside of the TvServers manual control section I see that the Kodi plugin tuned the channel, but there is no playback on the client.

I also tried the RTSP streaming option but then the spinning blue "busy" icon will never go away and I have to close Kodi with ALT+F4
(This post was last modified: 2017-02-13 08:41 by solidservo.)
find quote
solidservo Offline
Junior Member
Posts: 26
Joined: Nov 2012
Reputation: 0
Post: #2
tried it again yesterday, no joy. Undecided
find quote
pĆ¼nktchen Offline
Fan
Posts: 343
Joined: Jul 2012
Reputation: 8
Post: #3
Logs? http://forum.kodi.tv/showthread.php?pid=...pid1707504
find quote
mcelliott Offline
Fan
Posts: 366
Joined: Mar 2015
Reputation: 4
Post: #4
The plugin doesn't create the shares. These have to be shared in Windows.
find quote
solidservo Offline
Junior Member
Posts: 26
Joined: Nov 2012
Reputation: 0
Post: #5
(2017-02-14 20:45)mcelliott Wrote:  The plugin doesn't create the shares. These have to be shared in Windows.
Actually the plugin has a "create share" button and it does also create the shares. Smile

[Image: 48XTdUF.jpg]

HOWEVER it failed to set ANY permissions on the shares which meant that they could not be accessed! So thanks for making me look into the share details!
I will need to test this once I get back from work. Smile

If this turns out to be the cause of my problem, then it would be wise to to have the Kodi plugin tell the user that it can't access the share. Wink
(This post was last modified: 2017-02-15 11:15 by solidservo.)
find quote
solidservo Offline
Junior Member
Posts: 26
Joined: Nov 2012
Reputation: 0
Post: #6
Still not working. I can access both shares on the PC, the tsbuffer file is created and I can play it on the PC as well. But inside Kodi I get this

Code:
18:42:40.344 T:6640  NOTICE: ES: Starting UDP Event server on port 9777
18:42:40.345 T:6640  NOTICE: UDP: Listening on port 9777 (ipv6 : false)
18:42:40.636 T:4620   ERROR: CCurlFile::Open failed with code 404 for http://addonscriptorde-beta-repo.googlecode.com/svn/trunk/addons.xml.md5
18:42:40.637 T:4620   ERROR: XFILE::CFileCache::Open - failed to open source <http://addonscriptorde-beta-repo.googlecode.com/svn/trunk/addons.xml.md5>
18:42:40.637 T:4620   ERROR: CRepository: failed read 'http://addonscriptorde-beta-repo.googlecode.com/svn/trunk/addons.xml.md5'
18:42:42.674 T:6132  NOTICE: [plugin.video.youtube] Startup: detected Unknown XBMC Release (Unknown Application-1.0), setting DASH_SUPPORT_BUILTIN = False, DASH_SUPPORT_ADDON = False
18:42:51.341 T:4492  NOTICE: Previous line repeats 1 times.
18:42:51.341 T:4492  NOTICE: starting upnp client
18:42:51.390 T:4492  NOTICE: ADDONS: Using repository repository.addonscriptorde-beta
18:42:51.390 T:4492  NOTICE: ADDONS: Using repository repository.xbmc.org
18:42:51.449 T:4492 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
18:42:51.625 T:8360   ERROR: PVR - PVR::CPVRClients::ConnectionStateChange - invalid handler data
18:42:51.831 T:4620  NOTICE: PVRManager - stopping
18:43:04.454 T:4620  NOTICE: EPG::CEpgContainer::Start - EPG thread started
18:43:06.469 T:4492   ERROR: Control has invalid animation type (no condition or no type)
18:43:30.239 T:4492   ERROR: Previous line repeats 1 times.
18:43:30.239 T:4492  NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.mediaportal.tvserver_777.pvr
18:43:30.239 T:4492 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:43:30.245 T:4492   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
18:43:30.245 T:4492   ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
18:43:30.246 T:1700  NOTICE: Creating InputStream
18:43:30.250 T:1700  NOTICE: AddOnLog: MediaPortal PVR Client: Open Live stream for channel uid=777
18:43:32.826 T:1700  NOTICE: AddOnLog: MediaPortal PVR Client: Channel timeshift buffer: D:\HTPC\TSBuffer\live18-0.ts.tsbuffer
18:43:32.826 T:1700  NOTICE: AddOnLog: MediaPortal PVR Client: Creating a new TsReader...
18:43:32.826 T:1700  NOTICE: AddOnLog: MediaPortal PVR Client: TsReader open 'rtsp://192.168.1.10/stream18.0'
18:44:25.016 T:8136   ERROR: CAESinkDirectSound::UpdateCacheStatus: GetCurrentPosition failed. Unable to determine buffer status. HRESULT = 0x88780096
18:44:25.017 T:8136   ERROR: CActiveAESink::OutputSamples - sink returned error

*EDIT*
Disabled RTSP mode and now it works.
(This post was last modified: 2017-02-20 19:58 by solidservo.)
find quote