BUG - first_air_date regex bug in metadata.tvshows.themoviedb.org version 1.3.1?

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
djbloc Offline
Junior Member
Posts: 6
Joined: Mar 2017
Reputation: 0
Post: #1
I think I might have stumbled upon an issue while debugging tv shows not appearing in the library. I'm using the TV show scraper from The Movie Database from http://mirrors.kodi.tv/addons/krypton/me...-1.3.1.zip

For the search function GetSearchResults it is doing a RegExp on the first_air_date of either ([0-9]+) or null. Looking at the JSON API response The Movie Database API is returning "" (blank) instead.

When searching for Lorraine returns 5 results. The first entry is "Lorraine" but the first_air_date is set to "". The kodi debug logs for GetSearchResults returned "Audience with Lorriane". Note this is the wrong show but matches first_air_date regex. My debug logs then shows kodi returns the GetVideoDetails for the id of the original "Lorraine" show. This tv show is in the kodi video library.

When searching for Unreported World returns 1 result. This result has the first_air_date is set to "". Since this is the only result, the search function GetSearchResults returns empty. The next line in the logs is the warning "No information found for item xxx, it won't be added to the library."

I've seen this behavior on multiple entries now. See FYI Daily and Location, Location, Location

Other programs where first_air_date is set are working fine. One example is The Big Bang Theory

How do I pass this information to the maintainer?
find quote