Linux - setwake.sh does not post on poweroff

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
waddacrock Offline
Member
Posts: 66
Joined: Aug 2015
Reputation: 0
Post: #1
No sure if this is kodi or PVR related, but here goes;

The system is xubuntu 16.04.2 with updates, mythtv 0.28 backend (from the ppa), kodi 17.1

Using /usr/bin/setwakeup.sh $ time as the set wake up time command in Kodi > System > PVR & LiveTV > Power Saving > Wakeup command.

If I close Kodi from the "Exit" option, the wake up time is written correctly, if the log written by setwakeup.sh is to be believed.

However, it is not written at all, i.e. the script doesn't seem to be called, when the "Power off system" option is chosen.

The kodi, mythbackend and sys logs are not telling me anything, but the lack of output to the setwakeup.sh log seems to confirm the script is not executing on power off.

Any ideas?
find quote
ksooo Offline
Team-Kodi Member
Posts: 787
Joined: Jan 2015
Reputation: 40
Location: Hamburg, Germany
Post: #2
(2017-04-08 06:22)waddacrock Wrote:  No sure if this is kodi or PVR related, but here goes;

The system is xubuntu 16.04.2 with updates, mythtv 0.28 backend (from the ppa), kodi 17.1

Using /usr/bin/setwakeup.sh $ time as the set wake up time command in Kodi > System > PVR & LiveTV > Power Saving > Wakeup command.

If I close Kodi from the "Exit" option, the wake up time is written correctly, if the log written by setwakeup.sh is to be believed.

However, it is not written at all, i.e. the script doesn't seem to be called, when the "Power off system" option is chosen.

The kodi, mythbackend and sys logs are not telling me anything, but the lack of output to the setwakeup.sh log seems to confirm the script is not executing on power off.

Any ideas?


This is a known bug that will be fixed with Kodi 17.2.
(This post was last modified: 2017-04-08 16:37 by ksooo.)
find quote
waddacrock Offline
Member
Posts: 66
Joined: Aug 2015
Reputation: 0
Post: #3
(2017-04-08 16:37)ksooo Wrote:  This is a known bug that will be fixed with Kodi 17.2.

I'm not so sure; after endless hours trawling the net to solve other issues I was having with our mythtv backend/ slave backend setup I thought I'd try it again and it worked.

Only weird thing is that with "Wakeup Before Recording" set to15 minutes it's kicking in at 30 minutes Huh

Running Kodi 17.1: Git20170320, on Ubuntu 16.04.2 with mythtv 0.28 from the ubuntu repository.
find quote
ksooo Offline
Team-Kodi Member
Posts: 787
Joined: Jan 2015
Reputation: 40
Location: Hamburg, Germany
Post: #4
Whatever made it work for you in 17.1: what you described in your OP is the bug I've fixed for 17.2. As a matter of fact, if you suspend the system with 17.1, wake-up will work. If you turn it off, wake-up will not work.

Regarding waking up too early: the system wakes up "start of the show" minus "padding time configured for the recording" minus "configured system pre recording wake-up time."
find quote