[RELEASE] ITV Catchup (Video) Plugin

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
multipazz Offline
Junior Member
Posts: 40
Joined: Apr 2011
Reputation: 0
Post: #151
mr peacock... you posted invalid link Confused

any chance you can fix it

thanks
find quote
multipazz Offline
Junior Member
Posts: 40
Joined: Apr 2011
Reputation: 0
Post: #152
edit :

found it...

http://forum.xbmc.org/showpost.php?p=545...stcount=36
this file is reporting invalid structure on the latest official XBMC 10.0-8 19th June iOS ATV

going to try this one next ... http://www.megaupload.com/?d=46PTHD5V
this one has installed ok.. now to test it runs Confused
well it will load directories and show the thumbnails..
but fails to stream....
(This post was last modified: 2011-06-21 02:23 by multipazz.)
find quote
Mr Peacock Offline
Junior Member
Posts: 19
Joined: Jan 2010
Reputation: 0
Post: #153
Sorry

This is the one I used.

http://www.megaupload.com/?d=46PTHD5V

It's on page 12, post #119 of this thread.
find quote
pipps Offline
Member
Posts: 61
Joined: Dec 2010
Reputation: 0
Location: UK
Post: #154
I found the plugin installed successfully from zip. (The one linked by Mr Peacock directly above.) I can browse through all the programme categories. However, I am unable to play any videos. They simply never load.

Why could this be? I'm running XBMCLive 10.1. Please help!
find quote
bladeds Offline
Senior Member
Posts: 175
Joined: May 2011
Reputation: 0
Post: #155
are you using a atv2 or pc, lots of streams fail to load on that because it has a old version with a librtmp which there is no easy fix, if you are on a pc this can be fixed. have you used the freecable plugin, this is the reason only some of the streams work from that.

hopephelly soon in one of the nightly builds a version will be released with a new version of librtmp, youll just have to be patient if this is the problem

pipps Wrote:I found the plugin installed successfully from zip. (The one linked by Mr Peacock directly above.) I can browse through all the programme categories. However, I am unable to play any videos. They simply never load.

Why could this be? I'm running XBMCLive 10.1. Please help!
(This post was last modified: 2011-06-28 19:48 by bladeds.)
find quote
pipps Offline
Member
Posts: 61
Joined: Dec 2010
Reputation: 0
Location: UK
Post: #156
bladeds Wrote:are you using a atv2 or pc, lots of streams fail to load on that because it has a old version with a librtmp which there is no easy fix, if you are on a pc this can be fixed. have you used the freecable plugin, this is the reason only some of the streams work from that.

hopephelly soon in one of the nightly builds a version will be released with a new version of librtmp, youll just have to be patient if this is the problem

I was using a default build of XBMCLive 10.1 in my post directly above.

Today I have installed XBMC onto my Windows PC and configured the ITV plugin too. Exactly the same problem occurs upon attempting to load a stream.

Please tell me what I should do to my Windows XBMC installation to make this ITV plugin work properly.
find quote
Big Steve Offline
Junior Member
Posts: 6
Joined: Oct 2010
Reputation: 0
Post: #157
Just updated the libtrmp.dll file on my windows 7 machine, the file is in the program files/xbmc/system/players/dvdplayer folder, and the ITV plugin is working fine again.
find quote
aoaaron Offline
Fan
Posts: 461
Joined: Jul 2011
Reputation: 1
Post: #158
how do you install this on a mac XBMC?

tried to add it on as a zip file, unrecognised, tried renaming, once again unrecognised.
find quote
pipps Offline
Member
Posts: 61
Joined: Dec 2010
Reputation: 0
Location: UK
Post: #159
Big Steve Wrote:Just updated the libtrmp.dll file on my windows 7 machine, the file is in the program files/xbmc/system/players/dvdplayer folder, and the ITV plugin is working fine again.
Do you mean librtmp.dll, rather than libtrmp.dll?

Thanks for providing the Windows directory details.

I have found what seems to be a recent version of librtmp.dll at this page, within the rtmpdump-2.3-windows.zip file.

However, upon copying it to Windows /xbmc/system/players/dvdplayer directory, XBMC still cannot load the ITV video stream as it should. I am using the most up to date build of XBMC 10.1 Dharma from the main download page.

Is there a specific version of lbrtmp.dll which I should be using?

Where did you find the file which you successfully used?
find quote
quite98 Offline
Junior Member
Posts: 3
Joined: Mar 2011
Reputation: 0
Post: #160
bluecop has posted an updated librtmp for atv2. Tested it tonight with the ITV player and it appears to work well.

http://forum.xbmc.org/showpost.php?p=834...tcount=141
find quote
pipps Offline
Member
Posts: 61
Joined: Dec 2010
Reputation: 0
Location: UK
Post: #161
Thanks for the update!

Bluecop says:
Quote:Replace the existing file in "/Applications/XBMC.frappliance/Frameworks" on your atv2. that should fix the handshake issue. It should also work on ios but I am not sure the exact place to put it.

Is it safe to assume that for this ITV add-on, the librtmp should be placed in the usual 'Windows /xbmc/system/players/dvdplayer' directory?

Which directory did you copy this librtmp into?
find quote
myksterx Offline
Senior Member
Posts: 179
Joined: Jul 2009
Reputation: 0
Post: #162
I would also like to know (in 1 post if possible lol) -

1) Which librtmp to use out of the provided links..
2) Where to put it on Win7 XBMC 10.1 Build

Cheers
find quote
lewis Offline
Junior Member
Posts: 20
Joined: Apr 2009
Reputation: 0
Post: #163
myksterx Wrote:I would also like to know (in 1 post if possible lol) -

1) Which librtmp to use out of the provided links..
2) Where to put it on Win7 XBMC 10.1 Build

Cheers

Bump
find quote
CO55Y Offline
Junior Member
Posts: 1
Joined: Jul 2011
Reputation: 0
Post: #164
Here is a file i found earlier. I didn't compile it myself, or know where it originally comes from, but it seems to work. At the very least it should do until a better one comes along.

Just drop the file in C:\Program Files (x86)\XBMC\system\players\dvdplayer

It might be wise to make a backup of the original file just in case.

http://www.megaupload.com/?d=PPBSIBGN
find quote
lewis Offline
Junior Member
Posts: 20
Joined: Apr 2009
Reputation: 0
Post: #165
CO55Y Wrote:Here is a file i found earlier. I didn't compile it myself, or know where it originally comes from, but it seems to work. At the very least it should do until a better one comes along.

Just drop the file in C:\Program Files (x86)\XBMC\system\players\dvdplayer

It might be wise to make a backup of the original file just in case.

http://www.megaupload.com/?d=PPBSIBGN

Just to confirm this works on my setup, Win7 64Bit, XBMC 10.1 ITV plugin plays fine with this verison of the .dll

Thanks CO55Y
find quote
Post Reply