[MOVED] Problems starting XBMC fullscreen

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #1
So i'm using driver 180.37 with SVN 18345 (has the same problem with all previous versions also)

When i start XBMC with 1080p Fullscreen, all my video plays choppy and out of sync with lots of dropped frames. When I start with resolution set to auto (it dosnt open fullscreen), then change it to 1080p it works perfectly until the next restart.

Here is my xbmc.log:
http://pastebin.com/m4b326adb

Any ideas whats going on here?
find quote
pyrates Offline
Member
Posts: 93
Joined: Nov 2008
Reputation: 0
Post: #2
AllanMar Wrote:So i'm using driver 180.37 with SVN 18345 (has the same problem with all previous versions also)

When i start XBMC with 1080p Fullscreen, all my video plays choppy and out of sync with lots of dropped frames. When I start with resolution set to auto (it dosnt open fullscreen), then change it to 1080p it works perfectly until the next restart.

Here is my xbmc.log:
http://pastebin.com/m4b326adb

Any ideas whats going on here?

I get the same thing and had to go back to the build of XBMC I was running without hardware acceleration of video decoding.
find quote
motd2k Offline
Team-XBMC Developer
Posts: 666
Joined: Dec 2008
Reputation: 0
Location: England
Post: #3
The cause of the choppyness is 9/10 times pulseaudio. killall -9 pulseaudio before launching xbmc perhaps.

Yes, the thumbnail generation is a known issue - i'll keep it in mind for my next batch of fixes but its a fairly low priority.
find quote
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #4
motd2k Wrote:The cause of the choppyness is 9/10 times pulseaudio. killall -9 pulseaudio before launching xbmc perhaps.

Yes, the thumbnail generation is a known issue - i'll keep it in mind for my next batch of fixes but its a fairly low priority.
Ive tryed killall -9 pulseaudio and i compiled with --disable-pulse. The thing is, this ONLY occurs when XBMC is started in 1080p(dosnt work when i hit \ to take it out of fullscreen either). If i start it in auto, and then choose 1080p/60 (or 1920x1080 @ 50hz) and hit test resolution 1080p plays flawlessly (until i restart xbmc). So I guess the big question would be, how does XBMC handle it differently between starting in a resolution and changing it afterwards? something to do with XRanR modes perhaps? Im hoping mayb you can shed some light on this.
find quote
kross Offline
Junior Member
Posts: 15
Joined: Jan 2009
Reputation: 0
Post: #5
AllanMar Wrote:Ive tryed killall -9 pulseaudio and i compiled with --disable-pulse. The thing is, this ONLY occurs when XBMC is started in 1080p(dosnt work when i hit \ to take it out of fullscreen either). If i start it in auto, and then choose 1080p/60 (or 1920x1080 @ 50hz) and hit test resolution 1080p plays flawlessly (until i restart xbmc). So I guess the big question would be, how does XBMC handle it differently between starting in a resolution and changing it afterwards? something to do with XRanR modes perhaps? Im hoping mayb you can shed some light on this.

I am getting the EXACT same behavior! I don't have pulseaudio installed. MythTV and mplayer (both with VDPAU) play fine. XBMC also plays fine if I follow the steps above, until I restart it of course.

I'm using r18361, with nvidia driver 180.37.

I tried:
Code:
make reallyclean
./configure --disable-pulse
make
./xbmc.bin

If you need more info, or some log files, or need me to test something, I'm glad to help.

-- Kevin
find quote
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #6
kross Wrote:I am getting the EXACT same behavior! I don't have pulseaudio installed. MythTV and mplayer (both with VDPAU) play fine. XBMC also plays fine if I follow the steps above, until I restart it of course.

I'm using r18361, with nvidia driver 180.37.

I tried:
Code:
make reallyclean
./configure --disable-pulse
make
./xbmc.bin

If you need more info, or some log files, or need me to test something, I'm glad to help.

-- Kevin
Glad to hear I'm not the only one, hopefully motd2k has some ideas. Out of curiosity though, what hardware do you have? M3N78-EM(8300GS) & 4850e X2 with 2x2gb ram here
(This post was last modified: 2009-03-09 22:29 by AllanMar.)
find quote
kross Offline
Junior Member
Posts: 15
Joined: Jan 2009
Reputation: 0
Post: #7
AllanMar Wrote:Glad to hear I'm not the only one, hopefully motd2k has some ideas. Out of curiosity though, what hardware do you have? M3N78-EM(8300GS) & 4850e X2 with 2x2gb ram here

Jetway JNC62K (Geforce 8200 IGP), AMD 5050e, 1x2gb RAM (only one slot on board)

And yes, I know about the AMD and IGP bus speed bottleneck. I have my CPU set to not go below 1.8 GHz with cpufreq.

-- Kevin
find quote
s7mx1 Offline
Senior Member
Posts: 265
Joined: Dec 2007
Reputation: 4
Post: #8
kross Wrote:Jetway JNC62K (Geforce 8200 IGP), AMD 5050e, 1x2gb RAM (only one slot on board)

And yes, I know about the AMD and IGP bus speed bottleneck. I have my CPU set to not go below 1.8 GHz with cpufreq.

-- Kevin


I am having onbord Geforce 8100. 1080p play fine in full screen, resolution was set at default native resolution 1680x1050. The only thing that I am worried about switching to full screen native resolution is when "sync to v blank" is enabled, the gui will be sluggish, while disabled, the CPU usage will be 100% on one core. But none of them are affecting video playback.

I am using XBMC-vdpau r18331, nvidia 182.37, ubuntu 8.10. CPU runs at 1.8G constantly.

Maybe you need to tweak your xorg.conf a bit.
Code:
Option         "TwinView" "0"
    Option         "UseEvents" "true"
    Option "NvAGP" "1"
    Option         "Coolbits" "1"
    Option "NoLogo" "True"
    Option "PixmapCacheSize" "1000000"
    Option "AllowSHMPixmaps" "0"
    Option "TripleBuffer" "True"
    Option "RenderAccel" "True"
they are in the screen section.

Have you tried to force the CPU run at the max frequency possible and see what will happen, since the memory bandwidth of your system is bit limited (only single channel)?
(This post was last modified: 2009-03-09 23:27 by s7mx1.)
find quote
mr.b Offline
Senior Member
Posts: 165
Joined: May 2007
Reputation: 0
Post: #9
@Allanmar, @kross

I have an Asus M3n78-VM -- geforce 8200 based mobo and experience the same thing. It should be noted, however, that this is not specific to the VDPAU branch so this discussion should be taken to an appropriate thread as this is a general bug in XBMC. I tested the latest intrepid SVN PPA (r18324) and r18359 vdpau branch and both have the same behavior.

--Nick
(This post was last modified: 2009-03-09 23:56 by mr.b.)
find quote
kross Offline
Junior Member
Posts: 15
Joined: Jan 2009
Reputation: 0
Post: #10
s7mx1 Wrote:I am having onbord Geforce 8100. 1080p play fine in full screen, resolution was set at default native resolution 1680x1050. The only thing that I am worried about switching to full screen native resolution is when "sync to v blank" is enabled, the gui will be sluggish, while disabled, the CPU usage will be 100% on one core. But none of them are affecting video playback.

I am using XBMC-vdpau r18331, nvidia 182.37, ubuntu 8.10. CPU runs at 1.8G constantly.

Maybe you need to tweak your xorg.conf a bit.
Code:
Option         "TwinView" "0"
    Option         "UseEvents" "true"
    Option "NvAGP" "1"
    Option         "Coolbits" "1"
    Option "NoLogo" "True"
    Option "PixmapCacheSize" "1000000"
    Option "AllowSHMPixmaps" "0"
    Option "TripleBuffer" "True"
    Option "RenderAccel" "True"
they are in the screen section.

Have you tried to force the CPU run at the max frequency possible and see what will happen, since the memory bandwidth of your system is bit limited (only single channel)?

I added your options to my xorg.conf. It didn't help. I also set the cpu freq to max, as seen:

Code:
htpc:~# cpufreq-set -g performance
htpc:~# cpufreq-info
cpufrequtils 004: cpufreq-info (C) Dominik Brodowski 2004-2006
Report errors and bugs to cpufreq@lists.linux.org.uk, please.
analyzing CPU 0:
  driver: powernow-k8
  CPUs which need to switch frequency at the same time: 0 1
  hardware limits: 1000 MHz - 2.60 GHz
  available frequency steps: 2.60 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz
  available cpufreq governors: userspace, powersave, ondemand, conservative, performance
  current policy: frequency should be within 1.80 GHz and 2.60 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 2.60 GHz (asserted by call to hardware).
  cpufreq stats: 2.60 GHz:6.27%, 2.40 GHz:0.17%, 2.20 GHz:0.14%, 2.00 GHz:0.17%, 1.80 GHz:93.25%, 1000 MHz:0.00%  (2508)
analyzing CPU 1:
  driver: powernow-k8
  CPUs which need to switch frequency at the same time: 0 1
  hardware limits: 1000 MHz - 2.60 GHz
  available frequency steps: 2.60 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz
  available cpufreq governors: userspace, powersave, ondemand, conservative, performance
  current policy: frequency should be within 1.80 GHz and 2.60 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 2.60 GHz (asserted by call to hardware).
  cpufreq stats: 2.60 GHz:6.27%, 2.40 GHz:0.17%, 2.20 GHz:0.14%, 2.00 GHz:0.17%, 1.80 GHz:93.25%, 1000 MHz:0.00%  (2508)
find quote
kross Offline
Junior Member
Posts: 15
Joined: Jan 2009
Reputation: 0
Post: #11
mr.b Wrote:@Allanmar, @kross

I have an Asus M3n78-VM -- geforce 8200 based mobo and experience the same thing. It should be noted, however, that this is not specific to the VDPAU branch so this discussion should be taken to an appropriate thread as this is a general bug in XBMC. I tested the latest intrepid SVN PPA (r18324) and r18359 vdpau branch and both have the same behavior.

--Nick

Ah, interesting! motd2k is off the hook then! Big Grin

Thanks,
-- Kevin
find quote
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #12
mr.b Wrote:@Allanmar, @kross

I have an Asus M3n78-VM -- geforce 8200 based mobo and experience the same thing. It should be noted, however, that this is not specific to the VDPAU branch so this discussion should be taken to an appropriate thread as this is a general bug in XBMC. I tested the latest intrepid SVN PPA (r18324) and r18359 vdpau branch and both have the same behavior.

--Nick
Well I'm not really sure if that is good or bad news. lol. I was wondering that but my processor struggles with 1080p without vdpau so I wasnt sure.

EDIT: Found this: http://trac.xbmc.org/ticket/4884 sounds similar, unfortunately its 6 months old. The workaround there also dosnt help.
EDIT2: Actually I remember a few posts back motd2k said he had basically the same hardware running and wasn't having any problems. So I wonder whats different with our setup(s)?
(This post was last modified: 2009-03-10 02:54 by AllanMar.)
find quote
xnappo Offline
Fan
Posts: 351
Joined: Oct 2008
Reputation: 10
Post: #13
Allan/Kross/Mr.B

What video are you using to test 1080p? Killa?

xnappo
find quote
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #14
xnappo Wrote:Allan/Kross/Mr.B

What video are you using to test 1080p? Killa?

xnappo
I have several x264 movies, some VC1, and I've tried killa too. All have the same result, also killa performs worst when im having the problems (no surprise). All will play fine as long as xbmc is not started in 1080p

Im thinking mayb this has something to do with XRandR and setting modes? In my xbmc.log i have:
When starting in auto
22:15:25 T:3880572896 M:109060096 INFO: XRANDR: /home/allan/xbmc-vdpau/XBMC/xbmc-xrandr --output default --mode 0x10d
22:15:26 T:3880572896 M:105652224 DEBUG: Constructing surface 1280x720, shared=(nil), fullscreen=0

And theres no more mention of that again when i change to 1080p manually (will still play fine)

When i start with 1080 i get this though:
22:17:42 T:2299250656 M: 87248896 WARNING: CXRandR::SetMode: found alternative mode (same hz): default mode: 0x138.
22:17:42 T:2299250656 M: 87248896 INFO: XRANDR: /home/allan/xbmc-vdpau/XBMC/xbmc-xrandr --output default --mode 0x138
22:17:42 T:2299250656 M: 71061504 DEBUG: Constructing surface 1920x1080, shared=(nil), fullscreen=0
find quote
AllanMar Offline
Member
Posts: 75
Joined: Mar 2009
Reputation: 0
Post: #15
Just out of curiosity, have you tried what I been mentioning earlier as a problem? Try starting XBMC in Auto resolution, then goto settings, change to 1080 and hit test resolution, then try playing your video
find quote
Post Reply