[MOD] Multiplex View with Video Window Mod

  Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rflores2323 Offline
Posting Freak
Posts: 1,915
Joined: Jan 2009
Reputation: 2
Post: #376
anoobie. do you know how to code this to make it a new view type? This way we can add this as a new view type to other people mods (ie hitchers) and keep all the other mods aswell.

Thanks for the update and I love your work.

ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

find quote
anoobie Offline
Skilled Skinner
Posts: 187
Joined: Aug 2006
Reputation: 17
Post: #377
rflores2323 Wrote:anoobie. do you know how to code this to make it a new view type? This way we can add this as a new view type to other people mods (ie hitchers) and keep all the other mods aswell.

Thanks for the update and I love your work.

Sorry I don't know how to make it a new view type but isn't multiplexold a view by itself. I mean it doesn't affect any other view types as far as I know.
find quote
B-Fir3 Offline
Senior Member
Posts: 118
Joined: Dec 2008
Reputation: 0
Post: #378
anoobie Wrote:Hi, I just updated mod3 to be compatible with native flagging and added a little more spacing between movie thumbs.

[Image: screenshot002sou.png]

Does Mod3 no longer have a layout with Fanart in the middle, poster on the right and extra thumbs on the left?

I still love mod3, and I'm happy with the changes. I'm just wondering about that.

These mods are excellent though.
find quote
andyblac Offline
Posting Freak
Posts: 768
Joined: Feb 2009
Reputation: 0
Post: #379
anoobie Wrote:Hey, thanks for letting me know, yeah, I'm interested. Could you post the code here? if not i'll take a look at your mod.

put this the wraplist:
Code:
<ondown>600</ondown>

and this above the scrollbar:
Code:
<control type="group" id="600">
            <control type="button" id="601">
                <visible>Skin.HasSetting(videomovies) + Skin.HasSetting(movietrailers) + !Player.Playing + [!Skin.HasSetting(multiplextvshowsinfooff) | !Skin.HasSetting(multiplexinfooff)]</visible>
                <onleft>52</onleft>
                <onright>52</onright>
                <onup>7000</onup>
                <ondown>604</ondown>
                <onfocus>PlayMedia($INFO[ListItem.Trailer],1)</onfocus>
            </control>

            <control type="button" id="602">
                <visible>Skin.HasSetting(videotv) + Skin.HasSetting(tvpreview) + !Player.Playing + [!Skin.HasSetting(multiplextvshowsinfooff) | !Skin.HasSetting(multiplexinfooff)]</visible>
                <onleft>52</onleft>
                <onright>52</onright>
                <onup>7000</onup>
                <ondown>604</ondown>
                <onfocus>PlayMedia($INFO[listitem.path]$INFO[listitem.filename],1)</onfocus>
            </control>

            <control type="button" id="603">
            <visible>[!Skin.HasSetting(movietrailers) | !Skin.HasSetting(tvpreview) + !Player.Playing] | [Skin.HasSetting(multiplextvshowsinfooff) | Skin.HasSetting(multiplexinfooff)]</visible>
            <onfocus>SetFocus(60)</onfocus>
            </control>
        </control>

        <control type="button" id="604">
            <texturefocus>-</texturefocus>
            <texturenofocus>-</texturenofocus>
            <onleft>52</onleft>
            <onright>52</onright>
            <onup>7000</onup>
            <ondown>600</ondown>
            <onfocus>PlayerControl(stop)</onfocus>
        </control>

then just make sure that controls that your visible have this in them.
Code:
Control.HasFocus(600) | Control.HasFocus(601) | Control.HasFocus(602) | Control.HasFocus(603) | Control.HasFocus(604)

but by all means have a look around my mod Big Grin
find quote
B-Fir3 Offline
Senior Member
Posts: 118
Joined: Dec 2008
Reputation: 0
Post: #380
My DivX movies aren't showing up with the DivX flag in Mod3. Any ideas?
find quote
neurosis13 Offline
Fan
Posts: 609
Joined: Jan 2009
Reputation: 18
Location: Germany
Post: #381
B-Fir3 Wrote:Does Mod3 no longer have a layout with Fanart in the middle, poster on the right and extra thumbs on the left?

I still love mod3, and I'm happy with the changes. I'm just wondering about that.

These mods are excellent though.

yes please anoobie, 2 extrathumbs on the left would be sweeet.
Big Grin
find quote
Rabid_Child Offline
Junior Member
Posts: 39
Joined: Oct 2007
Reputation: 0
Post: #382
I'm interested in your stop trailer solution and I think I followed everything up to this point. Where exactly do these go? There are various places where Control.HasFocus .... exists.

andyblac Wrote:then just make sure that controls that your visible have this in them.
Code:
Control.HasFocus(600) | Control.HasFocus(601) | Control.HasFocus(602) | Control.HasFocus(603) | Control.HasFocus(604)

but by all means have a look around my mod Big Grin

On another note. I've read every post of this thread, took awhile. It seems people are saying the issue with the movie not playing full screen was solved and hardcoded into the mod but it doesn't work for me. It is minimized for the trailer and the movie. What am I overlooking here?

I d/led the newest XBMC build as of 07-19-2009. And I got the github version of djh Aeon today too. Now here may lie an issue. At first I was using the mod paired with Hitchers Aeon mod. So I thought maybe that was causing the issue. But with the original djh Aeon I can't select legacy dark. So I guess I'm wondering... Will this not work with the Hitcher mod? and Isn't the newest djh Aeon supposed to have this option?

After reading so many posts its very likely I missed the answer somewhere. Please enlighten me.

Thanks
find quote
neurosis13 Offline
Fan
Posts: 609
Joined: Jan 2009
Reputation: 18
Location: Germany
Post: #383
regarding MOD2 which is a very powerful view, when there is a white fanart you cant read the Top where the moviename and plot outline is.

[Image: screenshot003xpi.png]

When trailer window opens it would also be nice if the edges where rounded so the design doesnt collide with the other fields down below.

Very nice view annobie, well done!
find quote
andyblac Offline
Posting Freak
Posts: 768
Joined: Feb 2009
Reputation: 0
Post: #384
Rabid_Child Wrote:I'm interested in your stop trailer solution and I think I followed everything up to this point. Where exactly do these go? There are various places where Control.HasFocus .... exists.

anywhere that has Control.HasFocus(60) add the other to it

Rabid_Child Wrote:On another note. I've read every post of this thread, took awhile. It seems people are saying the issue with the movie not playing full screen was solved and hardcoded into the mod but it doesn't work for me. It is minimized for the trailer and the movie. What am I overlooking here?

I d/led the newest XBMC build as of 07-19-2009. And I got the github version of djh Aeon today too. Now here may lie an issue. At first I was using the mod paired with Hitchers Aeon mod. So I thought maybe that was causing the issue. But with the original djh Aeon I can't select legacy dark. So I guess I'm wondering... Will this not work with the Hitcher mod? and Isn't the newest djh Aeon supposed to have this option?

After reading so many posts its very likely I missed the answer somewhere. Please enlighten me.

Thanks

i dont know what is in this mod so, but in the early days a hack was used to get the trailer to play minimised maby that is still present it seem to recall it was something to do with the advancedsettings.xlm fle
find quote
Pete_London Offline
Senior Member
Posts: 196
Joined: May 2009
Reputation: 1
Post: #385
I'm finding when I scroll through movies, the new thumbs appearing on the screen take their time... they stay blank until I pause, or until the first blank one gets to the centre.

Anybody else get this? When I do pause to let them catch upm they load at the same time as the fanart.

Cheers,

Pete
find quote
Rabid_Child Offline
Junior Member
Posts: 39
Joined: Oct 2007
Reputation: 0
Post: #386
andyblac Wrote:i dont know what is in this mod so, but in the early days a hack was used to get the trailer to play minimised maby that is still present it seem to recall it was something to do with the advancedsettings.xlm fle

Thanks, I feel stupid now but the xml file was the problem. One of the early postings said you needed it so I made it. Then forgot it was there. It was why my movies wouldn't launch full screen. Got rid of that command and it all worked fine.

As to the stop trailer, I haven't had an chance to mess with that yet. But I'll give it a whirl as soon as I can.
find quote
andyblac Offline
Posting Freak
Posts: 768
Joined: Feb 2009
Reputation: 0
Post: #387
Rabid_Child Wrote:Thanks, I feel stupid now but the xml file was the problem. One of the early postings said you needed it so I made it. Then forgot it was there. It was why my movies wouldn't launch full screen. Got rid of that command and it all worked fine.

As to the stop trailer, I haven't had an chance to mess with that yet. But I'll give it a whirl as soon as I can.

if you get lost, download my mod and look around the multiplex file and MyVideoNav, to see what i have done.
find quote
jorisdekloris Offline
Junior Member
Posts: 14
Joined: May 2009
Reputation: 0
Post: #388
I'm trying to get the trailers to play in this mod. It show the "Press down to view Trailer' but when i press down nothing happens.

Does it matter I use PLEX who lagges behind and isnt nearly a newest release from XBMC?
find quote
hikaricore Offline
Posting Freak
Posts: 1,515
Joined: Dec 2008
Reputation: 0
Location: Tuesday
Post: #389
jorisdekloris Wrote:I'm trying to get the trailers to play in this mod. It show the "Press down to view Trailer' but when i press down nothing happens.

Does it matter I use PLEX who lagges behind and isnt nearly a newest release from XBMC?

I'd imagine that is exactly the problem. Tongue
find quote
jorisdekloris Offline
Junior Member
Posts: 14
Joined: May 2009
Reputation: 0
Post: #390
Me 2 but i want to exclude it. Do you know this for sure?
find quote
Post Reply