How can i switch to 1980x1080@24Hz

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dannybullit Offline
Senior Member
Posts: 114
Joined: Dec 2008
Reputation: 0
Location: Sweden
Post: #16
Thanks!

I will try this tonight. I´ve seen posts one avsforum that my V can handle 24p with a mild "judder". Still it´s probably better to use 1080p@60.

btw, is it always better to use 1080p@60 instead of 1080p@50?
I´mthinking that it could depend on what material you are playing.

Br, Daniel
find quote
boba23 Offline
Fan
Posts: 360
Joined: Nov 2007
Reputation: 0
Post: #17
Folks, you do NOT need a modeline in xorg.conf. My Panasonic 46PZ80 is happily running 24p 1080p without a modeline. Played around with it first but it wasn't needed.
Make sure you have:

Option "DynamicTwinView" "false"

in your xorg.conf among your "Screen" section options.
Then enable "adjust refresh rate" in xbmc, settings, video, player ....
And enjoy 24p output. Check the output refresh rate while playing a video with pressing "z" on your keyboard ....

Edit: and make sure xrandr is available on your linux installation. XBMC will use it to auto adjust refresh rates.

boba

Antec Black Fusion 430, Gigabyte GA-73PVM-S2H, NVIDIA 9400GT 1GB - passive, Intel E8400 @ 3ghz C0 Stepping, 2x 1024MB DDR2-667, Samsung DVD-ROM - Ubuntu Lucid Beta2 AMD64, XBMC switching between Camelot and SVN.
find quote
dannybullit Offline
Senior Member
Posts: 114
Joined: Dec 2008
Reputation: 0
Location: Sweden
Post: #18
boba23 Wrote:Folks, you do NOT need a modeline in xorg.conf. My Panasonic 46PZ80 is happily running 24p 1080p without a modeline. Played around with it first but it wasn't needed.
Make sure you have:

Option "DynamicTwinView" "false"

in your xorg.conf among your "Screen" section options.
Then enable "adjust refresh rate" in xbmc, settings, video, player ....
And enjoy 24p output. Check the output refresh rate while playing a video with pressing "z" on your keyboard ....

Edit: and make sure xrandr is available on your linux installation. XBMC will use it to auto adjust refresh rates.

boba

This is exciting information! I will try this.

But could it be so that it´s working for you because "xbmc live" can detect your TV´s EDID properly?

Is Option "DynamicTwinView" "false" the only thing that you have modified in xorg.conf, what about vertical and horizontal refresh rates?

Br, Daniel
(This post was last modified: 2009-05-18 16:44 by dannybullit.)
find quote
boba23 Offline
Fan
Posts: 360
Joined: Nov 2007
Reputation: 0
Post: #19
I can post my xorg.conf tonight when I am home. I am not using xbmc live but the latest svn revision ... not sure if I disabled EDID in xorg.conf or not. Will let you know.

boba

Antec Black Fusion 430, Gigabyte GA-73PVM-S2H, NVIDIA 9400GT 1GB - passive, Intel E8400 @ 3ghz C0 Stepping, 2x 1024MB DDR2-667, Samsung DVD-ROM - Ubuntu Lucid Beta2 AMD64, XBMC switching between Camelot and SVN.
find quote
dev/x Offline
Junior Member
Posts: 6
Joined: May 2009
Reputation: 0
Post: #20
boba23 Wrote:Folks, you do NOT need a modeline in xorg.conf. My Panasonic 46PZ80 is happily running 24p 1080p without a modeline. Played around with it first but it wasn't needed.
Make sure you have:

Option "DynamicTwinView" "false"

in your xorg.conf among your "Screen" section options.
Then enable "adjust refresh rate" in xbmc, settings, video, player ....
And enjoy 24p output. Check the output refresh rate while playing a video with pressing "z" on your keyboard ....

Edit: and make sure xrandr is available on your linux installation. XBMC will use it to auto adjust refresh rates.

boba


thanxx man that was the trick for me !!!!
find quote
cejstrup Offline
Senior Member
Posts: 168
Joined: Mar 2008
Reputation: 0
Post: #21
The problem with my TV is that the EDID information it returns is wrong. Based on EDID it's only capable of 720p even though it's a full HD capable TV. I guess it's not a general problem with Panasonic TVs,but for me the solution is to disable EDID and use a modeline Smile
find quote
boba23 Offline
Fan
Posts: 360
Joined: Nov 2007
Reputation: 0
Post: #22
I am really not sure, didn't find the time yday night to look into it, but I may even have EDID disabled in xorg.conf. You sure EDID is the only way that the gfx driver gets resolution information about the display?

boba

Antec Black Fusion 430, Gigabyte GA-73PVM-S2H, NVIDIA 9400GT 1GB - passive, Intel E8400 @ 3ghz C0 Stepping, 2x 1024MB DDR2-667, Samsung DVD-ROM - Ubuntu Lucid Beta2 AMD64, XBMC switching between Camelot and SVN.
find quote
owagner Offline
Junior Member
Posts: 34
Joined: Nov 2008
Reputation: 0
Post: #23
boba23 Wrote:Folks, you do NOT need a modeline in xorg.conf.

Interesting. I always had the issue, at least with the 180.x drivers, that if I only disabled DynamicTwinview, xrandr (both the Ubuntu one and the one included in XBMC), the NVidia drivers would pretend to have switched to 24p (or 50 Hz, for that matter), show 24p or 50 Hz in xrandr, but still output 60 Hz (as shown in the info screen on my TV).

I only managed to get rid of this effect using custom modelines. "AllowNon60HzDFPModes" etc. also didn't help.

I had this with two Samsung TVs; an older LE 46F86 and a newer LE40A616. Both offer 24p and 50 Hz via EDID.

I haven't checked wether this is still the case with 182+ drivers.

Best Regards,
Olli
find quote
boba23 Offline
Fan
Posts: 360
Joined: Nov 2007
Reputation: 0
Post: #24
Ehm, why would 24p mean 50hz? 50hz would in my eyes be PAL output meaning 25fps in the source.
24p source has 24fps framerate, meaning the tv should either display 24hz or 48hz for that matter, but for sure not 50hz.

boba

Antec Black Fusion 430, Gigabyte GA-73PVM-S2H, NVIDIA 9400GT 1GB - passive, Intel E8400 @ 3ghz C0 Stepping, 2x 1024MB DDR2-667, Samsung DVD-ROM - Ubuntu Lucid Beta2 AMD64, XBMC switching between Camelot and SVN.
find quote
dannybullit Offline
Senior Member
Posts: 114
Joined: Dec 2008
Reputation: 0
Location: Sweden
Post: #25
boba23 Wrote:Folks, you do NOT need a modeline in xorg.conf. My Panasonic 46PZ80 is happily running 24p 1080p without a modeline. Played around with it first but it wasn't needed.
Make sure you have:

Option "DynamicTwinView" "false"

in your xorg.conf among your "Screen" section options.
Then enable "adjust refresh rate" in xbmc, settings, video, player ....
And enjoy 24p output. Check the output refresh rate while playing a video with pressing "z" on your keyboard ....

Edit: and make sure xrandr is available on your linux installation. XBMC will use it to auto adjust refresh rates.

boba

Hi, I´ve added Option "DynamicTwinView" "false" & enablel "adjust refresh rate".

Pressing Z indicates that the output is 24Hz when playing a bluray and 50Hz for a NTSC/PAL DVD-R. strange, it should be 50 for ntsc and 60 for pal.

However, my panasonic indicates tha it´s recieving a 1080i signal.

I want it to be 1080p since the movies I have are in 1080p.

Have you edited xorg.conf so HorizSync (minimum and maximum) & VertRefresh (minimum and maximum) matches your TV?

Thanks
find quote
dannybullit Offline
Senior Member
Posts: 114
Joined: Dec 2008
Reputation: 0
Location: Sweden
Post: #26
cejstrup Wrote:IMPORTANT: I've had several issues with nvidia drivers and/or xbmc version. So this is my tested and verified combination what works without issues for me:

* xbmc live 9.04
* nvifia drivers 180.44



Your TV will not be able to do 24p ,look at your vertical refresh it's 59-86. So it's similar to my TV which means you can get 1080p@60.

Try my xorg.conf with the above combination of xbmc live and nvidia driver.Your TV has the same data as mine,so can't see why it shouldn't work out.Use the whole section from my conf file :

Section "Monitor"
Identifier "panasonic"
ModelName "Generated by Another Modeline Calculator"
HorizSync 31-69
VertRefresh 59-86
DisplaySize 929 523 # Aspect ratio 1.778:1
# Custom modes
Modeline "1920x1080" 148.5 1920 1980 2028 2200 1080 1084 1089 1125
EndSection # panasonic


Section "Device"
Identifier "nVidia Corporation NV43 [GeForce 6200]"
Driver "nvidia"
Option "TripleBuffer" "True"
Option "Composite" "False"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV43 [GeForce 6200]"
Option "TVStandard" "HD1080p"
Option "ConnectedMonitor" "DFP"
Option "UseEdid" "False"
Option "ExactModeTimingsDVI" "True"
Option "ModeValidation" "AllowNon60HzDFPModes, NoEdidModes, NoEdidDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck,NoMaxSizeCheck,
NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck"
Monitor "panasonic"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1920x1080"
EndSubSection
EndSection

Hi,

Can I really use your modeline? I probably have another max pixelclock, even if we have the same spec on the tv the modeline should be different for me?

I tried the same modeline calculator and got a completely different modeline:
Modeline "1920x1080" 85.96 1920 2056 2248 2536 1080 1081 1084 1149 interlace # 85.96 MHz, 33.90 kHz, 59.00 Hz field rate

One thing that I dont understand with the modeline calculator is why its adding interlaced in the end of the modeline. I want p for progressive output.

Br, Daniel
(This post was last modified: 2009-05-19 23:11 by dannybullit.)
find quote
sparkyhall Offline
Junior Member
Posts: 22
Joined: Apr 2009
Reputation: 0
Post: #27
dannybullit Wrote:I tried the same modeline calculator and got a completely different modeline:
Modeline "1920x1080" 85.96 1920 2056 2248 2536 1080 1081 1084 1149 interlace # 85.96 MHz, 33.90 kHz, 59.00 Hz field rate

One thing that I dont understand with the modeline calculator is why its adding interlaced in the end of the modeline. I want p for progressive output.

Br, Daniel

It's because in the modeline above you have specified 85.96MHz pixel rate so it is impossible to achieve 1080p@59Hz (1920x1080x59 = 122.35MHz), you need and even higher pixel rate to allow for overscan and back porch timing etc.

Chris
find quote
boba23 Offline
Fan
Posts: 360
Joined: Nov 2007
Reputation: 0
Post: #28
Quote:Pressing Z indicates that the output is 24Hz when playing a bluray and 50Hz for a NTSC/PAL DVD-R. strange, it should be 50 for ntsc and 60 for pal.

Eh? I have no clue where you got that info from?

PAL Standard = 25 FPS / 50 hz refresh rate

NTSC Standard = 30 FPS (or to be more exact 29.97) / 60 hz refresh rate

24hz Output from XBMC for 24p material is what you want. Then your TV must support 24p playback, meaning it must be able to do 2:2 or 3:3 pulldown thus converting the 24 hz signal to 48 or 72 hz, since displaying native 24hz would suck big time :-) That's what 24p means in your TVs specs, it can handle 24p input and convert it to 48 or 72hz for proper display on your TV set.

Quote:However, my panasonic indicates tha it´s recieving a 1080i signal.

I have no clue why you get a interlaced signal. I wouldn't even know how to get 1080i out to my Panasonic right now, besides manually selecting it in XBMC settings. With my standard settings, output is always 1080p and that's what my TV shows me when pressing the Info key on its remote.

Quote:I want it to be 1080p since the movies I have are in 1080p.

hehe, yea that's what you need.

Quote:Have you edited xorg.conf so HorizSync (minimum and maximum) & VertRefresh (minimum and maximum) matches your TV?

No I didn't edit anything regarding frequency or modeline, here's my current xorg.conf:

-----------
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Thu Apr 16 17:18:41 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
# Option "RegistryDwords" "PowerMizerLevel=0x3"
Option "ExactModeTimingsDVI" "True"
Option "UseEDIDFreqs" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEvents" "True"
Option "TripleBuffer" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "False"
Option "RenderAccel" "True"
Option "DPI" "100 x 100"
Option "DynamicTwinView" "False"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Antec Black Fusion 430, Gigabyte GA-73PVM-S2H, NVIDIA 9400GT 1GB - passive, Intel E8400 @ 3ghz C0 Stepping, 2x 1024MB DDR2-667, Samsung DVD-ROM - Ubuntu Lucid Beta2 AMD64, XBMC switching between Camelot and SVN.
find quote
cejstrup Offline
Senior Member
Posts: 168
Joined: Mar 2008
Reputation: 0
Post: #29
dannybullit Wrote:Hi,

Can I really use your modeline? I probably have another max pixelclock, even if we have the same spec on the tv the modeline should be different for me?

I tried the same modeline calculator and got a completely different modeline:
Modeline "1920x1080" 85.96 1920 2056 2248 2536 1080 1081 1084 1149 interlace # 85.96 MHz, 33.90 kHz, 59.00 Hz field rate

One thing that I dont understand with the modeline calculator is why its adding interlaced in the end of the modeline. I want p for progressive output.

Br, Daniel

Yes,you should be able to use my modeline without making changes. Your pixelclock is probably close if not the same as on my gfx card.

Try it out and see how it goes. Remember to use the whole section to make sure EDID is disabled is case your TV is lying about it's abilities like mine Smile
find quote
DeanM3 Offline
Donor
Posts: 86
Joined: Mar 2008
Reputation: 0
Location: nyc
Post: #30
I was hoping someone could help me here.

I have a Pioneer Kuro 42" ( PDP-4280HD ), and I am having serious issues getting XBMC to run properly. This display does not output usable EDID, and although it supports 1080p and 1080p/24, the only way I can get this resolution is through the Nvidia Display Manager in Gnome.

What is the best way of achieving this? Should I add custom modelines to xorg.conf, or should I use xrandr and the method described in this thread by disabling TwinView.

Also if anyone has a similar Pioneer Plasma Kuro, I would greatly appreciate it if you could post your configs.

thanks
find quote
Post Reply