[FIX] Contextual fanart in music list view

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Leeuw Offline
Senior Member
Posts: 274
Joined: Apr 2009
Reputation: 0
Post: #1
This code will turn on custom music fanart in list view (which seems to be disabled as a bug in the latest updates to Auriga):

Open 720p\MyMusicNav.xml and look for the following code:
Code:
<control type="largeimage" id="102">
    <include>FullscreenDimensions</include>
        <visible>!Control.IsVisible(103) + Control.IsVisible(57) + !IsEmpty(listitem.property(fanart_image)) + !Skin.HasSetting(nomusicfanart)</visible>
    <fadetime>400</fadetime>
    <texture>$INFO[listitem.property(fanart_image)]</texture>
    <include>Animation_FanartFade</include>
  </control>

  <control type="largeimage" id="103">
    <include>FullscreenDimensions</include>
        <visible>Control.IsVisible(57) + !IsEmpty(container.property(fanart_image)) + !Skin.HasSetting(nomusicfanart)</visible>
    <fadetime>400</fadetime>
    <texture>$INFO[container.property(fanart_image)]</texture>
    <include>Animation_FanartFade</include>
  </control>

And replace it with this:
Code:
    <control type="largeimage" id="102">
        <include>FullscreenDimensions</include>
        <visible>!Control.IsVisible(103) + [Control.IsVisible(57) | Control.IsVisible(50)] + !IsEmpty(listitem.property(fanart_image)) + !Skin.HasSetting(nomusicfanart)</visible>
        <fadetime>400</fadetime>
        <texture>$INFO[listitem.property(fanart_image)]</texture>
        <include>Animation_FanartFade</include>
    </control>

    <control type="largeimage" id="103">
        <include>FullscreenDimensions</include>
        <visible>[Control.IsVisible(57) | Control.IsVisible(50)] + !IsEmpty(container.property(fanart_image)) + !Skin.HasSetting(nomusicfanart)</visible>
        <fadetime>400</fadetime>
        <texture>$INFO[container.property(fanart_image)]</texture>
        <include>Animation_FanartFade</include>
    </control>

Enjoy!
find quote
Hitcher Online
Skilled Skinner
Posts: 11,174
Joined: Aug 2007
Reputation: 105
Location: Eastleigh, UK
Post: #2
Nice one, thanks.
find quote
thesoulhacker Offline
Senior Member
Posts: 103
Joined: Apr 2009
Reputation: 0
Post: #3
Hitcher Wrote:Nice one, thanks.

Hitcher, did you include this fix into your mod on Git?
can't seem to get it to work...
find quote