[RELEASE] Video Copilot (Video) Plugin

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #1
videocopilot.net
requested by @kricker

How to download my plugins!
(This post was last modified: 2012-05-27 09:40 by queeup.)
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #2
Thank you so much for this. I'm testing the speed of this new version now.

It is fast. The first time I launched it after grabbing it from the repo installer, it freaked out XBMC. The list was blank and when I went back to the list of plugins it jumped around erratically. I restarted XBMC and then it worked fine.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2009-06-09 04:29 by kricker.)
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #3
pls update v1.0.1. I made a mistake on url line Sad sry
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #4
Updated, and all seems fine so far.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #5
When I add your repo to the resources folder of the SVN repo installer it is causing the SVN Repo installer to hang when doing an update check.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #6
Hmm. What is your distro? Yesterday i update Copilot. Delete and re add to repo. Could you try again. If problem exist pls post xbmc.log too.
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #7
I am using windows. I can add the plugin fine. It just whenever I choose update from the repo plugin.

log at failure:
Code:
10:59:50 T:3188 M:4294967295   DEBUG: [SVN Repo Installer]: parseCategory() cat=plugins/video/Video Copilot
10:59:50 T:3188 M:4294967295  NOTICE: Traceback (most recent call last):
10:59:50 T:3188 M:4294967295  NOTICE:   File "D:\HTPC\Xbmc\plugins\programs\SVN Repo Installer\installerAPI\xbmcplugin_update.py", line 309, in showUpdates
10:59:50 T:3188 M:4294967295  NOTICE:     trunk_url = re.search('(/trunk.*?)$', svn_url, re.IGNORECASE).group(1)
10:59:50 T:3188 M:4294967295  NOTICE: AttributeError: 'NoneType' object has no attribute 'group'
10:59:50 T:3188 M:4294967295    INFO: Loading skin file: DialogOK.xml
10:59:50 T:3188 M:4294967295   DEBUG: Load DialogOK.xml: 8.40ms

Read this before using these builds.
XBMC win32 SVN builds
Changelog
(This post was last modified: 2009-06-18 17:02 by kricker.)
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #8
It's fine here on Linux. Sry but i should ask, are you use latest SVN Installer? If you have time pls past xbmc.log too.
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #9
I maintain 3rd party releases for Windows, so I'm always at a bleeding edge build. Log at trouble area posted above.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #10
Actually my plugins not in /trunk , its in /branches

Code:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<repo>
    <url>http://queeup.googlecode.com/svn</url>
    <root>/branches</root>
    <structure name="plugins" noffset="-2" install="" ioffset="2" voffset="0" />
</repo>

Pls paste all log to xbmc.pastbin I want to look maybe some other problems cause that error.

and if you have time come to irc channel
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #11
queeup Wrote:Actually my plugins not in /trunk , its in /branches

Code:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<repo>
    <url>http://queeup.googlecode.com/svn</url>
    <root>/branches</root>
    <structure name="plugins" noffset="-2" install="" ioffset="2" voffset="0" />
</repo>

Pls paste all log to xbmc.pastbin I want to look maybe some other problems cause that error.

and if you have time come to irc channel
That is the .xml I have in the repositories folder.

Full log.

I've never done irc, but you can IM me if possible.

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #12
Okay I am on #xbmc-linux using mibbit I think Smile

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #13
Ok. I think i found problem. You use my old plugin.

Code:
# plugin constants
__plugin__ = "Video Copilot"
__author__ = "queeup"
__url__ = "http://code.google.com/p/queeup/"
__svn_url__ = "http://queeup.googlecode.com/svn/trunk/plugins/video/Video%20Copilot/"
__version__ = "r3"

Am i right? version r3?

Maybe this __svn_url__ confuse SVN Installer. Please delete Video Copilot directory and download again with SVN Installer.
find quote
kricker Offline
Team-XBMC QA Specialist
Posts: 3,520
Joined: Apr 2004
Reputation: 20
Location: Knoxville, TN
Post: #14
Bingo!

I thought I had updated it earlier....hmmm. Oh well. Thank again!

Read this before using these builds.
XBMC win32 SVN builds
Changelog
find quote
queeup Offline
Posting Freak
Posts: 765
Joined: Feb 2009
Reputation: 16
Post: #15
No prob. Sry for irc. I forget to look irc lol
find quote
Post Reply