Port XBMC to BSD based operating-system like FreeBSD, PC-BSD, or NetBSD?

  Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
taliz Offline
Junior Member
Posts: 7
Joined: Dec 2011
Reputation: 0
Post: #31
ELSE Wrote:Hello! I have already installed XBMC on FreeBSD 8.1#amd64 with ASRock A330ION motherboard from port. It works!!! It has a lot of depences and more of them I installed by pkg_add.
Also I have already installed nvidia driver for ION chipset.
I have no any problem during installation.
Now I use startx and do xbmc to launch it. I have some problems:
1. Russian charsets are not work (I am using an english now)
2. Cannot get sound through HDMI port. Video works as well.
3. I cannot find any way to get USB MCE Remote Control (based on Philips receiver) works.

Now I am testing it. If any problem will be appeared I will post here.

I have the exact same problems with my setup, a Zotac 330 ION board. I think the solution to the remote problem may be here: http://forums.freebsd.org/showthread.php?t=28262

I gave up before I saw that though because not getting the audio to work via hdmi is a show stopper for me. I put many hours on trying to get it to work, but it just want possible. I'm going to try a clean 9.0 install and the latest nvidia drivers shortly but I doubt that will help.
find quote
Mur77 Offline
Junior Member
Posts: 5
Joined: Aug 2011
Reputation: 0
Post: #32
davilla Wrote:HAHAH, you have plenty on ponies there.


23:00:13 T:731910464 M:3111014400 ERROR: GLX: Same window as before, refreshing context

That's 1st thing I notice. gdb it and see where it's spending time. I'd suspect atomics or pthread sleeps not working.

Hi,
I have the same string in the xbmc.log. (Installed on FreeBSD 8.1)
CPU is not too slow - Intel Celeron 2.0 GHz (Live XBMC works well with such CPU). I'm not familiar with gdb, so how can I find the problem?
Thanks!
find quote
Mur77 Offline
Junior Member
Posts: 5
Joined: Aug 2011
Reputation: 0
Post: #33
ELSE Wrote:Hello! I have already installed XBMC on FreeBSD 8.1#amd64 with ASRock A330ION motherboard from port. It works!!! It has a lot of depences and more of them I installed by pkg_add.
Also I have already installed nvidia driver for ION chipset.
I have no any problem during installation.
Now I use startx and do xbmc to launch it. I have some problems:
1. Russian charsets are not work (I am using an english now)
2. Cannot get sound through HDMI port. Video works as well.
3. I cannot find any way to get USB MCE Remote Control (based on Philips receiver) works.

Now I am testing it. If any problem will be appeared I will post here.

Hi! Can you present yours xorg.conf and xorg.log files?
Thanks!
find quote
Post Reply