[MOD] xTV SAF (Spouse Acceptance Factor)

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Martijn Offline
Team Kodi
Posts: 11,946
Joined: Jul 2011
Reputation: 170
Location: Dawn of time
Post: #631
For your Eden version see that you have logo-downloader as dependency:

Just for you to know
Logo Downloader (the end of it as we know it)

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #632
Martijn Wrote:For your Eden version see that you have logo-downloader as dependency:

Just for you to know
Logo Downloader (the end of it as we know it)
Martijn,

Again thank you, known issue. If you check out my development branch for v1.2.0 you will see I don't have any dependency's as I got burnt by them early in Eden cycle. Will fix for release with Artwork downloader instead of Logo downloader and redo the various other dependencies at the same time.

Thank you for your work on Artwork downloader, it's much appreciated by me and the other skinners.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
Martijn Offline
Team Kodi
Posts: 11,946
Joined: Jul 2011
Reputation: 170
Location: Dawn of time
Post: #633
I see Smile
I just downloaded .zip file so i saw it was there so i thought i'd just mention it.

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #634
lipo Wrote:yup fanart still dont appear
full screen visualization also dont appear

on the postive note clearart works
waiting for next svnLaugh
Lipo,

Thanks mate, will work on these issues for next push to SVN. That clearart that you are talking about video or music? Have not made a big deal of it but have included support for music artist logos on the music visualisation screen. Try placing an apropriate logo.png file in your artists directory and see what you think.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #635
Martijn Wrote:I see Smile
I just downloaded .zip file so i saw it was there so i thought i'd just mention it.
Mate, feel free to point these things out. I use this thread as a todo list, so it does not hurt to have someone point things out here. You might find that the skin is much more stable from the Passion repo as the posted .zip file was from much, much earlier in the skins (and Eden's) development cycle. Also have a number of nice features (horizontal home menu for one) that is available from my dev SVN.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
lipo Offline
Senior Member
Posts: 188
Joined: Jul 2009
Reputation: 0
Location: Indonesia
Post: #636
been using the latest svn xbox ver 437
[Image: 825bba170244860.jpg]
the profiles setting is back but still no game saves setting

fanart still dont appear
[Image: fb88b0166112793.jpg]
heres the debug log started when i enable fanart oprtion
http://pastebin.com/zDqiLRxE

setting button on music full screen osd dont work, no visualization buttonseeking indicator stuck at begining, & visualization no show on full screen
[Image: d1d7e3166149426.jpg]
[Image: bbe127166113274.jpg]
http://pastebin.com/V2dGUXMu

blank video menu
[Image: 4a477b166394730.jpg]
http://pastebin.com/6KgiKJem

no player osd for music & vid
http://pastebin.com/RHPVSXFT
(This post was last modified: 2012-01-17 16:14 by lipo.)
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #637
lipo Wrote:been using the latest svn xbox ver 437
[Image: 825bba170244860.jpg]
the profiles setting is back but still no game saves setting
So, in previous versions of the skin there was a entry in the settings menu called "Game Saves"? I have never used any games on the XBox, so I would never of even registered if this was there. Will take a further look.
Quote:fanart still dont appear

heres the debug log started when i enable fanart oprtion
http://pastebin.com/zDqiLRxE

setting button on music full screen osd dont work, no visualization buttonseeking indicator stuck at begining, & visualization no show on full screen


http://pastebin.com/V2dGUXMu
Ok all of these things appear in your log files, Again will take yet another look and see what I can do.
Quote:blank video menu

http://pastebin.com/6KgiKJem
Nothing in the log, but I now think I know what I have done here, hopefully should not be too hard to fix.
Quote:no player osd for music & vid
http://pastebin.com/RHPVSXFT
Not sure what you are saying is wrong here (nothing showing in the log file at any rate). Can you not bring up the OSD with the "appropriate" menu key?

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #638
wyrm Wrote:Javalsu,

I believe this is an issue with the AppleTV (gen2) build of XBMC. Try using a latter build of XBMC should probably help this. Go check the FAQ's for AppleTV in this forum should confirm if this is your issue.

Wyrm (xTV-SAF)

Javalsu Wrote:Great job, I (and my wife) love this skin.

One question though. I have XBMC installed on my laptop as well as my apple tv. When I set the fan art as the background on my laptop, the fan art's opacity is lower, and and the background color comes through. Which makes the menu much more readable.

However, when I set it on the atv, the fan art is at 100% opacity and it may wash out the text in the menus.

Am I missing a setting?
Javalsu,

Just push an update to my SVN that fixes this issue, will be available tomorrow morning on Passion repo. Good new is that by changing how I show the fanart the opacity is now handled correctly, bad new is that skin is now a little slower than it was before. Not so bad news is that the skin is now showing about the same frame rate as Quartz and Confluence.

Let me know if you spot any other issues like this one.
Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
joselbcn33 Offline
Junior Member
Posts: 46
Joined: Feb 2010
Reputation: 0
Post: #639
Hi there , just congratulations for the new version!!!

Just a small question. I have realized that in this new one there is no option to install themes ( I love the blue one in the old version). How can I install new themes?
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #640
joselbcn33 Wrote:Hi there , just congratulations for the new version!!!

Just a small question. I have realized that in this new one there is no option to install themes ( I love the blue one in the old version). How can I install new themes?
joselbcn33,

Install themes is still supported by the skin, but is about to be removed as 1 - Nobody seemed to care about the function as witness the lack of response in the other stickied thread in this sub forum. 2 - It is the major reason why the skin is not in the official repo.

For the moment navigate to settings/skin settings/general and scroll down to 2nd last item of that sub menu.

At some point this option will be removed (but hopefully it will have a easyish way to add it back for those that really want it). If you visit my googlecode page you will see under the source tab the browse option. Click that and then click the 'trunk' tab in the file list. Drill down from there and I'm sure you can figure it out.

Note .xml file needs to go into the colors sub directory of the skin and the .xbt file needs to go into the media sub directory.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
joselbcn33 Offline
Junior Member
Posts: 46
Joined: Feb 2010
Reputation: 0
Post: #641
thank you for your reply Wyrm. Now I was able to change the theme to my favourite xdtv. Also one more question. I have made some custom buttoms on the default (vertical) home menu through the skin settings.
settings>skin>custom>video addon> script>Youtube (ok)
But when i try to add icecast through settings>skin>custom>music>music addon>script (select icecast or any of the online radios i have install) >label (the name of the addon or anyone you want for the buttom), the custom buttom does not appear. Do I miss something?
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #642
joselbcn33 Wrote:thank you for your reply Wyrm. Now I was able to change the theme to my favourite xdtv. Also one more question. I have made some custom buttoms on the default (vertical) home menu through the skin settings.
settings>skin>custom>video addon> script>Youtube (ok)
But when i try to add icecast through settings>skin>custom>music>music addon>script (select icecast or any of the online radios i have install) >label (the name of the addon or anyone you want for the buttom), the custom buttom does not appear. Do I miss something?
joselbcn33,

Thank you for the feedback. So very often I never hear back if my advise/suggestions where any help.

Could you provide a screenshot of what you see, as I think I know what you are trying to tell me, but not sure. Note that if you don't provide ALL of the required info (script location, name) I don't show anything as it's ALL required.

I will check the code and make sure I have not messed anything up. Also I am about to push a large number of minor bug fixes to the SVN (stuff found on the XBox build), so you might see this fixed soon if I find anything.

Wyrm (xTV-SAF)

OK, just checked and can confirm there is a problem with music addons in vertical home menu (horizontal home menu works fine), will find and fix problem and push to SVN ASAP.

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
(This post was last modified: 2012-03-08 05:37 by wyrm.)
find quote
wyrm Offline
Skilled Skinner
Posts: 970
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #643
wyrm Wrote:OK, just checked and can confirm there is a problem with music addons in vertical home menu (horizontal home menu works fine), will find and fix problem and push to SVN ASAP.
OK, have confirmed and fixed problem (problem is wyrm is a tool). Just pushed to SVN, so will appear in Passion repo tomorrow morning Paris time. Also now pushing a number of other fixes, so tomorrows repo update will have a few fixes.

Wyrm (xTV-SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
joselbcn33 Offline
Junior Member
Posts: 46
Joined: Feb 2010
Reputation: 0
Post: #644
thank you so much !!!!Laugh
find quote
pierocol Offline
Junior Member
Posts: 29
Joined: Nov 2009
Reputation: 0
Post: #645
I am an aficionado of this skin. I just upgraded to Eden and to the last version of the skin. One little problem, maybe irrelevant. The covers of CD's are stretched in the coverflow and wall views. Can it be changed? I use an LCD tv as the display, with 1360x 768 as the resolution. Thanks
find quote
Post Reply