[MOD] xTV SAF (Spouse Acceptance Factor)

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #46
Hi everyone,

just finished the translations, so new update has been posted. Only available via megaupload at the moment, will get bramm77 to add to the xbox skin project in a day or so (just in case there are any bugs I missed).

See first post of the thread for details (download link available there)

Enjoy, it's late and I'm off to bed, if there is anything that I forgot to mention, I will fix tomorrow morning.

Wyrm (xTV SAF)
(This post was last modified: 2009-11-30 03:54 by wyrm.)
find quote
batrad Offline
Member
Posts: 95
Joined: Jun 2007
Reputation: 0
Post: #47
Have the Sept Build of XBMC from t3ch's site

Looks great in Wrap mode and makes it easy to select the options I want to show up on the home screen..

Some of the options come up in Red as unsupported on this Skin

Also all the entries for the Settings Page (File Manager ..) don't come up (get blank entries, looks like the font is set to the background color..)

Will post more later...
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #48
batrad Wrote:Have the Sept Build of XBMC from t3ch's site

Looks great in Wrap mode and makes it easy to select the options I want to show up on the home screen..

Some of the options come up in Red as unsupported on this Skin

Also all the entries for the Settings Page (File Manager ..) don't come up (get blank entries, looks like the font is set to the background color..)

Will post more later...

batrad,

thank you for downloading the latest release of the skin (you would appear to be the only one).

The options that appear in red make use of special:// file addresses, and so will not run on XBMC builds from before about June. Since the most common complaint was that some menu items where not working (and the solution was to update XBMC), I have included this to remind people that they need to update. Having said this, there is a small bug in how I implemented this. At Startup, I check to see if you can run a script, if you can a FLAG is set and I then check in the menus for that flag. If there is no flag, I disable the affected menu items. Only problem is that you do not run startup if you just change from another skin to xTV SAF. So, just shutdown and restart XBMC and problem should go away.

As to the File manager issue, could you please turn on 'DEBUG' mode and try using the menu item again. Then post the log file to an online file host and post the link here. I will try to sort out what the problem is. Also, there is a new menu item under the settings menu called support. Could you please post the details listed on that screen here so that I know what you are running.

Thanks again
Wyrm (xTV SAF)
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #49
Announcing a new release, version 0.82. See [post=417901] Announcement post[/post] of this thread for release details and download links. If I do not find any more minor bugs, will get bram77 to upload this release to xbox-skins.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
(This post was last modified: 2009-12-03 03:49 by wyrm.)
find quote
skepti Offline
Junior Member
Posts: 26
Joined: Jul 2009
Reputation: 0
Post: #50
Very nice release. Some bugs i found:

1. the scroll bar shows no string so i cant see how many sites there are

2. the osd buttons are not good to see maybe you can change the color

3. the handling of the osd has changed ? my keyboard works not right.

e.g. i have to move the mouse before i can use right/left buttons to switch
between the osd controlbuttons (play,stop,...)
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #51
Ok, as promised, have now included a few screenshots on the Announcement post of this thread. I have also updated the Announcement post to make things a little easier to read. As you can see the xbox-skins link is for an older version, I will be asking bram77 to update to the latest build when I'm happy I have got the worst of the bugs.

In future I will use megaupload for posting the very latest (and probably buggy) version and xbox-skins for the stable versions.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #52
skepti Wrote:Very nice release. Some bugs i found:

1. the scroll bar shows no string so i cant see how many sites there are

2. the osd buttons are not good to see maybe you can change the color

3. the handling of the osd has changed ? my keyboard works not right.

e.g. i have to move the mouse before i can use right/left buttons to switch
between the osd controlbuttons (play,stop,...)

skepti,

See the bottom of this post for details of a helpful way to post problems. It's just my crystal ball is in the shop to be fixed, so I will just have to guess. Anyway, I'm assuming that you are not using an xbox, correct?

1. What view are you using, because I think I know what you are trying to tell me, but no idea which part of the skin to go looking in.
2. Yes, I agree with you, the OSD buttons are not good. I don't like my current layout (although it is better than the last version) and the buttons still need work.
3. Will look at it, but I'm pretty sure you are not using the current version(0.82), so things may have changed and it may not be an issue.

Go take a look at the Announcement post of this thread for screenshots and links to the very latest version of the skin. Thank you for the feedback, I have been looking at the skin so much lately, that I could be looking right at a problem and not even notice it. Many eyes make it much easier to find bugs.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
batrad Offline
Member
Posts: 95
Joined: Jun 2007
Reputation: 0
Post: #53
Am running XBMC-SVN_2009-11-08_rev24421-T3CH
Downloaded the new XTV_SAF from the first post, will try and post debug logs with this build if I still have any issues

Thanks
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #54
batrad Wrote:Have the Sept Build of XBMC from t3ch's site

Looks great in Wrap mode and makes it easy to select the options I want to show up on the home screen..

Some of the options come up in Red as unsupported on this Skin

Also all the entries for the Settings Page (File Manager ..) don't come up (get blank entries, looks like the font is set to the background color..)

Will post more later...

batrad,

Yep, found the problem. Have renumbered all of the strings and some of the xml files missed being updated, thus they where not pointing to the correct strings. Fixed on download message, but if you don't wish to re-download the skin again, download this small file : http://www.megaupload.com/?d=ZCESZLR7 and extract it to the skin PAL directory. It contains eight (8) files that you need to overwrite.

Sorry about that, as previously mentioned I have been staring at this skin for too long, so unfortunately a couple of little bugs have crept thru.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
(This post was last modified: 2009-12-04 10:14 by wyrm.)
find quote
skepti Offline
Junior Member
Posts: 26
Joined: Jul 2009
Reputation: 0
Post: #55
Yes, i am using PC version 9.04.1 r2020672. The problem with the scroll bar is
in all views. I only see the blue line without a horizontal black stripe. So the bar isn't useful for me.

Sorry for my English learned in a german school.Wink
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #56
skepti Wrote:Yes, i am using PC version 9.04.1 r2020672. The problem with the scroll bar is
in all views. I only see the blue line without a horizontal black stripe. So the bar isn't useful for me.

Sorry for my English learned in a german school.Wink

skepti,

that's OK, sorry about my English, learned in an Australian school Wink.

First major problem that I see is that most of the skin will not work with 9.04.1. You will need to be running an SVN version of XBMC from after July, any version after r21000 will be fine. Google 'XBMC nightly build' should take you somewhere that you can get hold of an appropriate build.

As to the scrollbar, I have changed it from about version 0.80 of xTV SAF. What you 'should' see is a grey bar with either a dark grey (not selected) or a blue bar (when it is selected) overlayed on the grey bar.

Try downloading the latest version of xTV SAF (version 0.82, download link in first post of this thread) and a newer version of XBMC and see how you get on.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
skepti Offline
Junior Member
Posts: 26
Joined: Jul 2009
Reputation: 0
Post: #57
Quote:that's OK, sorry about my English, learned in an Australian school .
LaughLaughLaugh

The problem with the scrollbar is that the grey is away wen i unselected the bar. I want to see the grey line or better red if possible ever. Not only wen select. So i can see how many sites there are. The newest mac beta is the same. Not only in my old version. Thx for your replay.
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #58
skepti Wrote:LaughLaughLaugh

The problem with the scrollbar is that the grey is away wen i unselected the bar. I want to see the grey line or better red if possible ever. Not only wen select. So i can see how many sites there are. The newest mac beta is the same. Not only in my old version. Thx for your replay.

skepti,

Sorry Tiger, while that seems to be pretty good English (and not too bad 'Strine' ), I still have no idea what you are trying to tell me. Could you please PM me and I will give you an e-mail address that you could send me a screen shot to show what the problem is.

Have you seen the screen shots from the download announcement post. There are one or two showing the new scrollbar, is this not what you see?

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
skepti Offline
Junior Member
Posts: 26
Joined: Jul 2009
Reputation: 0
Post: #59
hello wyrm,

Your screens looks other then mine. Here are my screens from beta1. I use the user-configs from my last stable. Is that the problem ?
(This post was last modified: 2009-12-10 11:58 by skepti.)
find quote
wyrm Offline
Skilled Skinner
Posts: 980
Joined: Nov 2007
Reputation: 10
Location: Perth, Australia (GMT +8)
Post: #60
skepti Wrote:hello wyrm,

Your screens looks other then mine. Here are my screens from beta1. I use the user-configs from my last stable. Is that the problem ?

http://my.opera.com/skepti/albums/show.dml?id=1246131

skepti,

Sorry that is my Bad. I uploaded the skin zip file and then discovered that I had not included the correct textures.xpr file, so uploaded the correct file. You must have just got really 'lucky' and downloaded the dud zip file in the 10 minutes that it was on megaupload. Solution - re-download the file in the megaupload link from the announcement post and you will then have the correct scrollbar images.

Sorry if anyone else got caught by this, but megaupload is not telling me if anyone is downloading the files any more (or just no one is downloading them).

I have submitted the skin to bram77 to include in xbmc-xbox-skin, but has not made its way thru the system just yet, no doubt will happen soon.

Wyrm (xTV SAF)

When postings problems, please provide build details. If required a FULL debug log can now be submitted from the skin in settings->appearance->skin->settings>support. Ensure debug logging has been set in settings->system->debugging (or from the support menu). FAQ's located at :- http://wiki.xbmc.org/index.php?title=Add-on:XTV-SAF
find quote
Post Reply