[WINDOWS] Internal Directshow Based Player - USERS support thread

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #46
blinkseb Wrote:You know, uou just need to register on the wiki and you can freely edit the article Wink It's so long to do, and I'm really busy at this time (school project, exams, dsplayer, ...). So, if you want to add something, you're more than welcome Laugh

I'm not even going to ask, because it will just make me feel really old and useless Big Grin But good luck mate hope your really successful. Nod
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #47
macmel Wrote:Glad to see that this thread is being linked from the DSPlayer thread. And thanks for considering my suggestions Big Grin

They were both worthy of consideration and inclusion, otherwise they woulda got ditched Laugh
find
uncertainty Offline
Fan
Posts: 499
Joined: Jun 2009
Reputation: 0
Location: Jersey
Post: #48
BTW Seb just compiled rev 29166 and it resolved my issue with mkv+subtitles under ffdshow...Keep in mind it now defaults to mpcvideodec so I made a dsfilterconfig.xml in my userdata folder with just the changes to have ffdshow the decoder.

http://dsplayer.passion-xbmc.org/Dsplaye...166-dx.exe
(This post was last modified: 2010-04-10 23:14 by uncertainty.)
find
oldpainless Offline
Fan
Posts: 524
Joined: Jan 2010
Reputation: 12
Post: #49
steelman1991 Wrote:They were both worthy of consideration and inclusion, otherwise they woulda got ditched Laugh

Steelman - you have a PM mate.

K
find
oldpainless Offline
Fan
Posts: 524
Joined: Jan 2010
Reputation: 12
Post: #50
uncertainty Wrote:BTW Seb just compiled rev 29166 and it resolved my issue with mkv+subtitles under ffdshow...Keep in mind it now defaults to mpcvideodec so I made a dsfilterconfig.xml in my userdata folder with just the changes to have ffdshow the decoder.

http://dsplayer.passion-xbmc.org/Dsplaye...166-dx.exe

Nice one uncertainty - thanks....hopefully a couple of folks will check it out and post their findings..

K
(This post was last modified: 2010-04-10 23:32 by oldpainless.)
find
sergiocos Offline
Posting Freak
Posts: 809
Joined: Jul 2009
Reputation: 5
Location: Bucharest, Romania
Post: #51
works fine so far (the latest build), but i noticed that all my external subtitles (*.srt) are showed using an ITALIC font. Anyone got the same behavior? There's an easy fix for this?
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #52
sergiocos Wrote:works fine so far (the latest build), but i noticed that all my external subtitles (*.srt) are showed using an ITALIC font. Anyone got the same behavior? There's an easy fix for this?

Welcome sergiocos - what build (I only ask because it looks like Seb has released a newer version this evening) - Also check your subtitle settings - go to System\Video\Subtitles and ensure that the style isn't set to Italics.
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #53
uncertainty Wrote:BTW Seb just compiled rev 29166 and it resolved my issue with mkv+subtitles under ffdshow...Keep in mind it now defaults to mpcvideodec so I made a dsfilterconfig.xml in my userdata folder with just the changes to have ffdshow the decoder.

http://dsplayer.passion-xbmc.org/Dsplaye...166-dx.exe

Welcome to the Pleasuredome uncertainty, thanks for the link, though I'm really scared to take the plunge - my current set-up is working so well at the moment - oh well in for a penny in for a pound as the saying goes.
find
sergiocos Offline
Posting Freak
Posts: 809
Joined: Jul 2009
Reputation: 5
Location: Bucharest, Romania
Post: #54
steelman1991 Wrote:Welcome sergiocos - what build (I only ask because it looks like Seb has released a newer version this evening) - Also check your subtitle settings - go to System\Video\Subtitles and ensure that the style isn't set to Italics.
Yes, I'm using the tonight build.
Everything it' set ok, embeded subs aren't italics, dvdplayer shows subtitles with normal font, only dsplayer gave me italics subtitles.

LE: and the subtitles dissapear after aprox 15 min.... damn, i thought this was fixed.
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #55
sergiocos Wrote:Yes, I'm using the tonight build.
Everything it' set ok, embeded subs aren't italics, dvdplayer shows subtitles with normal font, only dsplayer gave me italics subtitles.

LE: and the subtitles dissapear after aprox 15 min.... damn, i thought this was fixed.

Yep can confirm the italics issue in tonights build, never had the issue of disappearing subs. Will report the italics subs to Seb.

Disappearing Subs - not sure whether this was addressed, Seb indicated that it may have been working but I can't find any confirmation other than this post http://forum.xbmc.org/showthread.php?tid=61355&page=268 #2671. Noticed that you have commented on it on a few occasions but I can't find any definitive solution, either in the thread or changelogs. Might be worth drawing it to Seb's attention, with a debug log, though you would obviously have to run the movie until the subs disappeared, to provide a meaningful log for Seb.
(This post was last modified: 2010-04-11 00:59 by steelman1991.)
find
marc.aronson Offline
Junior Member
Posts: 34
Joined: Nov 2008
Reputation: 3
Location: California
Post: #56
oldpainless Wrote:Hi Marc,

Subs are very nearly fixed (seb if nearly there)....it kinda works for some types of subs in the latest build (as of today), but still has some issues...

I'd hold tight until the next build....hopefully not long to wait (although Seb has some exams at the mo).

K

Looks like a new build is out (29166). I'm using the powerdvd codec trick you documented -- is there anything special I need to do to get it to decode the subitltes that are embedded in "over the air" transmissions? Thanks!
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #57
marc.aronson Wrote:Looks like a new build is out (29166). I'm using the powerdvd codec trick you documented -- is there anything special I need to do to get it to decode the subitltes that are embedded in "over the air" transmissions? Thanks!

Marc - unless I'm totally off track here, embedded subs are exactly that embedded directly into the video. Therefore nothing is required to be carried out to activiate those subtitles, they will be played as part of the video. If, however you are referring to seperate subtitle files included in an mkv container then the only thing you need to do is ensure that subtitles are enabled from the XBMC OSD accessible when playing a video.
find
blinkseb Offline
Team-XBMC Developer
Posts: 599
Joined: Jan 2010
Reputation: 3
Location: Lyon, France
Post: #58
sergiocos Wrote:works fine so far (the latest build), but i noticed that all my external subtitles (*.srt) are showed using an ITALIC font. Anyone got the same behavior? There's an easy fix for this?

Only external subtitles? That's fun lol, I'm sure that if I wanted to do that, I wouldn't have succeeded!

I'll look at it.

Otherwise, you can look here for new build http://forum.xbmc.org/showthread.php?tid=70436 , there's a changelog and I keep it updated (approx. a 5min delay between the upload and the post edit Wink) when a new build is out

AndroIRC - Best IRC client for Android!
find
oldpainless Offline
Fan
Posts: 524
Joined: Jan 2010
Reputation: 12
Post: #59
blinkseb Wrote:Only external subtitles? That's fun lol, I'm sure that if I wanted to do that, I wouldn't have succeeded!

I'll look at it.

Otherwise, you can look here for new build http://forum.xbmc.org/showthread.php?tid=70436 , there's a changelog and I keep it updated (approx. a 5min delay between the upload and the post edit Wink) when a new build is out

Seb,

Looks like internal subs too are shown in italics (for me anyway)...not a big issue. Have not tested if they disapear yet tho.

K
find
steelman1991 Offline
Donor
Posts: 2,439
Joined: Jan 2009
Reputation: 10
Post: #60
oldpainless Wrote:Seb,

Looks like internal subs too are shown in italics (for me anyway)...not a big issue. Have not tested if they disapear yet tho.

K

Internal/External ? what's the difference, or am I just not up to date with the techno-terms.

Or are we talking about embedded or not embedded - just curious. All my sub files .srt are placed within an mkv container - are they classed as internal or external? Just curious so I know Confused
find
Thread Closed