CApplication::Create() failed

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
PaulC2K Offline
Member
Posts: 51
Joined: Apr 2011
Reputation: 0
Location: Manchester, UK
Post: #31
I've just installed XBMC 10.1, and the nightly, and have this error message too.

Its a fresh install of WHS, basic drivers (network, sound, gfx - intel o/b) and TeamViewer for remote access, although i have kb/m access and closing TViewer has no influence.
I've also got DirectX installed and all the windows updates it can locate at the moment inc Visual C++ etc

Quote:17:17:05 T:3044 M:2387591168 NOTICE: -----------------------------------------------------------------------
17:17:05 T:3044 M:2387574784 NOTICE: Starting XBMC, Platform: Windows XP Professional build 2600. Built on Apr 19 2011 (Git:20110419-d951ea1, compiler 1600)
17:17:05 T:3044 M:2387574784 NOTICE: Intel® Core™2 CPU 6400 @ 2.13GHz
17:17:05 T:3044 M:2387574784 NOTICE: Desktop Resolution: 1360x768 32Bit at 60Hz
17:17:05 T:3044 M:2387574784 NOTICE: Running with administrator rights
17:17:05 T:3044 M:2387574784 NOTICE: Aero is disabled
17:17:05 T:3044 M:2387574784 NOTICE: special://xbmc/ is mapped to: C:\Program Files\XBMC
17:17:05 T:3044 M:2387574784 NOTICE: special://xbmcbin/ is mapped to: C:\Program Files\XBMC
17:17:05 T:3044 M:2387574784 NOTICE: special://masterprofile/ is mapped to: C:\Documents and Settings\Administrator\Application Data\XBMC\userdata
17:17:05 T:3044 M:2387574784 NOTICE: special://home/ is mapped to: C:\Documents and Settings\Administrator\Application Data\XBMC
17:17:05 T:3044 M:2387574784 NOTICE: special://temp/ is mapped to: C:\Documents and Settings\Administrator\Application Data\XBMC\cache
17:17:05 T:3044 M:2387574784 NOTICE: The executable running is: C:\Program Files\XBMC\XBMC.exe
17:17:05 T:3044 M:2387574784 NOTICE: Log File is located: C:\Documents and Settings\Administrator\Application Data\XBMC\xbmc.log
17:17:05 T:3044 M:2387574784 NOTICE: -----------------------------------------------------------------------
17:17:05 T:3044 M:2387550208 NOTICE: Setup SDL
17:17:05 T:3044 M:2387378176 NOTICE: Found screen: Plug and Play Monitor on Intel® Q965/Q963 Express Chipset Family, adapter 0.
17:17:05 T:3044 M:2387374080 NOTICE: Primary mode: 1360x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 640x480 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 800x600 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 1024x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 1280x600 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 1280x720 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 1280x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387165184 NOTICE: Additional mode: 1360x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387161088 NOTICE: Additional mode: 480x640 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 640x480 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 480x640 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 600x800 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 800x600 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 600x800 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 768x1024 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 1024x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 768x1024 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 600x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 1280x600 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 600x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 720x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 1280x720 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 720x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 768x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 1280x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 768x1280 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 768x1360 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387156992 NOTICE: Additional mode: 1360x768 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387152896 NOTICE: Additional mode: 768x1360 @ 60.00 - Full Screen
17:17:05 T:3044 M:2387148800 NOTICE: load settings...
17:17:05 T:3044 M:2387202048 NOTICE: special://profile/ is mapped to: special://masterprofile/
17:17:05 T:3044 M:2387189760 NOTICE: loading special://masterprofile/guisettings.xml
17:17:05 T:3044 M:2384584704 NOTICE: Getting hardware information now...
17:17:05 T:3044 M:2384576512 NOTICE: Checking resolution 12
17:17:05 T:3044 M:2384060416 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
17:17:05 T:3044 M:2384015360 NOTICE: Loaded playercorefactory configuration
17:17:05 T:3044 M:2384003072 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
17:17:05 T:3044 M:2384003072 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
17:17:05 T:3044 M:2383994880 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
17:17:05 T:3044 M:2383994880 NOTICE: Default DVD Player: dvdplayer
17:17:05 T:3044 M:2383994880 NOTICE: Default Video Player: dvdplayer
17:17:05 T:3044 M:2383994880 NOTICE: Default Audio Player: paplayer
17:17:05 T:3044 M:2385756160 NOTICE: Loading media sources from special://masterprofile/sources.xml
17:17:05 T:3044 M:2382491648 WARNING: CRenderSystemDX::CreateDevice - initial wanted device config failed
17:17:05 T:3044 M:2382442496 ERROR: CRenderSystemDX::CreateDevice - unable to create a device. 8876086A - D3DERR_NOTAVAILABLE (Not available)
17:17:05 T:3044 M:2382442496 FATAL: CApplication::Create: Unable to init rendering system
17:17:06 T:4072 M:2378723328 ERROR: CRemoteControl::Connect - failed to connect

I've re-ran the Dx web setup file, it says a current or newer version is already installed, so its happy. But that sure does look like a DirectX/Direct3D error.

WHS was only installed in the early hours of this morning, and this is more or less a trial run. I just want to see everything in action on existing hardware first, and if all goes to plan then i'll start buying the hardware needed for what i want. As i only have 30 days before WHS wants activating i could do with getting everything running asap and living with it for a couple of weeks before taking the plunge.

I've no issue with giving anyone the TeamViewer details to take a look, so if it'd help i can PM it.

Thanks,

PaulC2K
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #32
In the Display settings, if you click the Advanced button there's a tab somewhere with a "hardware acceleration" slider on it. Check that this is set to Maximum.

If this makes no difference it might be worth running the MS DirectX installer from http://www.microsoft.com/downloads/detai...ceb6d8fa8d

JR
find quote
PaulC2K Offline
Member
Posts: 51
Joined: Apr 2011
Reputation: 0
Location: Manchester, UK
Post: #33
jhsrennie Wrote:In the Display settings, if you click the Advanced button there's a tab somewhere with a "hardware acceleration" slider on it. Check that this is set to Maximum.

If this makes no difference it might be worth running the MS DirectX installer from http://www.microsoft.com/downloads/detai...ceb6d8fa8d

JR

That did it, just the slider. how bizarre.

Thank you very much for your help, its much appreciated.
find quote
Homerboy Offline
Member
Posts: 54
Joined: Dec 2005
Reputation: 0
Post: #34
jhsrennie Wrote:In the Display settings, if you click the Advanced button there's a tab somewhere with a "hardware acceleration" slider on it. Check that this is set to Maximum.

If this makes no difference it might be worth running the MS DirectX installer from http://www.microsoft.com/downloads/detai...ceb6d8fa8d

JR

For the record, I was getting the same error msg as the OP. Googled it up. Got this thread. The above slider fixed it.

Thanks everyone!
find quote
mrblaqwood Offline
Junior Member
Posts: 2
Joined: Jun 2011
Reputation: 0
Post: #35
Action the below first while directly logged onto the machine you want to rdp to
=================================================

In the "video output" of the "System" section set the display mode for "windowed" and turn ON the option for "use full screen window..." and hit backspace and go back into the video output section and make sure the resolution and display mode are NOT CHANGEABLE.

Once you did that rdp to your box and see if you can access xbmc

I will advise you of this, you can change it back to full screen mode but once you restart your machine it will fail again once you know you setup XBMC 100% change it back to full screen mode, sit back and chill out!!


Host Name: ******
OS Name: Microsoft Windows 7 ROG (N)
OS Version: 6.1.7600 N/A Build 7600
OS Manufacturer: *******
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: Windows User
Registered Organization:
Product ID: ********
Original Install Date: ********
System Boot Time: 18/06/2011, 23:37:09
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: M68M-S2P
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
[01]: AMD64 Family 16 Model 6 Stepping 3 AuthenticAMD ~3000 Mhz
BIOS Version: Award Software International, Inc. F5, 02/07/2010
Windows Directory: C:\Windows
System Directory: C:\Windows\system32
Boot Device: \Device\HarddiskVolume1
System Locale: en-gb;English (United Kingdom)
Input Locale: en-gb;English (United Kingdom)
Time Zone: (UTC) Dublin, Edinburgh, Lisbon, London
Total Physical Memory: 4,094 MB
Available Physical Memory: 3,421 MB
Virtual Memory: Max Size: 8,187 MB
Virtual Memory: Available: 7,485 MB
Virtual Memory: In Use: 702 MB
Page File Location(s): F:\pagefile.sys
Domain: ****
Logon Server: ****
Hotfix(s): 115 Hotfix(s) Installed.
find quote
mrblaqwood Offline
Junior Member
Posts: 2
Joined: Jun 2011
Reputation: 0
Post: #36
Yep I'm 100% with the above, just deleted the settings for the profile and got the failure again, did the steps above = working via rdp
find quote
fGrs Offline
Junior Member
Posts: 3
Joined: Jun 2011
Reputation: 0
Post: #37
Hi, all! Iv been reading abit in this thread since I had the same problem.
I just setup a Windows server 2003 32bit and wanted to run xbmc on it.
I installed the ATI driver from xp manually and it worked like a charm.
When I tried to start xbmc I got the error message this thread is all about.
So I did what this guide said: http://www.wikihow.com/Install-ATI-Graph...64-Edition , just to try... and it made it work. Running flawless now =) hope this fixes the issue for other ppl.
(yes I know its for ATI cards and X64, but worked for me on X32)
find quote
lewisc Offline
Junior Member
Posts: 45
Joined: Aug 2010
Reputation: 0
Post: #38
I also had this problem on my Windows 7 machine. I found that having Shairport4W (to enable iPhone airplay) running locked the XBMC event log and stopped XBMC being able to write to it. Closing Shairport4W enabled XBMC to open as usual.

[Image: widget]
find quote
Spyhop Offline
Junior Member
Posts: 30
Joined: Sep 2011
Reputation: 0
Post: #39
I know this thread is a bit old, but if anyone's curious, I solved this problem.
If you have Active Background enabled in your skin settings, XBMC will flip out if you try to RDP, since RDP won't do hardware rendering. I found this thread because I was having the same issue, and I didn't connect the dots right away that I had just enabled that option.

Though you'd like to know.
find quote
Brad P Offline
Donor
Posts: 194
Joined: May 2009
Reputation: 0
Post: #40
I had Logmein on my machine and it was apparently messing with DirectX. Even just having it running in the background seemed to mess up DirectX. I was constantly having to uninstall my ATI drivers and reinstall them just to get DirectX working again as I didn't suspect Logmein. This went on for months, off and on. Anywho, one day I decided to uninstall LMI has I had a gut feeling and I never had another DirectX problem again. That was about a year ago and DirectX has not randomly disabled on me and therefore, no XBMC issues.

Desktop / HTPC: Win7 x86, Cooler Master Storm Sniper Black Edition case, Asus P5Q Pro, Intel C2Q q8300, Asus 4550HD, Asus 3450HD, CM M 1000w, 4GB GSkill, 2x Seagate 7200.11 1TB Raid 1, Samsung SSD 240GB, SPM393 Raid Controller w/ 1 Samsung 2TB, 4 1.5TB for a 7.2TB media volume

XBMC as of May 2014 - 12.2 Frodo
find quote
hellbringer Offline
Junior Member
Posts: 1
Joined: Jan 2010
Reputation: 0
Post: #41
I had an issue when I starten XBMC no video was displayed (black screen) I know it had to be some sort of video issue, when I turned down video acceleration this error came up. (that led me to this topic)
When I checked the logfile I got a 'D3DERR_OUTOFVIDEOMEMORY (Out of video memory)'
The solution was simple: I run a Asus Pundit-R as a second mediacenter, it has an integrated ATI Radeon 9100 IGP, in the BIOS I apparently turned the shared video memory down to 8MB.
Changing this to at least 32MB solved the problem. (Advanced -> Northbridge -> UDA Frame Buffer Size)
(This post was last modified: 2011-10-22 20:26 by hellbringer.)
find quote
xtlc Offline
Junior Member
Posts: 10
Joined: Nov 2011
Reputation: 0
Post: #42
I can also confirm the RMD causes the error - on win7 x64. I also do think, that the problem which causes the error is windows trying to play the sound on the remote pc instead of the one xbmc is installed.
find quote
pib@pib-et-flo Offline
Junior Member
Posts: 2
Joined: Nov 2011
Reputation: 0
Location: Geneva
Post: #43
Having the same problem. I cannot start XBMC. My problems is the same as Echild and its append to me since I have change my Graphic Card. Impossible to start XBMC. The message appear : CApplication::Create() failed - check log file and that it is writeable

my config is :

------------------
System Information
------------------
Time of this report: 11/12/2011, 18:24:53
Machine name: QUADCORE-PC
Operating System: Windows 7 Professionnel 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Language: French (Regional Setting: French)
System Manufacturer: System manufacturer
System Model: P5K SE
BIOS: BIOS Date: 04/01/08 18:43:14 Ver: 08.00.12
Processor: Intel® Core™2 Quad CPU @ 2.40GHz (4 CPUs), ~2.4GHz
Memory: 2048MB RAM
Available OS Memory: 2048MB RAM
Page File: 1344MB used, 2749MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode


---------------
Display Devices
---------------
Card name: NVIDIA GeForce GTX 560
Manufacturer: NVIDIA
Chip type: GeForce GTX 560
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_1201&SUBSYS_83B51043&REV_A1
Display Memory: 1760 MB
Dedicated Memory: 993 MB
Shared Memory: 767 MB
Current Mode: 1920 x 1200 (32 bit) (59Hz)
Monitor Name: Moniteur Plug-and-Play générique


and the log of XBMC is :

18:21:16 T:3976 M:1137516544 NOTICE: -----------------------------------------------------------------------
18:21:16 T:3976 M:1137590272 NOTICE: Starting XBMC, Platform: Windows 7, 32-bit Service Pack 1 build 7601. Built on Mar 8 2011 (Git:e9e9099, compiler 1500)
18:21:16 T:3976 M:1137569792 NOTICE: Intel® Core™2 Quad CPU @ 2.40GHz

......



18:21:16 T:3976 M:1137524736 NOTICE: Setup SDL
18:21:16 T:3976 M:1136680960 NOTICE: Found screen: Moniteur Plug-and-Play générique on NVIDIA GeForce GTX 560, adapter 0.
18:21:16 T:3976 M:1136066560 NOTICE: Additional mode: 1600x1024 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136066560 NOTICE: Additional mode: 1600x1024 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136091136 NOTICE: Additional mode: 1600x1024 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136078848 NOTICE: Additional mode: 1600x1024 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136082944 NOTICE: Additional mode: 1600x1024 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136074752 NOTICE: Additional mode: 1600x1024 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136074752 NOTICE: Additional mode: 1600x1200 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136062464 NOTICE: Additional mode: 1680x1050 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136054272 NOTICE: Additional mode: 1680x1050 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136062464 NOTICE: Additional mode: 1768x992 @ 25.00i - Full Screen
18:21:16 T:3976 M:1136058368 NOTICE: Previous line repeats 2 times.
18:21:16 T:3976 M:1136058368 NOTICE: Additional mode: 1768x992 @ 30.00i - Full Screen
18:21:16 T:3976 M:1136054272 NOTICE: Previous line repeats 2 times.
18:21:16 T:3976 M:1136054272 NOTICE: Additional mode: 1768x992 @ 29.97i - Full Screen
18:21:16 T:3976 M:1136066560 NOTICE: Previous line repeats 2 times.
18:21:16 T:3976 M:1136066560 NOTICE: Additional mode: 1920x1080 @ 30.00i - Full Screen
18:21:16 T:3976 M:1136070656 NOTICE: Additional mode: 1920x1080 @ 29.97i - Full Screen
18:21:16 T:3976 M:1136062464 NOTICE: Additional mode: 1920x1080 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136054272 NOTICE: Additional mode: 1920x1080 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136066560 NOTICE: Additional mode: 1920x1080 @ 25.00i - Full Screen
18:21:16 T:3976 M:1136054272 NOTICE: Additional mode: 1920x1080 @ 50.00 - Full Screen
18:21:16 T:3976 M:1136062464 NOTICE: Additional mode: 1920x1200 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136074752 NOTICE: Additional mode: 1920x1200 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136123904 NOTICE: Additional mode: 624x464 @ 59.94 - Full Screen
18:21:16 T:3976 M:1136058368 NOTICE: Additional mode: 624x464 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136062464 NOTICE: Additional mode: 1152x720 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136066560 NOTICE: Additional mode: 1440x900 @ 60.00 - Full Screen
18:21:16 T:3976 M:1136263168 NOTICE: load settings...
18:21:16 T:3976 M:1136394240 NOTICE: special://profile/ is mapped to: special://masterprofile/
18:21:16 T:3976 M:1136390144 NOTICE: loading special://masterprofile/guisettings.xml
18:21:16 T:3976 M:1136377856 ERROR: special://masterprofile/guisettings.xml, Line 0
Failed to open file
18:21:16 T:3976 M:1136377856 ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
18:21:16 T:3976 M:1136046080 NOTICE: Getting hardware information now...
18:21:16 T:3976 M:1136046080 NOTICE: Checking resolution 12
18:21:16 T:3976 M:1136041984 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
18:21:16 T:3976 M:1136029696 NOTICE: Loaded playercorefactory configuration
18:21:16 T:3976 M:1136029696 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
18:21:16 T:3976 M:1136025600 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
18:21:16 T:3976 M:1136025600 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
18:21:16 T:3976 M:1136025600 NOTICE: Default DVD Player: dvdplayer
18:21:16 T:3976 M:1136025600 NOTICE: Default Video Player: dvdplayer
18:21:16 T:3976 M:1136025600 NOTICE: Default Audio Player: paplayer
18:21:16 T:3976 M:1136164864 NOTICE: Loading media sources from special://masterprofile/sources.xml
18:21:19 T:3976 M:1134747648 FATAL: CApplication::Create: Unable to init rendering system



Is anyone able to help me!

Thanks in advance i am despited !
find quote
jhsrennie Offline
Team-XBMC Developer
Posts: 7,248
Joined: Nov 2008
Reputation: 119
Location: Chester, UK
Post: #44
The bit of the log you deleted contains information about your system that might be helpful. Can you post the whole log on http://pastebin.com/. Please don't post logs in the forum.

JR
find quote
pib@pib-et-flo Offline
Junior Member
Posts: 2
Joined: Nov 2011
Reputation: 0
Location: Geneva
Post: #45
Ok I try to do it !! ThanksWink
find quote
Post Reply