Resume seeem broken

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Hinz
Unregistered

Post: #1
Running xbmc-r32584-Dharma on Win7 64-bit.

"1.mkv"
MediaInfo: http://pastebin.ubuntu.com/475357/

"Resume at 21:00"
Video resumes at 21:07.
debug log: http://pastebin.ubuntu.com/475365/

Pressing OK on a bookmark while the video is paused causes seeking -1 sec for every press. Maybe working as intended, if so it's a strange feature. Using the bookmark works fine if the video isn't paused.
debug log: http://pastebin.ubuntu.com/475366/

"2.avi"
MediaInfo: http://pastebin.ubuntu.com/475359/

"Resume at 10.35"
Video resumes at 10:42.
debug log: http://pastebin.ubuntu.com/475367/
quote
Hinz
Unregistered

Post: #2
Resume still seems broken, using xbmc-r33778-Dharma_beta2. Though it's been broken since at least March. I thought first that the pause&bookmark error was fixed but it seems it's still broken too.
I can't find any ticket either, though the search function sucks so I guess it can be somewhere in the bug tracker.
quote
YodaEXE Offline
Fan
Posts: 455
Joined: May 2010
Reputation: 0
Post: #3
Resume works fine for me. You sure it's not something weird going on with your stuff?
find quote
Hinz
Unregistered

Post: #4
Nope, nothing wrong with my PC. The first post was done on a PC with a complete different hardware than my HTPC (easier to do the tests). I just observed yesterday on my HTPC that it was still not fixed. Resume is broken even if I do a clean XBMC install. This was confirmed a bug by a developer back in March but it seems hasn't been fixed.
quote
Hinz
Unregistered

Post: #5
I've done some more testing. It seems resume is a bit less broken then before (pre Dharma) but it still happens now and then. Back a few months ago files resumed +5-10 seconds after the bookmarked time every time.

These are tests with xbmc-r33778-Dharma_beta2.

MKV file. Trying resume at 20:15, resumes at 20:19:
http://pastebin.ca/1957749

Sama file but resume works this time:
http://pastebin.ca/1957751


AVI file. Trying to resume at 20:41, resumes at 20:48:
http://pastebin.ca/1957752

Sama file but resume works this time:
http://pastebin.ca/1957755
quote
Hinz
Unregistered

Post: #6
theuni Wrote:At the RC2 stage, we’re worried about crashers and major broken features. Surely you can understand that a bug causing resume to be off by a few seconds will get the back-seat this late in the release.
Also, you can’t just start playing every compressed video at any random frame

How would I test it then? It's not like I'm imagaining that there's a resume bug. IMO one of the big benefits of a softwareplayer compared to say a DVD-player is to have resume.
How is August late? That was Beta 1 or even before.
quote