[RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC

  Thread Rating:
  • 26 Votes - 4.27 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
SpottedDog Offline
Junior Member
Posts: 24
Joined: Aug 2012
Reputation: 0
Post: #2716
Could anyone link me to a copy of script.module.parsedom 1.5 so I can apply the patch.

ThanksTongue

edit: found it listed on Source Forge but can't see how to download it
(This post was last modified: 2012-12-31 18:05 by SpottedDog.)
find quote
debal Offline
Junior Member
Posts: 17
Joined: Jun 2012
Reputation: 0
Post: #2717
[quote='pmolson' pid='1279581' dateline='1356771993']
[quote='wmansir' pid='1279576' dateline='1356771211']
You can get the official 1.4.0 files here : http://hg.tobiasussing.dk/hgweb.cgi/comm...bae7630ede

Click on "zip" to download them in a single zip file, but the folder containing the files will be named commonxbmc-dfbae7630ede instead of script.module.parsedom.


THX man work great on windows 8 xbmc edden v11
find quote
wmansir Offline
Junior Member
Posts: 12
Joined: Aug 2011
Reputation: 0
Post: #2718
As I suspected would happen XBMC updated to 1.5 again, so manually reverting to 1.4 is a temporary fix. Thanks to dbohdan for the code fix to 1.5.
find quote
ewood1963 Offline
Junior Member
Posts: 1
Joined: Dec 2012
Reputation: 0
Post: #2719
Just learning about XBMC- I'm having similar problems with you tube and Vimeo- any ideas?
find quote
Tripp Offline
Member
Posts: 59
Joined: Aug 2012
Reputation: 0
Post: #2720
I use the Mac version of XBMC and coudn't find that exact line in the file.
find quote
enjoysummer Offline
Junior Member
Posts: 1
Joined: Dec 2012
Reputation: 0
Post: #2721
I just installed Frodo xbmc, I can't log in to youtube plug in. After input username and password, it says login failed. Any idea how to fix it? I even install xbmc on android tablet, can't log in to youtube either.
find quote
ccierider Offline
Junior Member
Posts: 2
Joined: Dec 2012
Reputation: 0
Post: #2722
I am running XBMC on a appeltv. I can not get anything like music video jukebox or youtube to work. Everytime i go to launch a video i get script failed! : script.video.youtube

Not sure what is going wrong but would love some help on this. I have updated all software and addons to latest version.

Was hoping to have MVJ working tonight for a new years party.

thanks

jm
find quote
nasimdejai2000 Offline
Junior Member
Posts: 22
Joined: Nov 2012
Reputation: 0
Post: #2723
(2012-12-31 23:00)enjoysummer Wrote:  I just installed Frodo xbmc, I can't log in to youtube plug in. After input username and password, it says login failed. Any idea how to fix it? I even install xbmc on android tablet, can't log in to youtube either.

I'm having the same issue on my device. Can't seem to login. I think it's due to change in YouTube's API. Until the plugin gets an update, I think we will continue to experience this failed login problem
find quote
nztech Offline
Junior Member
Posts: 5
Joined: Aug 2012
Reputation: 0
Post: #2724
Running Eden on Win7 and all of a sudden this plugin stopped.
Tried fix to script.module.parsedom
Location:
C:\Users\<username>\AppData\Roaming\XBMC\addons

Re-Installed youtube plugin version:3.3.0

Anyone got any ideas?
find quote
Crowly Offline
Junior Member
Posts: 25
Joined: Aug 2012
Reputation: 1
Location: Norway
Post: #2725
(I suspect this will be in vain ... ) To all those asking "i cant login in what can i do?":
First read through the last few pages of this thread, it is very unlikely that you are the first or only one that are experiencing this issue, it might just happen that someone has already posted a solution, and you will find it among the posts for the last few days. Which is true in this case.
--

In my case i had to update line 102 in CommonFunctions.py to fix the "Script Failed!" error, then download and update to 3.4.0 (beta?) version of the plug-in (clicky) to fix the login in problem.
This is on XBMCbuntu (11.10, Eden).I think this issue is OS independent, so basically just update the required files (make a backup first) and you should be all set.

3.4.0 also fixed the login issue on my Raspbmc Smile
(This post was last modified: 2013-01-01 00:14 by Crowly.)
find quote
mikey1234 Offline
Banned
Posts: 408
Joined: Nov 2011
Post: #2726
Use hubmaintenance plugin in my repo to fix YouTube

It's in the fix directory
find quote
nztech Offline
Junior Member
Posts: 5
Joined: Aug 2012
Reputation: 0
Post: #2727
I updated and tested the download and renamed to:
plugin.video.youtube
Replacing the current plugin

When checking CommonFunctions.py
Line 102 reads:
version = float(version)

Loaded XBMC and Error:
Script Failed! : plugin.video.youtube
This occurs when selecting Explore youtube/search/login/
find quote
Crowly Offline
Junior Member
Posts: 25
Joined: Aug 2012
Reputation: 1
Location: Norway
Post: #2728
(2013-01-01 00:05)nztech Wrote:  When checking CommonFunctions.py
Line 102 reads:
version = float(version)
Thats whats needs updating and gives the Script faild error, the solution is referred to many times in the last few pages.
(This post was last modified: 2013-01-01 00:13 by Crowly.)
find quote
nztech Offline
Junior Member
Posts: 5
Joined: Aug 2012
Reputation: 0
Post: #2729
Went trawling back through details on line 102.
Changed line 102 to: version = float(version.split()[0])

Work perfectly. Awesome thanks heaps for that Smile
find quote
rag1998 Offline
Junior Member
Posts: 7
Joined: Nov 2012
Reputation: 0
Post: #2730
YAY to Youtube Addon 3.4.0 along with this fix: http://forum.xbmc.org/showthread.php?tid...pid1280259

Fixed my login issues and "script failed" error.

P.S If you have Google's 2-step Auth turned on then a num-pad will pop up once you hit login, use the code from your phones "Authenticator" app here and you should be good to go!
find quote
Post Reply