[RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC

  Thread Rating:
  • 26 Votes - 4.27 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
HenrikDK Offline
Skilled Python Coder
Posts: 539
Joined: Jul 2007
Reputation: 18
Post: #2011
(2012-03-24 14:01)leezy Wrote:  
(2010-08-22 20:42)TobiasTheCommie Wrote:  Comment and suggestions welcome.

In case you encounter any bugs with our plugin, please do report them so we can make this rock solid.


hi,

can anyone tell me why when i login to youtube in xbmc go to my playlists that only one or two of the movies show up in stead of my full list.

i have loads of stuff yet its like i have none,could someone fix this you think.?

be very much appreciated if some one could work this one out.

thanks

im running xbmc on windows and imac

http://code.google.com/p/youtubexbmc/wik...llDebugLog
find quote
stephenp Offline
Junior Member
Posts: 2
Joined: Mar 2012
Reputation: 0
Post: #2012
(2012-03-23 15:25)HenrikDK Wrote:  
Code:
22:02:19 T:140136234862336  NOTICE: YouTube-2.1.3
You're still using an old version of the plugin the latest version is 2.9.2, seems your xbmc is pulling from the wrong repository.. not really sure how to fix it.

This got me pointed in the right direction - I completely removed youtube again, then uninstalled it via XBMC as well.

Then I forced a refresh of the repository and now I see the latest version!

Thanks for the help!
find quote
goldie87 Offline
Junior Member
Posts: 6
Joined: Mar 2012
Reputation: 0
Post: #2013
this might be a better place to put this:

howdys guys,

just got the youtube app, i selected the hard drive on my network that all my media is on to download the youtube vids to, however once they download they do not move to that location they stay in the script.module.simple.downloader folder in user data.

if i choose to download them to my mac hard drive from my mac, they go where intended.

something to do with the network drive but not sure what it could be, any ideas?

cheers
find quote
cami Offline
Senior Member
Posts: 116
Joined: Aug 2007
Reputation: 0
Location: Scotland
Post: #2014
updated to eden and youtube still not working Sad

edit: actually it is yay!!!! just had to login again
(This post was last modified: 2012-03-27 04:16 by cami.)
find quote
MassIV Offline
Skilled Skinner
Posts: 1,065
Joined: Mar 2012
Reputation: 34
Post: #2015
I had a request, to make the plugin a bit more wife friendly. Eden btw.

It would be nice to have a "loading..." indicator. Because it can take a long time to load up big playlists and top 100 ect.
And right now it just looks like a frozen screen while it is fetching data.

Also, it would be nice to be able to hide the "change plugin settings" from the normal menu.
Since it can also be accessed by the "s" menu. Could i do that manually? What file?

And hiding "my history" and in explore, hide "youtube education".

So yeah, Loading... and hiding stuff. And plugin is awesome, thnx all.
find quote
chtamina Offline
Member
Posts: 78
Joined: May 2010
Reputation: 0
Post: #2016
How come some videos can't be streamed for apparently no reason ?

thanks
find quote
pakee Offline
Senior Member
Posts: 222
Joined: Jan 2012
Reputation: 4
Post: #2017
Quick question...when invoking the youtube plugin from another plugin is it possible to request the quality for example for passing in another param?:
'plugin://plugin.video.youtube/?action=play_video&videoid=%s' % (video_id)

What is the default video quality when invoked this way..is it the highest possible? Also it would be nice to have the interfaces to invoking the plugin described somewhere e.g. url to play single video, url to play playlist, etc

Thanks!
find quote
DarkMorford Offline
Junior Member
Posts: 5
Joined: Feb 2012
Reputation: 0
Post: #2018
Issue: Attempting to log in to YouTube using 2-factor authentication fails

System: OS X 10.7.3, XBMC 11.0, YouTube Plugin 2.9.1

Reproduction steps:
Provide username and password for account with 2-factor authentication enabled.
Receive prompt for 2-factor PIN, enter PIN generated by smartphone app.
Notice an error notification:
Code:
Error
Script failed! : plugin.video.youtube
Note that the account has not been logged in.

Debug Log (Password removed for security)
(This post was last modified: 2012-03-27 23:24 by DarkMorford.)
find quote
TheMonkeyKing Offline
Donor
Posts: 49
Joined: Mar 2012
Reputation: 1
Post: #2019
Just a couple of things...

1) I'm kinda worried about storing Youtube credentials in XBMC as now all Google products fall under the same terms of service agreement. The credentials are now the same for gmail, +plus, as well as youtube. You store one set but that opens all the other google products.

2) Do you think the code could be modified to show (scrape) only one channel? So instead of being able to search/watch most Youtube content, instead you see all the videos related to Automotive Week, let's say. I can see where one channel could be useful in certain settings.
find quote
tomiso Offline
Junior Member
Posts: 10
Joined: Oct 2010
Reputation: 0
Post: #2020
...
(This post was last modified: 2012-03-28 20:17 by tomiso.)
find quote
bgood Offline
Junior Member
Posts: 9
Joined: Jan 2010
Reputation: 0
Post: #2021
(2012-03-27 23:04)DarkMorford Wrote:  Issue: Attempting to log in to YouTube using 2-factor authentication fails

System: OS X 10.7.3, XBMC 11.0, YouTube Plugin 2.9.1

Reproduction steps:
Provide username and password for account with 2-factor authentication enabled.
Receive prompt for 2-factor PIN, enter PIN generated by smartphone app.
Notice an error notification:
Code:
Error
Script failed! : plugin.video.youtube
Note that the account has not been logged in.

Debug Log (Password removed for security)

Same issue on Ubuntu

System: Ubuntu 10.04.4 LTS, XBMC 11.0, YouTube Plugin 2.9.1

Debug Log
find quote
kmfdm515 Offline
Senior Member
Posts: 191
Joined: Mar 2009
Reputation: 0
Post: #2022
couldn't find anything via a search....is there any way to not save your searches? modifying the XML to add a value of '0' to the default values of 10/20/30/40 doesn't seem to work.
find quote
sigterm Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #2023
what i really miss in this plugin is the ability to play playlists of my subscriptions...any chance u are going to implement this soon?
find quote
activate Offline
Fan
Posts: 610
Joined: Feb 2011
Reputation: 1
Post: #2024
Hey guys,

I am trying to play a live stream from youtube live. The stream is working perfectly well from the browser. I'd appreciate it if someone can have a look at the log below to see if it provides any hints. Cheers.

http://pastie.org/3738378

Macmini running OS 10.7.3/Eden 11.0

Macmini Server 2011 i7 Quad Core, OS 10.8.2, Amp Onkyo TX-SR308 USB WD drives 3x2TB TV Samsung Plasma 720p EyeTV Integration
There are only 10 kinds of people in this world, those who understand binary, and those who don't.



find quote
djfourmoney Offline
Member
Posts: 53
Joined: Apr 2012
Reputation: 0
Post: #2025
I can't say enough about this plug-in. Its the best implementation of You Tube outside of visiting the web site itself I have found! You can make any suggested changes but the way I use it, it works beautifully.
find quote
Post Reply