[WIP] TWiT Addon

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Lorq Offline
Junior Member
Posts: 12
Joined: Jun 2011
Reputation: 0
Post: #46
Maybe you could add Justin.tv (1 Mbps) to the live stream too.

Some show changes:
-Daily Giz Wiz has been renamed to Weekly Daily Giz Wiz.
-Mostly Photo has been renamed to TWiT Photo, it also has a new icon.
-The icon for Tech News Today has an icon with Tom Merrit with a beard.

Maybe remove cancelled shows?
-this WEEK in FUN
-Current Geek Weekly

-Missing shows:
-This Week in Radio Tech
-Ham Nation

Thanks for your great video addons.
(This post was last modified: 2011-07-02 15:47 by Lorq.)
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #47
Lorq Wrote:Maybe you could add Justin.tv (1 Mbps) to the live stream too.

I'll look into it but the last I checked the justin.tv url wasn't stable enough to hard code and there wasn't a way to scrape the url from the website.

Thanks for detailed list of changes! Look for an update~ later this week.
find quote
aremar2k2 Offline
Junior Member
Posts: 17
Joined: Dec 2009
Reputation: 0
Post: #48
Hey, I just wan to point out that the live stream does not work anymore after they switched to the new studio. It buffers and stays on 50%.

Thanks
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #49
aremar2k2 Wrote:Hey, I just wan to point out that the live stream does not work anymore after they switched to the new studio. It buffers and stays on 50%.

Thanks

Yeah, we have been discussing that in this thread http://forum.xbmc.org/showthread.php?tid=106238

Your using eden-pre(nightly) version correct? I found that if you select play instead of waiting for it to buffer that it will play fine. Dharma 10.1 works fine for me.

Anyone have any ideas? You can copy the url
Code:
http://bglive-a.bitgravity.com/twit/live/high
to a .strm file and the behavior is the same. The player opens and immediately starts buffering, seems to hang at " buffering...50%". Others have reported after about five minuets it will start playing.
find quote
Lorq Offline
Junior Member
Posts: 12
Joined: Jun 2011
Reputation: 0
Post: #50
Very often the Bitgravity stream will freeze, and it's not because of buffering. If you go and start the stream again the video will start playing instantly. I saw this in the description for the TWiT iPhone app: "The only TWiT app with auto re-fresh on stream drop."
Is it possible to fix that for a XBMC addon?

One more show to remove maybe, "Green Tech Today". Though it wasn't really cancelled I think, it just "ended". It was just supposed to go on for 26 episodes.
(This post was last modified: 2011-08-29 01:04 by Lorq.)
find quote
Zeth Offline
Junior Member
Posts: 6
Joined: Oct 2004
Reputation: 0
Post: #51
Twit's new site is up, different layout et all. Thought I'd give you a heads up.
find quote
brandonjcreek Offline
Junior Member
Posts: 23
Joined: Jul 2010
Reputation: 0
Post: #52
Are the developers of this add-on still working on compatibility with Pre-Eden? I'm running the latest nightly and so far I cannot get it to load. Just thought I'd bring it to someones attention if they aren't aware of the issue.
find quote
deadite66 Offline
Donor
Posts: 232
Joined: Aug 2008
Reputation: 0
Location: UK
Post: #53
mp3's being loaded on some shows.
windows weekly 229 an mp3 plays but clicking 228 plays the video.
same with tnt, latest show is mp3 and previous is mp4.

i thought i noticed a notification for the twit addon being updated yesterday, looks like they may have broke something.

Asus E2KM1I-DELUXE (E2-2000 with HD7340) 60GB SSD + 2TB WD Caviar Green : xubuntu Trusty x64 : 3.14.2, (mythtv 0.27+fixes + 2x PCTV 290e DVB-T2)
Acer aspire revo R3600 Ubuntu Oneiric.
ASRock ION 3D, atom D525/ion2, 2GB ram, 1TB HDD running Ubuntu Precise. - in storage

find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #54
deadite66 Wrote:mp3's being loaded on some shows.
windows weekly 229 an mp3 plays but clicking 228 plays the video.
same with tnt, latest show is mp3 and previous is mp4.

Hi, this happens when the video isn't up yet. They put the shows up with the audio link before they post the video link. This doesn't seem to happen as much as it use to, if it continues to be a problem I'll have to make some changes. Let me know how it goes for you.
find quote
chzcat1 Offline
Junior Member
Posts: 3
Joined: Nov 2011
Reputation: 0
Post: #55
My much beloved TWiT plugin seems to be failing recently with the nightlies. I've tried going back a couple of weeks in builds, but no love. What's the best solution for my situation?
Thanks.

Edit: Just after posting, I find that the TWiT site seems to be not responding. Perhaps I was hasty. Wink Thanks all....I use this every day.
(This post was last modified: 2011-11-18 15:29 by chzcat1.)
find quote
deadite66 Offline
Donor
Posts: 232
Joined: Aug 2008
Reputation: 0
Location: UK
Post: #56
the twit site had another exploit a few days ago, they turned off caching so the site has been running slowly at times.

Asus E2KM1I-DELUXE (E2-2000 with HD7340) 60GB SSD + 2TB WD Caviar Green : xubuntu Trusty x64 : 3.14.2, (mythtv 0.27+fixes + 2x PCTV 290e DVB-T2)
Acer aspire revo R3600 Ubuntu Oneiric.
ASRock ION 3D, atom D525/ion2, 2GB ram, 1TB HDD running Ubuntu Precise. - in storage

find quote
Lorq Offline
Junior Member
Posts: 12
Joined: Jun 2011
Reputation: 0
Post: #57
Justin.tv just plays the audio stream.

Is there no way to fix so there's not so much buffering and "dropped" streams (i.e. video just freezes)? Often the live stream is unusable because of it.
I dunno if it's a XBMC problem or TWiT (not enough bandwidth to Europe?) as I rarely watch live on my browser. Does it work better with Eden?
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #58
Sorry, I don't know why some have trouble with the streams. They all play normally for me, except for having to select play again for the bitgravity streams. The add-on just sends the playback url to the player, so from the add-on side of things, I don't think there is anything I can do.

I've been using Eden for sometime now without any issues with the add-on(except the bitgravity bug).
find quote
red_lego_man Offline
Junior Member
Posts: 39
Joined: Mar 2008
Reputation: 0
Post: #59
Sorry if this is bumping an old(er) post, but it's just about the only topic I could find about the TWiT add-on.

I'm not sure if this is a problem with me, with TWiT or with the add-on, but I can't see the newer TWiT show "This Week in Enterprise Tech". Maybe because it's new, it's not being published in the right place? I'm not sure. All the other shows I watch are there, just not this one.

Thank you very much for the add-on BTW, I love it, its the only add-on I use regularly.
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #60
Hi, I've been meaning to add the new shows, just haven't got to it yet Smile I'll try and get it done soon.
find quote
Post Reply