[RELEASE] Last.FM Playlist Generator Script - Auto Generate Similar Music Playlists

  Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
l0th Offline
Junior Member
Posts: 30
Joined: Dec 2010
Reputation: 0
Post: #31
ErlendSB Wrote:I'll look into it. What's the error?

-Erlend

It's not detailed, it's just an xbmc notification that says "lastfmplaylistgeneratorPM error!"

That's all I get, I don't even get to any menu.

Is there a log somewhere that I can paste here?
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #32
The partymode script does not have a menu, it runs in the background (once started) and add tracks (silently) to the now playing playlist.

You could post the xbmc.log or excerpts from it, where it states any error info.

Do you see a progress bar when you start playing a track?
find quote
l0th Offline
Junior Member
Posts: 30
Joined: Dec 2010
Reputation: 0
Post: #33
ErlendSB Wrote:The partymode script does not have a menu, it runs in the background (once started) and add tracks (silently) to the now playing playlist.

You could post the xbmc.log or excerpts from it, where it states any error info.

Do you see a progress bar when you start playing a track?

You mean in general, when I start playing a track from my xbmc library and regardless of whether I try to start the script or not?

If so, yes. I'm using Aeon MQ 2 and I get a progress bar in the upper left corner and the menu bar itself turns into a huge progress bar when music is playing.

I'll try to replicate and copy the relevant part of the log when I get home.
find quote
SpeedyV Offline
Junior Member
Posts: 3
Joined: Jan 2011
Reputation: 0
Post: #34
Tried the script, it partially works. It ads new tracks but keeps adding the current playing track on top of the list. This results in repeating the track over and over again.

At the bottom of the playlist the new tracks are there though.

Keep up the good work!
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #35
You're right. It's pretty useless at the moment (:
I need to figure out how the playlist logic works.
When I start playing a track, the whole album is added.
This is correct behavior, but for partymode I only want to queue the one song.
Anyway, that's another nut I need to crack.
Bu when I add a track to the playlist via the script, it's placed at some random place. I'm a bit confused about this. I have some time over the weekend, so I'll see what I can do about it Smile I'll keep you posted
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #36
Uploaded a new version of the partymode script. Check it out Smile

http://code.google.com/p/lastfmplaylistg...atorPM.zip
find quote
crooksy Offline
Member
Posts: 83
Joined: Dec 2010
Reputation: 0
Post: #37
This is a great idea, I will be checking it out this weekend.

I wish there were more XBMC music plugins that intigrated more with your local music, last.fm and other music services

I'd love to rate my songs that then updates my local files ID tags and last.fm library.

One feature that would be good is to switch between playing local files or last.fm songs or a mix of both.
find quote
crooksy Offline
Member
Posts: 83
Joined: Dec 2010
Reputation: 0
Post: #38
Just installed it and the script works great.

One little thing I noticed is that I suspect the script has trouble picking up certain characters. For example the script came back with no results for "Iron & Wine" when I know for sure this artist should come back with results in Last.fm
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #39
crooksy Wrote:Just installed it and the script works great.

One little thing I noticed is that I suspect the script has trouble picking up certain characters. For example the script came back with no results for "Iron & Wine" when I know for sure this artist should come back with results in Last.fm

Yeah you're right. I'm trying to figure out this searching syntax.

This is what i'm doing at the moment: (ugly, I knowBlush)
Code:
            similarArtistName = similarArtistName.replace("+"," ").replace("("," ").replace(")"," ").replace("&quot","'").replace("'","''").replace("&","and")

I might have a go at it during the weekend. Thanks for pointing it out.
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #40
Ok, I think I got it. A little urlencoding should do the trick.

New zip files and code has been uploaded.
find quote
DarkHelmet Offline
Fan
Posts: 352
Joined: Jul 2008
Reputation: 0
Location: Hamburg, Germany
Post: #41
Brilliant work! Love it, love it, love it. One request though. Since this is a music addon, would it be possible to put it into the addon section of music and not programs? Usually I don't even have the program section on my home screen of xbmc.

I'm using some remotes for my ipod touch and something really strange happens. With every program only the path of the songs of the generated playlist is displayed but not the names of the songs. It's as if the information of the contents of the playlists comes from the files section and not the music library. Hard to explain but I hope you get what I mean.
(This post was last modified: 2011-04-10 20:06 by DarkHelmet.)
find quote
DarkHelmet Offline
Fan
Posts: 352
Joined: Jul 2008
Reputation: 0
Location: Hamburg, Germany
Post: #42
The party mode really slows down my network connection somehow. I'm using a remote for my ipod and the party mode makes the wireless connection from the remote to my pc almost non respondent. My bluetooth connection to the pc is not affected. I have another remote using a bluetooth connection and I can use that remote just fine. Cpu load is fine, it's just the network connection that slows down.

Can anyone confirm this?

Using xbmc 10.1 on windows vista
find quote
donabi Offline
Senior Member
Posts: 297
Joined: Apr 2006
Reputation: 3
Location: germany
Post: #43
it does what it should.
but i have this strange "file/library", too.
No fanart is displayed when using this script.

It is not a big problem, but i would like to know, why the fanart isn't displayed?

http://www.xbmcnerds.com - german xbmc community
find quote
ErlendSB Offline
Senior Member
Posts: 188
Joined: Sep 2008
Reputation: 3
Location: Norway
Post: #44
The party mode version is polling the Last.FM api quite often (whenever a new track is starting to play), so it will generate some network trafic. But it hasn´t caused a problem with my wifi network.

I know about the fanart problem.
I have asked about it in this thread:
http://forum.xbmc.org/showthread.php?tid=98536

No replies yet Sad
I´ll keep searching for a solution though
find quote
kiboy6 Offline
Fan
Posts: 633
Joined: Mar 2009
Reputation: 0
Post: #45
I just love this script - specifically the partymode version. Finally we have a slick "genius" like solution for XBMC.

Thanks so much.

One minor problem I'm experiencing though:

If I run the script once it works fine - I get the "select a song to start playlist generation" message as expected and everything is great.

However if I then restart my PC and launch the script again I get a message saying "Are you sure you want to exit partymode".

If i click No and then proceed to select a song, no last.fm playlist is auto generated.

Instead I have to click "Yes", and then re-launch the script in order for it to work as expected.

Is this something you are aware of? I can post a debug log if necessary.

Thanks again for the awesome script!
find quote
Post Reply