XBMC constantly locking up.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
The Chef Offline
Junior Member
Posts: 40
Joined: Apr 2010
Reputation: 0
Post: #1
Hey guys,
Got XBMC running on Zotac MAG with Linux connected to a MyBook 500 GB media HD.
I will boot it up, select a movie and hit play (hit enter on my keyboard) and it locks up. Have to hard boot.
Repeat, select movie, hit play and...(if i am lucky) It plays!

This is a typical cycle. Last night though, it took me having to reboot my locked up machine 6 times before I could watch Inception.

Any ideas?

Thanks!
find quote
Hannes The Hun Offline
Posting Freak
Posts: 1,224
Joined: May 2009
Reputation: 3
Post: #2
without a debug log (or any other worthwhile information...) it could be a problem with the external hard drive

try to copy a file to internal hard drive, then try playback

OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sharp Aquos LC-46XD1E
Asus Chromebox EZ Script
find quote
The Chef Offline
Junior Member
Posts: 40
Joined: Apr 2010
Reputation: 0
Post: #3
Cool. I will give that a shot.
However, I am using just the command prompt version of Ubuntu so I have no clue how to copy a file from the external to internal HD haha.
find quote
Hannes The Hun Offline
Posting Freak
Posts: 1,224
Joined: May 2009
Reputation: 3
Post: #4
that's why XBMC has a built-in file manager. haha.

OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sharp Aquos LC-46XD1E
Asus Chromebox EZ Script
find quote
The Chef Offline
Junior Member
Posts: 40
Joined: Apr 2010
Reputation: 0
Post: #5
Wow nice! I think that fixed it.

As I was going through the menus I discovered my resolution isn't set to 1920x1080 and it doesn't give me the option to select that. Uhh something else to figure out.
find quote
Hannes The Hun Offline
Posting Freak
Posts: 1,224
Joined: May 2009
Reputation: 3
Post: #6
so there's a problem with the external USB drive... what file format (NTFS/FAT32) are you using? please let windows do a scan of the drive.

as for the 1080p problem, we need FAR more technical information from you: how did you install XBMC (ubuntu/live/version), what graphics hardware, what TV, etc

most probably an EDID problem, or your display is only HDready and 720p is the preferred resolution anyways.

OpenElec Standalone --> Asus Chromebox 'Panther' --> Onkyo TX-NR709 --> Sharp Aquos LC-46XD1E
Asus Chromebox EZ Script
find quote
The Chef Offline
Junior Member
Posts: 40
Joined: Apr 2010
Reputation: 0
Post: #7
Hannes The Hun Wrote:so there's a problem with the external USB drive... what file format (NTFS/FAT32) are you using? please let windows do a scan of the drive.

as for the 1080p problem, we need FAR more technical information from you: how did you install XBMC (ubuntu/live/version), what graphics hardware, what TV, etc

most probably an EDID problem, or your display is only HDready and 720p is the preferred resolution anyways.

Its NTFS.

As for the 1080p problem -
Im using Ubuntu Live - i believe the latest version.
Hardware is a Zotac MAG with NVIDIA ION
TV is an LG LCD 1080p.
find quote
iDVB Offline
Junior Member
Posts: 20
Joined: Feb 2009
Reputation: 0
Post: #8
ZBOXHD-ID11 - 30GB SSD - 2GB RAM
Ubuntu 10.10
XBMC Dharma
NexStar MX 2x-3.5 Bay USB 2.0 External with 2x 2TB Hitachi Drives

I have a similar issue. I start playing a movie/tv show off the external drive.... then about 1-2min into it... the movie stalls.... then after a few seconds.. I get the XBMC error "unsafe device removal".

I exit xbmc and I see that ubuntu have remounted the drive because the folder windows for both drives are popped back up.

Rinse and repeat. Usually this is intermittent, but today its EVERY time.

Any ideas? Frown

=========================
XBMC Frodo v12.2
Win7 x64
Core i5 3.3GHz
GeForce GTX 580
8 GB RAM
=========================
find quote
yelirekim Offline
Junior Member
Posts: 1
Joined: Apr 2011
Reputation: 0
Post: #9
I have this exact same issue as iDVB, my external drive seems to unmount itself while I'm playing files off of it. XBMC doesn't freeze itself, just the drive unmounts, and then remounts for some reason.

Bumping to see if there are any ideas here.
find quote
retsudo Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #10
I have exactly the same problem as iDVB and yrelekim.
Buffalo HD-LBU2 2TB external drive, Ubuntu 11.04, XBMC 11.0 (Git unknown? Compiled 24 March 2012)
Intermittent. Thought it had gone away for a week but now it's back with a vengeance.
Anyone?
find quote
retsudo Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #11
is there any tests I can do on the drive to check its ok?
find quote
Pyromaniac Offline
Donor
Posts: 157
Joined: Mar 2012
Reputation: 1
Location: Germany
Post: #12
http://forum.xbmc.org/showthread.php?tid...ght=freeze

Some of use had the same issues/freezes. We had to upgrade our Ubuntu to 12.04. So, if you are using ubuntu+xbmc just do a release-upgrade. But if you are using XBMCbuntu then there will probably problems upgrading as i've heard.
find quote