[RELEASE] PseudoTV Addon: Virtual EPG and TV Channel Surfing Script

  Thread Rating:
  • 25 Votes - 4.96 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
butchabay Offline
Skilled Skinner
Posts: 3,849
Joined: Mar 2010
Reputation: 75
Location: Planet Crematoria
Post: #2041
I'll try to explain my problem here, as i really don't what's causing following bug:

Skins:
cirrus extended v2 SVN
Rapier SVN
Fusion Migma

If i start ptv from the addon section everything's ok, but when i start the script by favourites, exiting ptv let loose focus on home menu and can't navigate anymore. Have to close xbmc (ctrl alt delete)

I've tried the same with following skins and everything's working as excepted:

Aeon Nox SVN
reFocus
Simplicity SVN

Running latest nightly on win 7.

Anyone an idea what could be the problem?

Thanx in advance.
find quote
mcorcoran Offline
Member
Posts: 75
Joined: Aug 2008
Reputation: 1
Post: #2042
I don't think the new versions work with SMB shares. Whenever I try to run the stable pre I get the "Unable to populate channels" message. Version 1.2.1 works fine though.)

In the log I see this:
Code:
19:03:23 T:2995731312 M:3233906688   DEBUG: GetSetsNav query: SELECT sets.idSet,sets.strSet,COUNT(1) AS c,count(files.playCount) FROM sets JOIN setlinkmovie ON sets.idSet=setlinkmovie.idSet JOIN movie ON setlinkmovie.idMovie=movie.idMovie JOIN files ON files.idFile=movie.idFile  where movie.idMovie in (select movieview.idMovie from movieview WHERE (idMovie in (select idMovie from genrelinkmovie join genre on genre.idGenre=genrelinkmovie.idGenre where genre.strGenre LIKE '%Standup%'))) GROUP BY sets.idSet HAVING c>1
19:03:23 T:2995731312 M:3233906688   DEBUG: GetMoviesByWhere query: select * from movieview WHERE (idMovie in (select idMovie from genrelinkmovie join genre on genre.idGenre=genrelinkmovie.idGenre where genre.strGenre LIKE '%Standup%')) and movieview.idMovie NOT in (select idMovie from setlinkmovie) ORDER BY RANDOM()
19:03:23 T:2995731312 M:3233906688   DEBUG: Time for actual SQL query = 31
19:03:23 T:2926570352 M:3233906688   DEBUG: Compress - using DXT1 (min error is: 17.12:0.00)
19:03:23 T:2995731312 M:3235176448   DEBUG: Time to retrieve movies from dataset = 194
19:03:23 T:2906418032 M:3235483648   DEBUG: script.pseudotv-ChannelList: runActions 2 on channel 1
19:03:23 T:2906418032 M:3235483648   DEBUG: script.pseudotv-VideoParser: getVideoLength smb://192.168.1.103/Levithan/Stand Up Comedy/Russell Peters - Red White and Brown (2008)/Russell Peters - Red White and Brown (2008).avi
19:03:23 T:2906418032 M:3235483648   DEBUG: script.pseudotv-VideoParser: Unable to find the file

This file does exist/is scanned into the library/and xbmc can play it just fine. Running that path from my ubuntu box works fine as well.

Here's the complete debug log:
http://pastebin.com/bL7KWhUV
find quote
RockDawg Offline
Posting Freak
Posts: 1,438
Joined: Jun 2005
Reputation: 1
Post: #2043
Jason102 Wrote:RockDawg: you have the weirdest problems. I...don't know. Know that if you skip around in a channel (going forward or back, pause, ff, rw) then those shifts are ignored when resuming.

Good to know, but I'm not doing any of that. What strikes me about these problems is that they're consistently reproducible on all of my machines across multiple OS's and even different versions of XBMC. I don't know what would be so unique about my systems that would give me these bugs and nobody else. Especially when my systems differ from each other. The only other thing I can think of is that I'm using a mysql central db and not the default sqlite. Anyone else using PTV with mysql?
find quote
Deano316 Offline
Posting Freak
Posts: 858
Joined: Jul 2011
Reputation: 9
Location: Brighton, England
Post: #2044
Edit: posted in wrong thread Confused
(This post was last modified: 2011-11-28 17:50 by Deano316.)
find quote
Jason102 Offline
Fan
Posts: 565
Joined: Nov 2010
Reputation: 29
Location: Fuquay-Varina, NC
Post: #2045
butchabay: You're seeing some odd skin issue...I can't fix this in PTV. You might want to ask this same question in one of the threads specific to one of those skins.

mcorcoran: You say that 1.2.1 works fine...did you also use 1.2.1 in Eden? I fully expect that SMB shares won't work in Eden in anything except Windows. This was a change in Eden that I'm not a big fan of, but one I also haven't figured out a way around.

RockDawg: I'm using a central MySQL server, so that's not the problem. Are you doing any channel sharing by chance? If you are, try a single machine without it to see if you still have the problem.

[Image: PseudoTV_icon.jpg]
Channel surfing for your video library
Development Blog Repository
find quote
RockDawg Offline
Posting Freak
Posts: 1,438
Joined: Jun 2005
Reputation: 1
Post: #2046
No, I'm not doing any channel sharing. I disabled that since you said it wouldn't work in Linux due to the Samba issues.
find quote
butchabay Offline
Skilled Skinner
Posts: 3,849
Joined: Mar 2010
Reputation: 75
Location: Planet Crematoria
Post: #2047
@jason102
I think i've found the problem, it's ofcourse skin related, i'll test and report back. Thanx anyway.
find quote
Jason102 Offline
Fan
Posts: 565
Joined: Nov 2010
Reputation: 29
Location: Fuquay-Varina, NC
Post: #2048
I've tried out the IceLibrary thing, and it appears that some code that I put in to check for errors is the thing causing problems. I don't want to get rid of the code, so I need some way to turn it off when trying to play a stream. Anyway, I'll figure that out.

Can someone else test this to make sure they are seeing IceLibrary work properly? Just edit resources/lib/Overlay.py. Look for:

Code:
if self.notPlayingCount == 3:
    self.end()
    return

Put the pound sign (#) in front of each line:

Code:
# if self.notPlayingCount == 3:
#    self.end()
#    return

If that fixes the issue, I can look into make some sort of permanent solution.

[Image: PseudoTV_icon.jpg]
Channel surfing for your video library
Development Blog Repository
find quote
NaDs Offline
Member
Posts: 84
Joined: Aug 2011
Reputation: 0
Post: #2049
Jason102 Wrote:I've tried out the IceLibrary thing, and it appears that some code that I put in to check for errors is the thing causing problems. I don't want to get rid of the code, so I need some way to turn it off when trying to play a stream. Anyway, I'll figure that out.

Can someone else test this to make sure they are seeing IceLibrary work properly? Just edit resources/lib/Overlay.py. Look for:

Code:
if self.notPlayingCount == 3:
    self.end()
    return

Put the pound sign (#) in front of each line:

Code:
# if self.notPlayingCount == 3:
#    self.end()
#    return

If that fixes the issue, I can look into make some sort of permanent solution.


thanks heaps for looking into this, if i wasn't late for work i would check this..

hopefully someone can look into this and we can get it working??
find quote
badwornthing Offline
Junior Member
Posts: 8
Joined: Oct 2011
Reputation: 0
Post: #2050
Jason102 Wrote:I've tried out the IceLibrary thing, and it appears that some code that I put in to check for errors is the thing causing problems. I don't want to get rid of the code, so I need some way to turn it off when trying to play a stream. Anyway, I'll figure that out.

Can someone else test this to make sure they are seeing IceLibrary work properly? Just edit resources/lib/Overlay.py. Look for:

Code:
if self.notPlayingCount == 3:
    self.end()
    return

Put the pound sign (#) in front of each line:

Code:
# if self.notPlayingCount == 3:
#    self.end()
#    return

If that fixes the issue, I can look into make some sort of permanent solution.

Hi, I gave that a try but unfortunately it didn't work for me, PsuedoTV still stops when I try to change channel. I am using Transparency SVP, a recent nightly build and Icelibrary with a premium Megaupload account.

Hope you can fix this problem, having Icelibrary and PTV working together would truly make an unbeatable TV experience!
find quote
TheOddLinguist Offline
Member
Posts: 51
Joined: Oct 2008
Reputation: 0
Post: #2051
Anyone have any ideas on how to make a channel from a static playlist? I'm trying to make some Christmas channels; I've tried a few different techniques (directory, smart playlist searching for the word "Christmas"), but I'm not happy with the results. Seems like XBMC doesn't take kindly to the lowly static playlist, and I can't figure out a way to make a PTV channel from one. Any thoughts out there?
find quote
NaDs Offline
Member
Posts: 84
Joined: Aug 2011
Reputation: 0
Post: #2052
badwornthing Wrote:Hi, I gave that a try but unfortunately it didn't work for me, PsuedoTV still stops when I try to change channel. I am using Transparency SVP, a recent nightly build and Icelibrary with a premium Megaupload account.

Hope you can fix this problem, having Icelibrary and PTV working together would truly make an unbeatable TV experience!


i also tried and could not get to work
aeon nox skin ,nightly build with premium mega account

any other ideas??
find quote
problaze Offline
Member
Posts: 84
Joined: Feb 2011
Reputation: 0
Post: #2053
This is awesome - without a word of a lie what I have been waiting for...I have no idea where else to simply shout THANK YOU! Big Grin
find quote
Jason102 Offline
Fan
Posts: 565
Joined: Nov 2010
Reputation: 29
Location: Fuquay-Varina, NC
Post: #2054
Damn, I was hoping that it would work. Only a problem when changing channels, eh? I'll keep looking...I don't have a premium account so it takes a bit longer to test.

TheOddLinguist: I don't necessarily have a good solution for you. What I did was to add all of my Christmas movies to the Holiday genre, and then just create a genre channel.

[Image: PseudoTV_icon.jpg]
Channel surfing for your video library
Development Blog Repository
find quote
Daavid Offline
Senior Member
Posts: 216
Joined: Aug 2011
Reputation: 0
Location: Ireland
Post: #2055
Looking forward to full IceLibrary support! Come on jason, we believe in you Wink
find quote
Post Reply