[MOD] ForumBrowser (Script View) for reFocus

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Sranshaft Offline
Posting Freak
Posts: 1,429
Joined: Dec 2008
Reputation: 25
Location: Melbourne, Australia
Post: #1
This is a preliminary release for the excellent addon ForumBrowser created by Ruuk. For those who haven't had the opportunity to try this addon out, it allows you to browse the XBMC forums directly from XBMC. It's available under Programs section in the addon manager. I highly recommend it!

Now on to the screenshots. It should be fully functional though there may be some minor cosmetic issues that need addressing. If you happen to find any, please let me know.

[Image: forumbrowser%20-%20001.png]
[Image: forumbrowser%20-%20002.png]
[Image: forumbrowser%20-%20003.png]
[Image: forumbrowser%20-%20004.png]
[Image: forumbrowser%20-%20005.png]
[Image: forumbrowser%20-%20006.png]

Download from here. Unzip to %appdata%\XBMC\addons\script.forum.browser\resources\skins folder.

[Image: all-thin-fanart.jpg]
(This post was last modified: 2012-02-03 19:07 by Sranshaft.)
find quote
Jeroen Offline
Skilled Skinner
Posts: 2,499
Joined: Feb 2008
Reputation: 23
Location: The Netherlands
Post: #2
Nice! You've been keeping busy lately Smile
I'll be sure to check it out
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #3
Can't find the add-on. Which repo host it?
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #4
Found the addon here but when I'm installing I get "dependencies not meet" error...
I'm running latest nightly on an Atv2. Any idea which other dependencies I need to meet?
(This post was last modified: 2011-09-23 16:07 by ecolombres.)
find quote
Sranshaft Offline
Posting Freak
Posts: 1,429
Joined: Dec 2008
Reputation: 25
Location: Melbourne, Australia
Post: #5
ecolombres Wrote:Found the addon here but when I'm installing I get "dependencies not meet" error...
I'm running latest nightly on an Atv2. Any idea which other dependencies I need to meet?

It was available through the official XBMC repo but I believe it hasn't been updated for inclusion into the Eden repo yet. Ruuk, the author of the addon, will have to update things for it be included. I believe the "dependencies not met" error has something to do with the version of python but I can't be completely sure.

Having said that, I'll need to fix things in order for the skin to work properly with the newer GIT branch of reFocus. I just checked it - I had it installed prior to installing the pre-Eden build - and elements such as the background are now missing. This is due to some changes Jeroen made to the reFocus skin.

You should be able to install the addon manually by unzipping the file directly into the addon folder. This folder would be found at %appdata%\XBMC\addons or the equivalent on the ATV2.

[Image: all-thin-fanart.jpg]
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #6
Gracias!
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #7
Error

Quote:23:28:27 T:147828736 ERROR: Error Type:
23:28:27 T:147828736 ERROR: Error Contents: No module named webviewer
23:28:27 T:147828736 ERROR: Traceback (most recent call last):
File "/var/mobile/Library/Preferences/XBMC/addons/script.forum.browser/default.py", line 5, in
from webviewer import webviewer #@UnresolvedImport
ImportError: No module named webviewer
23:28:27 T:147828736 INFO: -->End of Python script error report<--

Webviewer??
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #8
Webviewer installed.

The skin is not working for me, i cant see The background of the forumbrowser, its just not solid.
I tried disabling fanart slideshow, but nothing.
find quote
Sranshaft Offline
Posting Freak
Posts: 1,429
Joined: Dec 2008
Reputation: 25
Location: Melbourne, Australia
Post: #9
ecolombres Wrote:Webviewer installed.

The skin is not working for me, i cant see The background of the forumbrowser, its just not solid.
I tried disabling fanart slideshow, but nothing.

I mentioned before that things need to be fixed with the skin, specifically the background.

[Image: all-thin-fanart.jpg]
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #10
Jeroen Wrote:Nice! You've been keeping busy lately Smile
I'll be sure to check it out

Jeroen, any news about this update?
find quote
Sranshaft Offline
Posting Freak
Posts: 1,429
Joined: Dec 2008
Reputation: 25
Location: Melbourne, Australia
Post: #11
ecolombres Wrote:Jeroen, any news about this update?

Jeroen has nothing to do with this mod. If I have time this weekend I'll try to update the skin.

[Image: all-thin-fanart.jpg]
find quote
ecolombres Offline
Junior Member
Posts: 31
Joined: Sep 2011
Reputation: 0
Post: #12
Sranshaft Wrote:Jeroen has nothing to do with this mod. If I have time this weekend I'll try to update the skin.
Excellent!! Thx!
find quote
Sranshaft Offline
Posting Freak
Posts: 1,429
Joined: Dec 2008
Reputation: 25
Location: Melbourne, Australia
Post: #13
Now that Ruuk has thankfully updated his wonderful addon for Eden I felt it was time to update the skin as well!

Download from here. Unzip to %appdata%\XBMC\addons\script.forum.browser\resources\skins folder.

[Image: all-thin-fanart.jpg]
find quote