How to compile a PVR branch for iOS.

  Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bablefish Offline
Junior Member
Posts: 18
Joined: Jul 2011
Reputation: 1
Post: #316
I have never tried the mediaportal pvr plugin (I am using tvheadend), but from time to time the build available from picmania has been unstable with the PVR addon. I have then tested a one release older version that has worked fine.

The builds from Red_F has always worked for me. Try to download his new build and give it a test.

wget http://dl.dropbox.com/u/19265749/org.xbm...os-arm.deb
dpkg -i org.xbmc.xbmc-atv2_11.0-0_ftr.0.0.1.133_iphoneos-arm.deb
find quote
MrNorma Offline
Junior Member
Posts: 19
Joined: Dec 2011
Reputation: 0
Post: #317
Thats the one i tried. Will need to enable debugging but it seems a problems with the build and mediaportal plugin. When i enable livetv it crashes and when i enable the mediaportal addon it crashes. Will need to test and see if it does the same with any of the other listed pvr add ons.
find quote
makblast Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #318
I have tried both Red_F newest (it won´t start, stalls while loading) and older picmania. Unfortunately I have bought an old ATV2 with 5.0 firmware which is probably why the older builds/RED_F won´t work. Guess I´ll have to wait for a new build.
find quote
MrNorma Offline
Junior Member
Posts: 19
Joined: Dec 2011
Reputation: 0
Post: #319
(2012-04-05 17:31)makblast Wrote:  I have tried both Red_F newest (it won´t start, stalls while loading) and older picmania. Unfortunately I have bought an old ATV2 with 5.0 firmware which is probably why the older builds/RED_F won´t work. Guess I´ll have to wait for a new build.


That might be my problem, what firmware should i be on?
find quote
makblast Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #320
Anything below 5.0 is good. Don´t upgrade to 5.0. The thing is you can´t downgrade onless you save som "blobs". I was unlucky as the one I bought was upgraded! And I can´t revert to an older firmware.
find quote
MrNorma Offline
Junior Member
Posts: 19
Joined: Dec 2011
Reputation: 0
Post: #321
Ok so im on firmware 4.3 and trying a full wipe and reinstall incase any addons are causing a problem. What i did find is a could enable any of the PVR addons apart from media portal

RED_F im trying your Eden PVR build for ios. Will let you know if i still have a problem and try get some logs up.
Hmmmm after reinstall i cant boot xbmc?
little update....

22:29:34 T:804851712 NOTICE: initializing playlistplayer
22:29:34 T:804851712 NOTICE: DONE initializing playlistplayer
22:29:34 T:804851712 ERROR: Default skin 'skin.touched' not found! Terminating..

Thats the error log that wont let me boot xbmc?
(This post was last modified: 2012-04-05 23:37 by MrNorma.)
find quote
Red_F Offline
Member
Posts: 53
Joined: Oct 2010
Reputation: 2
Location: The Netherlands
Post: #322
I'm really sorry if this does not work for you. But.... I'm no ATV2 expert. Actually I know already more about the internal workings of the ATV2 and other iOS devices then I really care for Big Grin. I can't test the MediaPortal add-on since I don't have MP at home. All I really intended to do was to get the ForTheRecord add-on running. And share that version with those that want it. You really should address Margro about MediaPortal add-on, he is very actively developing and I do not know if his add-on currently is expected to work on iOS.

Sorry guys, but I'm just a single person. With a wife, two kids and two cats (who claim 'quality time' from their servant too). And the day simply does not have enough hours in it to dive into every problem, no matter how interesting.

Fred
find quote
MrNorma Offline
Junior Member
Posts: 19
Joined: Dec 2011
Reputation: 0
Post: #323
Ok i managed to get RED_F's build working buy using a backed up version of my guisettings.xml and everything seems to be good. Only problem i have now is with the media portal plugin. When i enable it XBMC crashes. If i enable any other plugin everything seems to be fine.

http://pastebin.com/LyA1JPRz

Thats my xbmc.log file.

Hope someone can help. Dont have my DVB S card in yet but trying to get all software working first.
(2012-04-06 00:13)Red_F Wrote:  I'm really sorry if this does not work for you. But.... I'm no ATV2 expert. Actually I know already more about the internal workings of the ATV2 and other iOS devices then I really care for Big Grin. I can't test the MediaPortal add-on since I don't have MP at home. All I really intended to do was to get the ForTheRecord add-on running. And share that version with those that want it. You really should address Margro about MediaPortal add-on, he is very actively developing and I do not know if his add-on currently is expected to work on iOS.

Sorry guys, but I'm just a single person. With a wife, two kids and two cats (who claim 'quality time' from their servant too). And the day simply does not have enough hours in it to dive into every problem, no matter how interesting.

Fred


Total appreciate that as im a father to be within 6 weeks! Mediaportal was my Tv server of choice as it seemed easy to setup with sky fta. If 4therecord is easy i may as well look at that.
(This post was last modified: 2012-04-06 00:21 by MrNorma.)
find quote
makblast Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #324
Hi
I have tried FTR and FRED´s plugin. It works however hardwaredecoding of the stream dosen´t. This lead to laggy streams. Guess I have to wait until they jailbreak ATV3. Thank a lot for the effort.
(This post was last modified: 2012-04-06 21:01 by makblast.)
find quote
MrNorma Offline
Junior Member
Posts: 19
Joined: Dec 2011
Reputation: 0
Post: #325
The latest Red_F build is pretty stable and running nicely. My only problem now is the MediaPortal PVR client plugin. I have my main pc all setup and working well with my windows build but when i try enable the client on the ATV2 build it crash's back to desktop? Only reason i use Mediaportal and not ForTheRecord is the sky epg. I have not found an easy way to scan the channels and put them in the correct order within ForTheRecord.

The question is ask is does anyone know if i can replace just the Mediaportal addon with the ATV2 build?
find quote
grndmstr Offline
Junior Member
Posts: 7
Joined: Apr 2012
Reputation: 0
Post: #326
Is there any word as to whether the Red_F build works on 5.1?
find quote
Red_F Offline
Member
Posts: 53
Joined: Oct 2010
Reputation: 2
Location: The Netherlands
Post: #327
(2012-04-12 06:24)grndmstr Wrote:  Is there any word as to whether the Red_F build works on 5.1?
I'm afraid they will not work on 5.1 Sad The builds represent the source code state: "Eden" (PVR) final, and I have seen commits to the development repo to support 5.1, but these were way past-Eden. When development has progressed enough however, I'm sure there will come a moment that I will create new builds. And should the 5.1 fixes be merged back to the Eden (PVR) support branch I definitely will make new builds.

(2012-04-11 17:13)MrNorma Wrote:  ....
The question is ask is does anyone know if i can replace just the Mediaportal addon with the ATV2 build?
Yes this should be possible. A newer build of the addon for iOS, properly zipped (meaning re-cursing into all the supporting resources directories etc.) should be able to be installed via the "Add-ons / Install add-on from Zip" system menu.

There is one catch however (isn't there always?). The new(-er) add-on is installed at a completely different location then the original version. This works, and the new version of the add-on will be found and used. I myself was bitten by the fact that after installing a new(-er) xbmc package with an even newer-new-version of the addon (Tongue), xbmc would still load the add-on version that was installed via the Zip file and not the newest one that was present in the xbmc installation package. I had to remove that installed-from-zip version manually from the various folders the files had been put into.

I think this has to do with the fact that the PVR add-ons are true binary code (DLL's, shared objects) while all the other add-ons come as a bundle of python source/media/language files.

Cheers,
Fred
(This post was last modified: 2012-04-12 10:53 by Red_F.)
find quote
schneberger Offline
Junior Member
Posts: 14
Joined: Dec 2011
Reputation: 0
Post: #328
could anyone make a build based on tsp42's new mythtvplugin. i seem to lack the competens to do it myself.
i would be forever greatfull =)
find quote
schneberger Offline
Junior Member
Posts: 14
Joined: Dec 2011
Reputation: 0
Post: #329
really can't get it to work. have tried red_f's take and also mephiz take 11. maybe it is something wrong with the mythtvplugin or maybe i am just stupid =)

here is a post from the log

03:43:54 T:106930176 DEBUG: InitialiseClient - initialising add-on 'MythTV PVR Client'
03:43:54 T:106930176 DEBUG: PVR - Create - creating PVR add-on instance 'MythTV PVR Client'
03:43:54 T:106930176 DEBUG: ADDON: Dll Initializing - MythTV PVR Client
03:43:54 T:106930176 DEBUG: SECTION:LoadDLL(/private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr)
03:43:54 T:106930176 DEBUG: Loading: /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr
03:43:54 T:106930176 ERROR: Unable to load /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr, reason: dlopen(/private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr, 1): Symbol not found: _GetChannelGroupMembers
Referenced from: /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr
Expected in: flat namespace
in /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/pvr.mythtv/XBMC_MythTV.pvr
03:43:54 T:106930176 INFO: Called Add-on status handler for '4' of clientName:MythTV PVR Client, clientID:pvr.mythtv (same Thread=no)
03:43:54 T:164708352 DEBUG: Thread CAddonStatusHandler:pvr.mythtv start, auto delete: 1
03:43:54 T:106930176 ERROR: PVR - InitialiseClient - can't initialise add-on 'MythTV PVR Client'
find quote
margro Offline
Fan
Posts: 662
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #330
Short answer for the MediaPortal plugin: ATV2 is not yet possible. Porting the TSReader code from the 4TheRecord addon back to the MediaPortal addon is still work-in-progress from my side. I don't own any OSX, ATV2 or IOS devices so I can't test it and I'm not able to build an ATV2 version.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
Post Reply