[AppleTV2] AC3 / DTS Audio problem with a nightly build

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
root2 Offline
Junior Member
Posts: 26
Joined: Jan 2011
Reputation: 0
Post: #1
Plattform: AppleTV2 with IOS 4.3.0 v2 - Build 8F202
Jailbreaked: via Seas0npass
Installed via: copyed the *.deb file via SSH and then dpkg -i filename.deb
XBMC Version: Self compiled from scratch 10.April.2011. Git:20110409-5218c31
Instructions: Just try to play the mkv file. Under settings its configured to optical/coax 5.1 and that i have a AC3 / DTS capable Receiver. Thats all. I use the AppleTV2, an optical cable to my Denon AVR-2105 Receiver, which is set to auto-mode. (PCM, DTS, AUTO)

Bug: The Audio Playback AC3 and DTS is not working, i only hear a loud noise.

xbmc.log http://pastebin.com/vd2PH3cw
syslog http://pastebin.com/1Rfw7xUf
mediaInfo http://pastebin.com/J6J7PtHe

[Image: 1120082351.png]
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,848
Joined: Feb 2011
Reputation: 117
Location: germany
Post: #2
Its known and caused either by the jailbreak or bei the Apple iOs 4.3.x. There is no resolution for it i know off by now. For AC3/DTS passthrough i suggest to revert to 4.2.1.

PS: Others should take a leaf out of your very good bug report :o) - thx man
find quote
root2 Offline
Junior Member
Posts: 26
Joined: Jan 2011
Reputation: 0
Post: #3
i went back to 4.2.1 there my own compiled nightly and keith's nightly works perfect!

I think its a 4.3 bug, we need to wait, until someone will fix this Nod

[Image: 1120082351.png]
find quote
keith Offline
Team-Kodi Member
Posts: 721
Joined: Sep 2007
Reputation: 3
Location: SF, CA
Post: #4
I agree, thanks for the detailed bug report root2! Too bad there's not much we can do with audio until AudioEngine gets merged.

FOR IOS: xbmc.log: /var/mobile/Library/Preferences/xbmc.log (be sure to enable debugging)
For troubleshooting and bug reporting please make sure you read this first.
Always read the XBMC online-manual, FAQ and search the forum before posting.
MediaInfo : http://mediainfo.sourceforge.net/
find quote
PressureDrop Offline
Junior Member
Posts: 12
Joined: Mar 2011
Reputation: 0
Post: #5
keith Wrote:I agree, thanks for the detailed bug report root2! Too bad there's not much we can do with audio until AudioEngine gets merged.

Is there an ETA for when AudioEngine will get merged? I've been hoping to move to the latest version of iOS (mainly to get 5.1 sound on Netflix). Are we talking days, weeks or months?

Thanks for all of the work you and the rest of the team have done on this!
find quote
zerolimit Offline
Junior Member
Posts: 42
Joined: Apr 2011
Reputation: 0
Post: #6
No one knows etas
find quote
keith Offline
Team-Kodi Member
Posts: 721
Joined: Sep 2007
Reputation: 3
Location: SF, CA
Post: #7
AudioEngine will be merged when these things (and possibly more) are done:
1) it's sufficiently tested all over
2) the bugs testing has came up with are fixed
3) it's tested alot more again
4) more bugs fixed

As one of the people asked to test and haven't been able too, I feel bad.

So how can we accelerate stuff like this? Why, more knowledgable people on the IRC channel who help with ios stuff, so we can include them in osx testing (because AE is on both OSX and iOS) and the devs get to spend time debugging/fixing and not testing. Smile

That's why an ETA is not given. Nobody here works 9-5's on this, so bursts of activity happen when: a) devs are around b) people are around to test. This isn't rocket science folks.

Which is why the common response to 'ETA?' is 'Patches welcome!'
IE, you code it and make sure it works/doesn't break stuff/integrates in the code if you want an arbitrary date.

BTW, I am not a dev, so don't tell me because you 'dont code' you can't contribute. If you read this, I contributed to your mindshare and it didn't even cost you a dime but a few seconds. Smile

FOR IOS: xbmc.log: /var/mobile/Library/Preferences/xbmc.log (be sure to enable debugging)
For troubleshooting and bug reporting please make sure you read this first.
Always read the XBMC online-manual, FAQ and search the forum before posting.
MediaInfo : http://mediainfo.sourceforge.net/
find quote
DN38416 Offline
Junior Member
Posts: 46
Joined: Jan 2011
Reputation: 0
Location: Coffs Harbour, Australia
Post: #8
Keith I'm confused. In your nightly thread, you deleted my post for telling others that it doesn't work on 4.3 (I apologize for that by the way)... And that you've had yours working with AC3 and DTS the whole time.
But now you're agreeing that there is a problem with it?

I wasn't trying to hijack your thread or anything, I just wanted to warn people about the bug and let them know that 4.2.1 firmware has AC3 and DTS working correctly. Mainly so you wouldn't have a bunch of people asking why it wasn't working with the latest firmware and cluttering your thread.
find quote
keith Offline
Team-Kodi Member
Posts: 721
Joined: Sep 2007
Reputation: 3
Location: SF, CA
Post: #9
AC3/DTS works for 'some' people. We don't know why/how/etc yet.

AudioEngine will hopefully fix most/some/all? of these issues.

There's been an AC3/DTS issue since day 1 for some folks. Other folks it worked for and broke on 4.3. Some it broke earlier.

The thing is, nobody is going to do anything about it until AE is merged, so might as well stop having tons of posts related to it.

FOR IOS: xbmc.log: /var/mobile/Library/Preferences/xbmc.log (be sure to enable debugging)
For troubleshooting and bug reporting please make sure you read this first.
Always read the XBMC online-manual, FAQ and search the forum before posting.
MediaInfo : http://mediainfo.sourceforge.net/
find quote
DN38416 Offline
Junior Member
Posts: 46
Joined: Jan 2011
Reputation: 0
Location: Coffs Harbour, Australia
Post: #10
Ah okay. Thanks for explaining Smile
find quote
peeltone Offline
Junior Member
Posts: 2
Joined: Apr 2011
Reputation: 0
Post: #11
I am also having issues with sound, connecting to my itunes library via homeshare playing AC3 fine, playing direct from NAS not working - can I downgrade to 4.2.1 with seasonpass by creating a custom ipsw or will it not work as I don't have the blobs?

Anyone point me in the direction of some instructions?
find quote
dtviewer Offline
Fan
Posts: 664
Joined: Jul 2008
Reputation: 1
Post: #12
peeltone Wrote:I am also having issues with sound, connecting to my itunes library via homeshare playing AC3 fine, playing direct from NAS not working - can I downgrade to 4.2.1 with seasonpass by creating a custom ipsw or will it not work as I don't have the blobs?

Anyone point me in the direction of some instructions?

There are instructions in the off topic section.
find quote
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #13
In case anyone doesn't know where the Off-Topic area is: http://forum.xbmc.org/forumdisplay.php?fid=113
find quote
peeltone Offline
Junior Member
Posts: 2
Joined: Apr 2011
Reputation: 0
Post: #14
appreciated thanks.
find quote