MP4 movies crash XBMC on my Apple TV 2

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wallyyfm Offline
Junior Member
Posts: 2
Joined: Apr 2011
Reputation: 0
Post: #16
this totally helped my as well, although the audio is still destroyed right now
find quote
mydogjake Offline
Junior Member
Posts: 4
Joined: Apr 2011
Reputation: 0
Post: #17
I am having the same problem with mp4 video. I JB using Seas0npass. I did not install nitoTV, just XBMC. So my question is was the firecore media player installed with the Seas0npass image. If so how do I delete it?
find quote
dvverga Offline
Junior Member
Posts: 21
Joined: Apr 2011
Reputation: 0
Post: #18
mydogjake Wrote:I am having the same problem with mp4 video. I JB using Seas0npass. I did not install nitoTV, just XBMC. So my question is was the firecore media player installed with the Seas0npass image. If so how do I delete it?

Firecore media player doesn't come with season pass or with nito tv, but comes with atv black flash. So if you bought and paid for that and ran it then that is where it got installed.

On another note, version .3 that just got released is said to fix the issues with xbmc at least according to the release notes.
find quote
mydogjake Offline
Junior Member
Posts: 4
Joined: Apr 2011
Reputation: 0
Post: #19
I just installed the nightly build an now have no problems playing mp4/m4v
find quote
jpod-x Offline
Junior Member
Posts: 1
Joined: Apr 2011
Reputation: 0
Post: #20
I got it working following Chiss and amet's code instructions and dazex's advice on removing Firecore's media player. Thank you all.

One question: Will I have to regularly use above code to continually have the latest build?
find quote
keith Offline
Team-Kodi Member
Posts: 723
Joined: Sep 2007
Reputation: 3
Location: SF, CA
Post: #21
jpod-x Wrote:I got it working following Chiss and amet's code instructions and dazex's advice on removing Firecore's media player. Thank you all.

One question: Will I have to regularly use above code to continually have the latest build?

I'm assuming you meant the commands that amet gave you and yes. But if the build you have works, you don't need to upgrade until you reach a problem and are aware the nightlies fix it.

As my grandpa always used to say, if it ain't broke, why fix it?

FOR IOS: xbmc.log: /var/mobile/Library/Preferences/xbmc.log (be sure to enable debugging)
For troubleshooting and bug reporting please make sure you read this first.
Always read the XBMC online-manual, FAQ and search the forum before posting.
MediaInfo : http://mediainfo.sourceforge.net/
find quote
salchicha Offline
Junior Member
Posts: 4
Joined: Feb 2011
Reputation: 0
Post: #22
Thanks for the instructions Chiss & Amet...helpful instructions for a supernoob like me! MKVs are working fine now, no crashes, just can't work out how to turn off subtitles. I'm sure I'll figure it out :-)
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #23
salchicha Wrote:Thanks for the instructions Chiss & Amet...helpful instructions for a supernoob like me! MKVs are working fine now, no crashes, just can't work out how to turn off subtitles. I'm sure I'll figure it out :-)

open OSD(hold center button), select audio menu, disable subtitles in there

if you want subs off by default on all movies in the same menu look for "set as default for all movies"
find quote
Yanni Offline
Junior Member
Posts: 11
Joined: Apr 2011
Reputation: 0
Post: #24
hi guys....i run these commands via ssh:

wget http://hadm.net/~keith/xbmc_atv2/latest_atv2.deb
dpkg -i latest_atv2.deb
rm -rf latest_atv2.deb

so now i have mkv and mp4 play, but the sounds goes in and out.
also, subtitles are on.
any idea how to turn it off.

i read amet said hold the OSD, is this the main button on ATV 2G ?

please help.
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #25
Yanni Wrote:hi guys....i run these commands via ssh:

wget http://hadm.net/~keith/xbmc_atv2/latest_atv2.deb
dpkg -i latest_atv2.deb
rm -rf latest_atv2.deb

so now i have mkv and mp4 play, but the sounds goes in and out.
also, subtitles are on.
any idea how to turn it off.

i read amet said hold the OSD, is this the main button on ATV 2G ?

please help.

If you actually read what I said, you will see it's the center button you need to hold
find quote
Yanni Offline
Junior Member
Posts: 11
Joined: Apr 2011
Reputation: 0
Post: #26
thanks amet.

is that the white remote control? or...?
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #27
Yanni Wrote:thanks amet.

is that the white remote control? or...?

Somehow I doubt you got the white remote with atv2, but yeah the white one as well
find quote
Yanni Offline
Junior Member
Posts: 11
Joined: Apr 2011
Reputation: 0
Post: #28
amet,

i have it.

so that will take care of the subs.

and about the sounds.....please write me what to do.

thanks amet.
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #29
Yanni Wrote:amet,

i have it.

so that will take care of the subs.

and about the sounds.....please write me what to do.

thanks amet.

read the sticky about nightly builds and report the issue in a proper way, not here though
find quote
Yanni Offline
Junior Member
Posts: 11
Joined: Apr 2011
Reputation: 0
Post: #30
amet, i fixed the subs, but i was able to get the menu also with the new remote.

thanks for your devotion to this chat. i hope i can contribute help as well.
find quote