Kodi Community Forum

Full Version: [MOD] Blue OSD for reFocus
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
One of the things I liked about reFocus 0.9 was the new blue OSD so I tried to port it to Because most of my movies don't have a studio image, I replaced with movie cover (see screenshots). For tv shows, it remained as the original. All the credit goes to Jeroen and Sranshaft, I only rearranged what was already available.

Installation is very simple. Copy all the .xml files to "720p" folder, and those three png images to "media" folder. Please make sure to backup the original xml files first, just in case. Enjoy.

LE: I added a modified blue OSD for pause/skip.




Thanks ! The new OSD is one of the coolest features of 0.9 Smile
Very nice, and well done. Thank you!
Hi , Maybe I'm stupid but how to get that OSD with 0.9?
I have it installed but when I press pause I only have a screen like below

Press 'i' or whatever button you've mapped for info.
Cool thanks for the info mate, so easy !
I've only one issue. I run XBMC at 1080p, and so, the 'Now Watching' text is 2x smaller than how it it is in the screen shots in the first post. What do I have to edit to increase the font size? I'm been able to edit the text so it says 'Now Watching' instead of 'now watching', but I don't know how to change the font size.
@rd1979: open DialogFullScreenInfo.xml and delete lines 50 and 58 where it says <width>1080</width>. I have only a HD Ready tv so I can't test it. Let me know if it worked, if not, we'll try something else.
Or just download again (I updated the archive) and overwrite.
No, didn't change the text size.
Have you downloaded the archive again ? If you did and didn't worked, the open font.xml and go the line 188 and increase the font size.
Galefury Wrote:Have you downloaded the archive again ? If you did and didn't worked, the open font.xml and go the line 188 and increase the font size.

It's not having any effect at all.
You are doing something wrong. I just tried, increasing osd7 font size, line 188, definitely works, I can post a screenshot if you like.

My archive also contains a font.xml. Have you replaced the original one with the one modified by me ?
I don't know what to tell you, I REPLACED the files even. I re-downloaded the zip, and changing the size doesn't affect it. The blue OSD bar is there, but the font size doesn't change.

I've even changed the resolution in XBMC to 720p to see if it only happens in that res, and nothing. I was even able to change the text from 'now watching' to 'Now Watching', but the font size of that text is the same if I increase or decrease it.
I don't know what to say, man. It should work. Anyone else having this problem ?
I tried changing this


number 48 to 32, 64, 96.. tried changing font under skin setting to unicode, alternate and back, tried changing lang restarting xbmc changing to different skin and back, but no effect. Using refocus, xbmc 10.1 and as I post this I downloaded your OSD again just to make sure it the latest version and put font size 88 but again nothing. The OSD works and it looks just like in your screenshots otherwise.

Aha it works with font setting set to default!
Pages: 1 2