Kodi Community Forum

Full Version: [LINUX] Ubuntu Natty and vsync/tearing issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Have just run an upgrade and now I get tearing in the UI and on video.

Nvidia gpu. There are plenty of comments around about driver blacklisting or incompatibility with Unity, but after reading them all they seem red herrings or not xbmc specific enough.

Have tried many combinations of vsync vblank for blotting and GL etc. Nothing seems to help. Am booting into "classic" to avoid Unity issues, but in neither is it clear how to confirm compiz is turned off. But I think it is.

Glxgears runs at 60hz exactly so it is clearly syncd in the desktop but even there, when gears is maximised there is a clear tear about 20% down the screen in a fixed location (doesn't skip around)

This does seem related to the other Natty/nvidia issues so I'm assuming other xbmcers must be seeing this too
colinjones Wrote:Am booting into "classic" to avoid Unity issues, but in neither is it clear how to confirm compiz is turned off.

both Unity and Ubuntu Classic use Compiz,
you need to pick Ubuntu Classic (no effects) to get rid of it.
Did you try solution from the sticky?
It will disable compiz on NVIDIA drivers level.
@ronie - I'm using (no effects) for exactly that reason. And that Appearance no longer explicitly allows you to turn it off. This doesn't solve the problem.

@uomiarz - I used to use the explicit composite disable option but it seems that was overwritten a couple of district upgrades ago! I assume setting Appearance to no effects had the same impact. That option doesn't exist now but I thought the (no effects) option would do the same. I will try it this morning. But I note I'm seeing the tearing in gears on the desktop as well.

Thx!
Have you actually tried Unity2D?
You can install it via Software Center. Log out after installation.

I have a Ubuntu 10.04 sytem with no effects enabled and plan to upgrade too.
Tearing would be very bad...
But as Unity2D doesn't use any compiz it may help a lot!

p.s. Classic Gnome is no option for me.
laryllan Wrote:Have you actually tried Unity2D?

yep, and it didn't work for me Sad

natty, nvidia GT240, hdmi out, XBMC 10.1

EDIT: tried mplayer and vlc and it was the same tearing so found this thread with quite a few options.... but

Code:
sudo nvidia-xconfig --no-composite

worked for me using unity 2d Smile
I tried a bit with my netbook (ION graphics) and I think I may have found a sollution.

Disable all vsync settings in Nvidia settings and XBMC.
Enable vsync in Compiz OpenGL settings.
Set Don't wait for video sync in Compiz workarounds.

I haven't tried much, but it seems the tearing is gone in XBMC using Unity3D...
...can you try?
gobbledigook Wrote:natty, nvidia GT240, hdmi out, XBMC 10.1

... found this thread with quite a few options.... but
Code:
sudo nvidia-xconfig --no-composite
worked for me using unity 2d Smile

Link within the link that you referenced helped me. I had a new HTPC build and I couldn't figure out why the tearing was happenning... was it my monitor, power supply, HDMI cables or video card (Galaxy GeForce GT 430 1GB)? I was thrilled to find that:

1. /etc/X11/xorg.conf
Code:
Option         "TripleBuffer" "True"

2.
Code:
sudo nvidia-xconfig --no-composite

3. When logging into Ubuntu 11.04, after selecting user name and before entering password - selecting "Classic Gnome with NO Effects".

I don't know if one or all 3 of the above solved the issue, but I now have NO TEARING.
mythtv link

I continue to be THRILLED with XBMC and am hugely grateful to developers and community support! And I am further THRILLED with my new HTPC/FamilyPC build:
  • GIGABYTE GA-870A-UD3 Motherboard
  • HITACHI 5K3000 2TB SATA 6.0Gb/s 3.5" Internal Hard Drive
  • G.SKILL Ripjaws 8GB (2 x 4GB)
  • AMD Phenom II X4 955 Processor
  • LG Black 10X Blu-ray Burner
  • Galaxy GeForce GT 430 (Fermi) 1GB Video Card
  • Rosewill RD500-2DB 500W ATX12V Power Supply
  • Sunbeam UFO ACUF-HUVB UV Blue Clear Acrylic ATX Cube Computer Case
I've been watching these '11.04/tearing' issue threads like a hawk and I'm surprised there hasn't been a more definite fix for this from Ubuntu, either people are going back to <10.10 or they don't mind the tearing...

For me I had everything I wanted working in Maverick (PS3 Remote, dual audio to optical and HDMI etc.), so the only benefit of Natty to me is the Unity interface. I have no interest in running the Classic interface as I might as well run Maverick.

Therefore I've not tried the 'fixes' from the previous few posts (mainly because I've rebuilt and changed so many settings over the last few weeks that I'm sick of it!) but I believe I might have found a workaround for XBMC by accident.

I installed Unity 2D just to see how it compared with Unity 3D and I was a little disappointed. When I went into 'System Settings - Login Screen' to change back to Unity 3D I noticed there was an option to make XBMC the default session.
I rebooted my machine and it went straight into XBMC, I tried my usual tearing test video (The Good Wife s2e01) and if by magic the tearing was gone!

I thought this may have something to do with Unity 2D so I went back into the 3D sessions to make it the default session and then followed the same procedure to make XBMC the default session, result = still no tearing.

If I load up XBMC after launching a desktop session the tearing re-appears.
If I make Unity 3D the default session but cancel the autologin and log into the XBMC session the tearing is gone.

Just to confirm the only vsync settings I have changed are in the NVIDIA control panel, I haven't touched compiz, ccsm isn't even installed.
The only other non-default stuff I've installed is NFS-Common for my NAS shares and makeMKV.

If I get my audio and Bluetooth working then my machine is back to where it was with Maverick and I'm happy. I can live with interrupting the autologin session to switch between the full desktop and XBMC, even thought it delays my bootup - I just hope this helps someone else until Ubuntu fix whatever the real cause is.

My setup

Revo 3610
64-bit 11.04 Ubuntu
Latest NVIDIA drivers from x-swat PPA: 270.41.19
XBMC - unstable PPA (2:11.0~git20110529-ff2f1c1)
AeonNox skin from git
Synology NAS with NFS shares
I am also extremely interested in this thread. I did a clean install of ubuntu 11.04, and I am using xbmc version pre-11.0 compiled Jul 20 2011.
U should have 2 separate issue:

1) xrandr is unable to report correct frame rate (it report always 50)
- disable dynamic twinview in xorg.conf (nvidia control panel will be disabled and xrandr based tools will start to work)
2) compiz is unable to detect correct frame rate
- manually set your fps and untick detect refresh rate in ccsm

after that i'm able to use both xbmc and unity/compiz

nvidia 9800gs here

to temp disable compiz use "metacity --replace" in a terminal
Ok, this is probably a pretty stupid question, but what refresh rate should I choose for my TV? I am plugged in, via HDMI, to a Sony 55HX800 - it has refresh rate of 240Hz, so should I select 24, 60Huh?
For me, making sure compiz configuration manager is installed and using it to allow no redirect buffer for full screen, solved a lot of these issues.

The beauty of 240Hz refresh is that it is evenly dividable by your source refresh... I guess run the xbmc at 60Hz (which will be 4 frames/frame) and movies at 24Hz (which will be 10 frames/frame) etc... I think...
I have tried a few different things, and none of them have been very successful. I have played about with the compiz configuration manager mostly. What is the problem here? Why did it used to work fine, now no longer works at all. It is really off-putting for me.
Pages: 1 2