Kodi Community Forum

Full Version: XBMC alsa set_channels error 22
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi guys !

I got a strange problem with xbmc (10.00svn version from ppa) and alsa (1.0.24) on 11.04 (but i had the same on 10.10).

Indeed, I can play with xbmc mp3, video with mp3, with "dolby digital" content and dvd, but no video with "ac3" content (no sound, the image works).

I can read the file with vlc or media player on the same machine.

Could someone have a clue for me ?

Here are some info:

[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

and the error in the log:

21:35:30 T:2165234544 M:1591422976 DEBUG: Initialize - using alsa device iec958:CARD=Intel
21:35:30 T:2165234544 M:1591422976 ERROR: Initialize - hw_params_set_channels, alsa error: -22 - Invalid argument

Thanks in advance !!
Full debug log please.
Here's a dump http://pastebin.com/AawRcUrj

Thanks for your help !
for info this paste is with HDA Intel selected in both audio device and it works with all my other media.
Just for the subscription..
Sorry, my mistake, that's the error I got with pulseaudio..
I removed it and now here's the correct log: http://pastebin.com/LVhmSBvX
What are your audio settings? It's opening the iec958 device (spdif) with 6 channels in pcm mode, spdif only supports two channels unless you're using passthrough.
Hi bobo1on1,
what do you mean by audio settings ? in xmbc ? both device (audio and passthrough) are set to iec958
You have to set audio output to Optical/Coax for spdif to work correctly.
That is already done Smile, works with other ac3 files
During playback, turn off "Output stereo to all speakers" then restart the video.