Kodi Community Forum

Full Version: [Live] Audio issues. HDMI/or/Analog sound
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey all, ive got an HDMI audio issue. Everything else is working fine and video is playing smoothly. My specs are XBMC live with :-

AMD Athlon II X2 255
ASRock 880GMH-LE/USB3 AM3 Motherboard
On-board ATI Radeon HD 4250
Corsair VS2GB1333D3 2GB DDR3
250GB Samsung SpinPoint F3 500GB

I read tutorials and threads that say select "digital" instead of analog/hdmi/coaxial, but i dont see a digital option. Only Analog/HDMI/Coaxial. I've tried each one of these with different output and passthrough combinations and none of them work. Its either:-

- no sound with an "error initializing sound" error message,
- no sound without any message.
- stuttering audio AND video
- or if i plug in my computer speakers into the green color audio slot i can hear sound coming

Now the weird bit is that i used to have one cable DVI to HDMI for my computer to TV, along with an audio cable going from the green hole in my sound card to audio in on my tv and that works fine. I plugged this audio cable into my HTPC and its not working. I then plug my computer speakers into my HTPC and i hear sound from the speakers. Sorry i couldnt explain this any better.

I really need help with this, been trying to find a fix for this for the past 24 hours. I've never touched linux/ubuntu so all this is foreign to me. Seems like an easy fix is to install windows? But that sort of defeats the purpose of getting this box setup in the first place. Dont want to take ages booting into windows and having to run a XBMC executable etc.
I have a similar problem with LIVE...I don't have this problem with Ubuntu running XBMC or XP running XBMC..I would prefer using live because it runs a bit faster and boots easier.

ATI Radeon HD 4250 with HDMI doesn't play through TV but plugging into the Front panel with headphones or the back audio with speakers works fine.
I guess people have fixed this problem by installing the catalyst driver but I don't know how to do this from the terminal (putty). Could anyone post a link or explain how to install the catalyst driver via terminal? Thanks........UM so random but I just started XBMC and apparently it works now...so I think this is what I did that works...

1)From putty (or terminal using CTRL+ALT+F1) turn everything on in "alsamixer" and turn volume up
2)"aplay -l" and note what card and device you need...for me Card = 1 and Device = 3
i took it from the "card 1: HDMI" which is what I think we want
3) "sudo pico /home/.asoundrc" and add
Quote:pcm.!default {
type hw
card 1
device 3
}

You can add it in putty by copying it here then right clicking in putty...at least thats how I did it.

4) Then change in XBMC Settings > Audio output change to HDMI and output device to Custom then add "plughw:1,3" where 1 is the card and 3 is the device. Next change the pass through to the same "plughw:1,3"

5) you might have to restart

I hope this helps, I've been reading different forums for a while and tried this as a modification to the nVidia way here:
http://wiki.xbmc.org/index.php?title=HOW...,_or_GT240

Had to edit this because...I can hear the button presses from the speakers with this setting but am getting strange audio noise when I listen to music...it sounds like feedback but I don't know what is going on, I will attempt to fix it.

PS
FYI I don't really know what I'm doing