Kodi Community Forum

Full Version: Refresh rate mismatch: 1080i instead of 24p
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello!

I want to switch from Wndows 7 to linux for my mediacenter pc. But instead of a working system, I ran into many problems. The newest problem I cannot solve myself is a refresh rate mismatch.

I set up a fresh Ubuntu 11.04 with opdenkamps XBMC-PVR repositoryand newest NVIDIA drivers. Most things are working fine so far. But the automatic refresh rate changer does not play movies at 24hz, instead it changes to 1080i25.

Is this a known problem? Could not find much info about it...


System:

AMD Athlon II X2 240
2GB RAM
NVIDIA GT520 (NVIDIA Driver 270.41.19)
Ubuntu 11.04
XBMC-PVR (11.0-pvr+odk40 - git rev. 615e173 (30 May 2011))



thx,
Crash
Please post a debug log (remember to turn on debug logging).
Hello!

I don't know if need the whole log file. I think this is the interesting part:

Code:
14:38:50 T:140367784093440 M:1484029952  NOTICE:  (VDPAU) Total Output Surfaces Available: 2 of a max (tmp: 2 const: 4)
14:38:50 T:140367784093440 M:1484029952   DEBUG: CDVDPlayerVideo - CDVDMsg::GENERAL_RESYNC(41000.000000, 0)
14:38:50 T:140367784093440 M:1483640832  NOTICE:  (VDPAU) Creating the video mixer
14:38:50 T:140367784093440 M:1482244096  NOTICE:  fps: 23.976024, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
14:38:50 T:140367784093440 M:1482244096   DEBUG: OutputPicture - change configuration. 1920x1080. framerate: 23.98. format: VDPAU
14:38:50 T:140367784093440 M:1482244096   DEBUG: Resolution default: 1920x1080 @ 50.00Hz (13) not a very good match for fps 23.976 (weight: 0.043), trying 2:3 cadence
14:38:50 T:140367784093440 M:1482244096  NOTICE: Display resolution ADJUST : default: 1920x1080 @ 60.00Hz (23) (weight: 0.001)
14:38:50 T:140368396601312 M:1481801728  NOTICE: Using GL_TEXTURE_2D
14:38:50 T:140368396601312 M:1481801728  NOTICE: GL: Using VDPAU render method

Why does it adjust resolution to 1920x1080 @60Hz instead of @24p?

This is my actual xconfig:

Code:
nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.41.19  ([email protected])  Mon May 16 23:52:01 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SONY TV"
    HorizSync       15.0 - 75.0
    VertRefresh     23.0 - 61.0
    ModeLine       "[email protected]" 148.350 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.250 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.175 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.250 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.250 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
    ModeLine       "[email protected]" 74.250 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync interlace
    ModeLine       "[email protected]" 74.175 1920 2008 2052 2200 1080 1085 1095 1125 +hsync +vsync interlace
    ModeLine       "[email protected]" 74.250 1920 2448 2492 2640 1080 1085 1095 1125 +hsync +vsync interlace
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 520"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

That is what xrandr says - the values are wrong, whcih could be a problem with nvidia twinview.

Code:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      50.0     51.0     52.0     53.0     54.0     55.0     56.0     57.0     58.0     59.0     60.0*    61.0     62.0     63.0     64.0  
   1680x1050      65.0     66.0  
   1600x1024      67.0  
   1440x900       68.0  
   1400x1050      69.0     70.0  
   1360x768       71.0     72.0  
   1280x1024      73.0     74.0  
   1280x960       75.0     76.0  
   1280x720       77.0     78.0     79.0  
   1152x864       80.0     81.0     82.0     83.0     84.0     85.0     86.0  
   1024x768       87.0     88.0     89.0     90.0     91.0     92.0  
   960x720        93.0     94.0  
   960x600        95.0  
   960x540        96.0  
   928x696        97.0     98.0  
   896x672        99.0    100.0  
   840x525       101.0    102.0    103.0    104.0    105.0  
   832x624       106.0  
   800x600       107.0    108.0    109.0    110.0    111.0    112.0    113.0    114.0    115.0    116.0  
   800x512       117.0  
   720x576       118.0    119.0  
   720x480       120.0    121.0  
   720x450       122.0  
   720x400       123.0  
   700x525       124.0    125.0    126.0    127.0  
   680x384       128.0    129.0  
   640x512       130.0    131.0    132.0  
   640x480       133.0    134.0    135.0    136.0    137.0    138.0    139.0  
   640x400       140.0  
   640x350       141.0  
   576x432       142.0    143.0    144.0    145.0    146.0    147.0    148.0  
   512x384       149.0    150.0    151.0    152.0    153.0  
   416x312       154.0  
   400x300       155.0    156.0    157.0    158.0    159.0  
   360x200       160.0  
   320x240       161.0    162.0    163.0    164.0  
   320x200       165.0  
   320x175       166.0
Add this to the screen section in xorg.conf:
Code:
Option         "DynamicTwinView" "False"
Thx for your help, it really works. But only under special circumstances ;-)

When I start forum Ubuntu Classic interface (no effects) it switches to 24p playback (with tearing). I want to start XBMC from login-prompt, without starting Gnome first. When I do that, XBMC does not change the refresh rate. For me it looks like it tries, but without success.

This is a part of the log - looks good!

Quote:18:27:19 T:2885700464 M:1877078016 NOTICE: (VDPAU) screenWidth:1920 vidWidth:1920
18:27:19 T:2885700464 M:1876951040 NOTICE: (VDPAU) screenHeight:1080 vidHeight:1080
18:27:19 T:2885700464 M:1867390976 NOTICE: (VDPAU) Total Output Surfaces Available: 2 of a max (tmp: 2 const: 4)
18:27:19 T:2885700464 M:1867390976 NOTICE: (VDPAU) Creating the video mixer
18:27:19 T:2885700464 M:1859772416 NOTICE: fps: 23.976024, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
18:27:19 T:2885700464 M:1859645440 DEBUG: OutputPicture - change configuration. 1920x1080. framerate: 23.98. format: VDPAU
18:27:19 T:2885700464 M:1859645440 NOTICE: Display resolution ADJUST : default: 1920x1080 @ 24.00Hz (15) (weight: 0.001)
18:27:19 T:7028480 M:1832218624 NOTICE: Using GL_TEXTURE_2D
18:27:19 T:7028480 M:1832091648 NOTICE: GL: Using VDPAU render method
Sorry, but I have to ask again!

I made a fresh install of Ubuntu Natty 11.03 x86 (32bit), only installed the nvidia-current driver from the ubuntu repository.

The automatic refresh rate changer is working fine, when I start XBMC from the Gnome GUI (Ubuntu Classic - no effects). But when I load XBMC from GDM (automatic start) it doesn't. I have no clue what the problem could be!

Please help me a second time Blush
My system looks like this:

AMD Athlon X2 240
2GB RAM
NVIDIA GT520 (Driver 270.41.06)
Ubuntu 11.04 32bit (fresh and clean)
XBMC 2:11.0-pvr+odk40-eden~git20110530.615e173-0ubuntu1~ppa+odk40~natty (xbmc-bin)



LINK TO XBMC LOG

My XORG.CONF

Quote:# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 ([email protected]) Mon Apr 18 15:15:12 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
#HorizSync 28.0 - 33.0
#VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1920x1080_60_0" "1920x1080_60_1" "1920x1080_50" "1920x1080_24" "1920x1080_60i" "1920x1080_50i"
EndSubSection
Option "DynamicTwinView" "false"
EndSection

XRANDR Output:
Quote:xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
1920x1080 60.0 50.0* 24.0
1680x1050 60.0
1600x1024 60.0
1440x900 60.0
1400x1050 70.0 60.0
1360x768 60.0
1280x1024 75.0 60.0
1280x960 85.0 60.0
1280x720 60.0 50.0
1152x864 100.0 85.0 75.0 70.0 60.0
1024x768 85.0 87.0 75.0 70.0 60.0
960x720 75.0 60.0
960x600 60.0
960x540 60.0
928x696 75.0 60.0
896x672 75.0 60.0
840x525 85.0 75.0 70.0 60.0
832x624 75.0
800x600 85.0 75.0 72.0 60.0 56.0 70.0 65.0
800x512 60.0
720x576 50.0
720x480 60.0
720x450 60.0
720x400 85.0
700x525 85.0 75.0 70.0 60.0
680x384 60.0
640x512 85.0 75.0 60.0
640x480 85.0 75.0 73.0 60.0
640x400 85.0
640x350 85.0
576x432 100.0 85.0 75.0 70.0 60.0
512x384 85.0 87.0 75.0 70.0 60.0
416x312 75.0
400x300 85.0 75.0 72.0 60.0 56.0
360x200 85.0
320x240 85.0 75.0 73.0 60.0
320x200 85.0
320x175 85.0
Then add this to your screen section:
Code:
Option         "FlatPanelProperties" "Scaling = Native"
Fantastc, it works!

Now I begin to understand what the xorg.conf is needed for and what Gnome Components and Nvidia Settings applicaton do when loaded ;-)

thx for your help!