Kodi Community Forum

Full Version: grub issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Total noob here. I recently bought a couple of Giada Cubes and have been trying to get the suspend/ resume working. The fix in the wiki requires a grub update. I have updated the file but when I try and run the command

sudo update- grub

I get

/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).

I'm running live from a bootable thumbdrive (created using the wizard) with one of the nightly builds.

What does it mean and how do I get rid of it?

That sounds sticky. I have an alternate idea. In the past I have used a app called acpitool to handle resume and suspend. Messing with grub on a usb made from a wizard sounds like trouble. Or at least outside of grubs ability to detect.

Here is a man page on it:


Available for all versions of ubuntu and does not require messing with grub.

What I dont know is how to make XBMC call"

acpitool -S

when the suspend button in the gui is pressed. Are you using live or a full linux install?
I am using LIVE from one of the nightly builds.

My problem isn't necessarily suspend and resume. After the first resume I get the autoresume bug (hit the suspend and it will suspend for half a second and then resume). This is apparently due to a bug with Nvidia smb bus on certain machines.

The fix is to Disable Usbcore Autosuspend as follows (from the wiki)

Add a boot option to grub to disable the usbcore autosuspend. This bug exhibits itself as immediately waking after suspension.
Edit /etc/default/grub and add usbcore.autosuspend=-1 to GRUB_CMDLINE_LINUX_DEFAULT. Example:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash xbmc=autostart,noredir usbcore.autosuspend=-1"
Update grub:
sudo update-grub

as stated in the original post I can't run the grub update because of the following error
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?)

I unfortunately do not know how to make the gui call the aciptool.

Figured it out. You need to edit this file

Quote:Originally Posted by lcapriotti
either you open the file (\boot\grub\grub.cfg) on the usb disk on a different machine (Win/Linux/OSX), or ssh into the box and edit /live/image/boot/grub/grub.cfg.

There are several sections that refer to the menu choices. The one you want is

Quote:menuentry "XBMCLive" {
set quiet=1
set gfxpayload="800x600"
linux /live/vmlinuz video=vesafb boot=live xbmc=autostart,nodiskmount splash quiet usbcore.autosuspend=-1 acpi_enforce_resources=lax loglevel=0 persistent quickreboot quickusbmodules notimezone noaccessibility noapparmor noaptcdrom noautologin noxautologin noconsolekeyboard nofastboot nognomepanel nohosts nokpersonalizer nolanguageselector nolocales nonetworking nopowermanagement noprogramcrashes nojockey nosudo noupdatenotifier nouser nopolkitconf noxautoconfig noxscreensaver nopreseed union=aufs
initrd /live/initrd.img

You can paste usbcore.autosuspend=-1 acpi_enforce_resources=lax in this section (You can see that I did it right after quiet splash. make sure there are spaces on both sides of the text).


PS- How do I edit the thread title to put solved i it and perhaps make a better description for anyone else who has this problem?