Kodi Community Forum

Full Version: MySQL works great...movie sets don't??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I used to run a MySQL setup (on 10.0) and everything worked perfect except movie sets. Sets created before the import worked fine but sets created with new movies after do not work. It's as if MySQL is completely ignoring the tags.

I switched to a normal XBMC install (now on 10.1) for awhile but want to go back to MySQL for multiseats. I switched back and the same thing is happening. Imported sets are fine pre-conversion but after switching to MySQL it breaks any future sets. Lets say I scrape a new collection in Ember and let XBMC add it in...no set is recognized?? Same when I add an existing movie to a collection, remove it from the library and re-add it. The set tags are being ignored??

I will post an example NFO I use below. I don't feel it's the issue since it works great with the normal built in db. I eliminated the actor thumbs, rating, plot, and such to keep it short:

Code:
<?xml version="1.0" encoding="utf-8"?>
<movie xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <id>tt0320691</id>
  <title>Underworld</title>
  <originaltitle>Underworld</originaltitle>
  <sorttitle>Underworld 1</sorttitle>
  <year>2003</year>
  <releasedate>9/19/2003</releasedate>

  <BLAH BLAH BLAH tumbnails locations etc>

  <set>Underworld Collection</set>
  <fileinfo>
    <streamdetails>
      <audio>
        <channels>6</channels>
        <codec>dca</codec>
      </audio>
      <video>
        <aspect>2.353</aspect>
        <codec>h264</codec>
        <duration>133</duration>
        <height>544</height>
        <language>eng</language>
        <longlanguage>English</longlanguage>
        <scantype>Progressive</scantype>
        <width>1280</width>
      </video>
    </streamdetails>
  </fileinfo>
</movie>
I've got sets wokring fine on a mySQL setup although I manually editted the exported .nfo file rather than created it using Ember.

The only difference I can really see in the .nfo is the order of the tags, but that shouldn't make a difference

Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<movie>
    <title>Day of the Dead</title>
    <set>George A. Romero's Zombies</set>
    <sorttitle>Day of the Dead 1985</sorttitle>
    <rating>7.000000</rating>
    <epbookmark>0.000000</epbookmark>
    <year>1985</year>
    ...
    ...