Kodi Community Forum

Full Version: XBMC Video "Files" are blank
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

Firstly, just wanted to say that I'm really digging XBMC so far, it's great. The only real problem I've had in a couple of months is that since the other day, the Video>Files section of XBMC is no longer showing anything. I'm using the default Confluence skin with XBMC installed on Windows 7 32-bit. Version shows 10.1 Git:e9e9099.

I've tried deleting the video library, which has cleared out the library, but still nothing shows in the Video>Files section. I have since restored the library, since the library was never causing me an issue anyway and was always showing correctly, it was only the files section causing a problem. I have tried playing with the settings available on the "files" screen that pop out from the left, still nothing. So I can't amend any of the directories or remove them.

Any help will be much appreciated Laugh


EDIT: I have added this screenshot so you guys can see exactly what I mean.
full debug log
OK, here goes. Here is the full log:


Any suggestions gratefully received.
Turn debug logging on.

My guess is you're going to a directory that doesn't exist. Turn on parent items (settings->appearance).
Thanks for the reply - will try that as I'm fairly sure it's to do with that too but couldn't work out how to actually get XBMC to stop looking for the directory that doesn't any longer exist, plus the library was still working OK, only the files view that seems to have an issue.. Didn't realise I had to switch debug logging on.
OK, switched debug logging on now: http://pastebin.com/2SFK0xfW
Turn parent folder items back on (settings->appearance->file lists) should give you the ability to go back to the root, whereby context menu -> Clear Default should do the trick.

Alternatively, take a nosy through sources.xml (in userdata) and get rid of the <default> under the video sources.
ah this is exactly this http://trac.xbmc.org/ticket/10087

Parent is enabled....

Very interesting as <default> tags don't exist and other screens like

error! success makes zero sense.
I have tried parent items on and off, and sadly still no ability to go back to the root. I have also backed up my sources.xml file and tried deleting any sources that are SMBs that I know may not be available or cause issues, leaving only video sources on the local machine. Still looks exactly the same.
Sorry, just re-read that post - have deleted the "default" tag and I now have a normal looking interface where I can add sources again! Many thanks - will let you know how I get on and if run into further problems.
Strange the parent item doesn't show - I'll see if I can reproduce that for a start.