Kodi Community Forum

Full Version: Has anyone successfully installed XBMC Live on an Asus 1201/1215N ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello all,

I installed a copy of XBMC Live (10.1 DHARMA) on my brand new Asus 1215N from a USB flash drive (but installed to the netbook HD)

http://xbmc.org/download/

The installation appeared to go perfectly. The XBMC logo appears, but then it kicks me to the command terminal.

Running the startx command gives me the following:

Quote:(EE) No devices detected.

Fatal server error:
no screens found

Searching around for people with a similar issue, it felt like it might have been an NVIDIA driver issue.

But I've tried nearly everything I can think of including...

Quote:$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

$ sudo apt-get update

$ sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings

and

Quote:$ sudo apt-get remove nvidia-settings
$ sudo apt-get remove nvidia-current

$ sudo apt-get install nvidia-glx-185 nvidia-settings mesa-utils libvdpau-dev

But I get the same result.

I've been Googling around for hours trying to get a lead on what the issue might be. It seems that Ubuntu has an issue with Optimus enabled graphics displays? Not sure if that has anything to do with it or not.


The other thing to note is that the display flickers every now and then when booted into XBMC. I've discovered a few other posts where people describe this same issue, with the same error messages, but nobody seems to have a concrete answer as to what the issue might be.

Taking a look at the end of the /etc/X11/Xorg.0.log ...

Quote:(II) NVIDIA dlloader X Driver 270.29 Wed Feb 23 16:18:22 PST 2011
(II) NVIDIA Unified Driver for all supported NVIDIA GPUs
(II) Primary Device is: PCI [email protected]:02:0
(EE) No devices detected.

Fatal server error:
no screens found

Everything up to that point seems to be fine in the log.


If anyone out there has an Asus 12XX with XBMC Live successfully running on it, if you could post and let me know, that would be a great help.

I'm basically just trying to find out if it's even possible, or if I'm just tearing my hair out for nothing.
Update, so I ran the following command:

Quote:$ sudo lspci | grep VGA

And it came back with:

00:02.0 VGA compatible controller: Intel Corporation N10
04:00.0 nVidia Corporation Device

So it seems to me that the nVidia driver needs to be told to use 04:00.0 instead of 00:02.0 as the primary device. Is that right?

Anyone know how to accomplish this? Do I just edit xorg.conf ? I'm new to Ubuntu.
Ive just ordered one of these after some research.
Laptops with optimus have two gpu's, one a low power intel gpu and the other the ion gpu. The ion outputs through the intel video outputs and is also shut off when not needed to save power. Unfortunately the linux nvidia drivers do not support this switching, but there is a project called bumblebee which enables this switching, although there is no automatic switching like with the windows driver, but from what I read you can launch apps to automatically enable the ion gpu.

In a week or so Ill know some more Smile

Edit: I also read that enabling the nvidia ion card and in windows and then rebooting into linux would enable the ion gpu.
Thanks for the reply teeedubb!

Eventually everything I read and researched boiled down to the Bumblebee project as perhaps being the only hope.

I'm giving it a shot this week, I'll report how it goes. Thanks for the info about enabling the Nvidia card in Windows first, I'll try testing that as well.
Well I've been playing around with Bumblebee, but without any luck unfortunately.

Everything appears to be installed just fine, and the optirun command appears to work...

Quote:optirun startx
gives...

Quote:_DSM Starting Bumblebee X server bumblebee
_PS0 Enabling nVidia Card Succeeded
P3M0 Enabling nVidia Card Succeeded
DGPS Enabling nVidia Card Succeeded

But then I get...

Quote:/usr/bin/optirun line 13: 2640 Segmentation fault


I've tried everything I can think of, but like I say, I'm new to Ubuntu.

Hopefully you have better luck teeedubb and I would definitely appreciate reading your posts if you have any success!
I got my 1215n the other day but Ive been busy and havent had much time to play around with it, but the first thing I noticed was that theres no way to access the hdd with out opening up the whole netbook and voiding the warranty in the process!!! NOT COOL ASUS!!! But now after all that Im really liking it, its real snappy with the ssd + btrfs w/compression and natty x64 and runs cool.

Im able to run xbmc from a desktop install of ubuntu. It launches fine and I can browse menus although I havent played any media but its using the intel gpu. Ive installed bumble bee but I havent had any luck with it. I keep getting an error saying Another bumblebee powered application is running, keeping bumblebee alive.
Ive read through this wiki article and it looks like theres some work involved to get it working. I may have some time tonight to try some of it out.
After following the Load kernel module and Setup X Server sections its working. Xbmc loads and shows the ion gpu in the system info tab and glxgears gets is over 3 times faster with the optirun prefix.
UPDATE: I've installed the 2.6.39 kernel to get the atheros wifi to connect to the net. It would connect to the network and I could browse samba shares but I couldnt browse any web sites. Seems to be working after the update, although I haven't tested it thoroughly, but now I need to reinstall the nvidia propriety drives again as the kernel has changed...
Wow, I'm glad to hear you had success teeedubb.

I'm new to the world of Ubuntu, so I was wondering if I could pick your brain for the exact steps involved...

1. Installing Ubuntu Desktop

- Can you tell me which exact Ubuntu desktop version you installed? I see there's a list of them...

http://packages.ubuntu.com/search?keywor...tu-desktop

Dapper? Hardy? Natty? A link to the exact one you used would be very helpful to me.

2. Installing XBMC Live

Did you follow the steps in the XBMCbuntu wiki to install XBMC Live?

http://wiki.xbmc.org/?title=XBMCbuntu

Or was it another method?


Thanks for that Bumblebee Wiki link, it looks very useful.
Ok, my progress so far:

- Installed Desktop Ubuntu 11.04

Installing XBMC Live

Click on 'Applications' on the left, and do a search for 'Terminal'. Double click on the terminal to open it up.

At the command line prompt, type:

Quote:sudo apt-get install python-software-properties pkg-config

Then type...

Quote:sudo add-apt-repository ppa:team-xbmc/ppa

Now click on 'Update Manager' from the left hand side. Click on Settings -> and then go to the 'Other Software' tab.

Highlight the XBMC PPA and click Edit. Change the Distribution from natty to maverick

Click OK. You may see another one by team-xbmc. Highlight that one, hit edit, and change the distribution to maverick as well.

Now go back into the terminal and type:

Quote:sudo apt-get update

and then

Quote:sudo apt-get install xbmc

Hit Y to install.


XBMC Live is now installed, and seems to load fine, using the Intel graphics card.

Now let's install Bumblebee...

$ cd /tmp

$ sudo apt-get install ppa-purge

$ sudo ppa-purge ppa:ubuntu-x-swat/x-updates

$ sudo ppa-purge ppa:xorg-edgers/ppa

$ sudo apt-add-repository ppa:mj-casalogic/bumblebee

$ sudo apt-get update

$ sudo apt-get install bumblebee

This all goes fine.

Now let's compile the Nvidia dynamic kernel module.

$ cd /tmp

$ wget ftp://download.nvidia.com/XFree86/Linux-...mpat32.run

$ chmod +x NVIDIA-Linux-x86_64-275.09.07-no-compat32.run

$ Hold down CTRL and ALT and hit backspace at the same time. Then CTRL-ALT-F2.

$ sudo /etc/init.d/gdm stop

$ sudo killall gdm

$ sudo ./NVIDIA-Linux-x86_64-275.09.07-no-compat32.run

NVIDIA driver installed successfully.


Now this where I'm stuck. The next step is to install the graphics libraries?

As found at: https://aur.archlinux.org/packages.php?ID=50025

I'm not quite sure how to do this. I downloaded the Tarball and inside I see a PKGBUILD file and an Nvidia.install file.

I'm not quite sure what to do with either.

Same with the VirtualGL package found at:

https://aur.archlinux.org/packages.php?ID=36600


I was wondering if anyone had any hints for how to install these two packages?

Thanks
teeedubb Wrote:After following the Load kernel module and Setup X Server sections its working. Xbmc loads and shows the ion gpu in the system info tab and glxgears gets is over 3 times faster with the optirun prefix.

Teedubb, just wondering if there's any chance you would be able to post a step by step guide of what you did to get Bumblebee working with Ubuntu 11.04 ?

I have XBMC Live installed in Ubuntu 11.04 and working just fine with the Intel drivers.

I'm new to Ubuntu though, so I'm not 100% sure if I'm installing Bumblebee correctly. I gave it a shot, and ended up freezing my Ubuntu 11.04 build at bootup (I think it was an Nvidia problem).

Can you tell me if this is what I should be doing...

1. Go to https://wiki.archlinux.org/index.php/Bumblebee

2. Attempt to install the Bumblebee AUR package linked to on that page.

3. Next attempt to install dkms-nvidia, nvidia-utils-bumblebee, and VirtualGL (in that order).

Or should I be doing Step 3 first, and then installing Bumblebee?

4. Follow the Load Kernel and Setup X Server sections.

Thanks!
From memory you're on the right track, but I used ubuntu PPA's to install bumblebee and the nvidia drivers. Ill give a quick rundown as I'm typing on my phone:

Install the this ppa
https://launchpad.net/~mj-casalogic/+archive/bumblebee/

Then install 'bumblebee'

Add this ppa
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Then install 'nvidia-current nvidia-settings'

I then followed the two sections in the arch wiki then re configure bumblebee with 'bumblebee-configure' (not sure if that's the right command but in a terminal console type bumblebee then tab to auto complete to get the correct command).

All this is on a x64install of natty.

Hope this helps..
I played a HD x264 movie and I noticed it was skipping...it turns out vdpau isnt being used and isnt supported yet with bumblebee:

https://github.com/MrMEEE/bumblebee/issues/16

That thread metions hybrid-windump:

https://github.com/gebart/hybrid-windump

which looks like it could fix this...
Thanks teeedubb I will give it a shot!