Kodi Community Forum

Full Version: VDPAU playback option not available
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Im desperate, you more skilled users are my last chance :-)

My XBMC does not have VDPAU option in playback options. I cant enable it. Playback using VDPAU in Mplayer works without problem.

Im using:
- Zotac MB with ION (512MB graphics memory set)
- newest ppa version of XBMC
- Ubuntu 9.10
- newest NVIDIA driver (275)

Do any of you have idea where could be the problem?

Thanks a lot

Do you have libvdpau1 and libvdpau-dev installed?
hi X3lectric, thanks for reply...
yes, I do have them installed Undecided

dpkg -l | grep libvdpau

ii  libvdpau-dev     0.4-2~karmic~nvidiavdpauppa4    Video Decode and Presentation API for Unix
ii  libvdpau1      0.4-2~karmic~nvidiavdpauppa4      Video Decode and Presentation API for Unix

i have tried purge reinstalling XBMC, no effect Undecided any other idea?
where did you install xbmc from?

I presume form your first post you MAY have full desktop installed.

what I would do is actually re-install the packages.

can be done by
sudo aptitude reinstall libvdpau1 libvdpau-dev
But lemme now where you installed XBMC from, put xbmc in debug mode (settings somewhere) try to play a mkv file and post your sbmc log in a pastebin.

I have full desktop Ubuntu 9.10 installation with xbmc installed from official PPA. I have tried to clean all the PPAs and reinstall XBMC from scratch, no effect Undecided

link to xbmc.log on pastebin:

about line 376 there it starts to be interesting (i think :-) )
I see this

Thers no mention of vdpau except line 491

15:35:30 T:2945448816 M:930705408 DEBUG: CDVDFactoryCodec: compiled in hardware support: CrystalHD:yes OpenMax:no VDPAU:yes VAAPI:no

I would like to see if you add a vdpau ppa and install the vdpau/nvidia-settings again what happens.

see this link

the only thing I would like you to omit from that link is the nvidia-current package the rest should remain.

(Even though karmic is unsupported EOL there's no reason why this shouldn't work)

please do as I asked and pastebin all results including terminal output as it performs the commands.

And then a debug log again.

so all together I would expect 2 logs and the actions performed.

er as a complete aside form this can you also post the ppa you got xbmc from?
Im using official ppa:team-xbmc (from this official how-to)

I have tried your how-to (with iquik) and latest drivers, no luck.
Next I have tried purging all PPAs, all nvidia and xbmc related stuff and install everything from scratch by how-to above, no luck :-(

VDPAU + mplayer still OK, Im really confused.

Everything (VDPAU playback in XBMC) went ok few months ago, then since some XBMC update (dont remember which and when exactly) it have stopped working
This is pretty strange, the xbmc guisetting is a compile time option, you seem to have VDPAU compiled in so you should at least see the guisetting.
Is there a reason you're running Ubuntu 9.10? It's almost 2 years old.
Besides stating what has already been said, if you want to give XCI (xbmc complete installer) a run for your current install and see if it works. The script works for karmic only as I dont have any more interest in developing a newer version to support newer distros.

in terminal do:
cd root
wget http://dl.dropbox.com/u/4325533/XCI/xci.sh
chmod +x xci,sh
sudo ./xci.sh
There's a tons of things this does right from installing and configuring XBMC and vdpau and whatever else you want.

Then if you want newer drivers do as before.

As I mentioned here Karmic is EOL (end of live) but it SHOULD still work up to Dharma 10.1

After that if you want to continue, you need to install yavj Which I backported for karmic and compile libbost from source if you wnat to continue using karmic + script compile form GIT options.

The alternative is to dump karmic and use something else.

HAVING SAID that, you have installed mplayer and you may have messed up something else which may be interfering with this. It would be great if any of us were mind readers, but since you yourself dont know when this started happening it makes me wonder if there's and end to this tunnel.

thank to all of you for your willignes and help ... PROBLEM SOLVED

darkscout: Im using 9.10 because I have a lot of server services on the machine and Im scared of upgrading :-)

What I did, what happened and what did help? Im not sure.
1. on X3lectric hint, I have tried running his XCI script, but I didnt want to risk upgrade to Live, so I have only reinstalled drivers to 190 from it -> reboot

2. still no VDPAU, so on bobo1on1's "hint" about guisettings file, I have tried to play a little with it manually.
I have changed

3. well, I saw VDPAU switch now but was not working, and it totally deleted all my XBMC's settings, so I have tried reinstalling xbmc-standalone and restore settings, no luck ...

4. after start of XBMC, it started in default English language (not in my prefered Czech)... and HERE comes the MIRACLE ... In English menu, there WAS option to enable VDPAU and everything was ok ... then I only have switched back to Czech language without changing video playback options, VDPAU option disapeared, but VDPAU works now ...

so Im not sure what was the main cause of problem, but I think Czech translation was making the problem and may be bugged ...

So to summarize it: thanks you guys for a willingness :-)
sounds to me like a bug in the Czech translation and be even missing a string...

Anyways you can use the ppa for the video-drivers I provided so at leat you get the newest drivers and vdpau.

Also, upgrading distro is never a wise idea, fresh installs are always the sure way to go. Problem leaves reconfiguration.