Kodi Community Forum

Full Version: Library-Mode Thumbs Broken In Recent Nightlies?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I haven't tried to update XBMC for a while because last time I tried, it broke all my thumbnails. I just updated to yesterday's nightly build for Windows, and once again I am unable to get thumbnail functionality to work correctly in Library mode. When I browse in File mode, XBMC is finding things like folder.jpg and correctly displaying them. However, there is nothing displayed for the same items in library mode. What's more, in order to set the thumbnail for an item, I have to manually go in and do a "Browse To" the item. What's weird about this is that in the "set thumb" screen, it shows the correct thumbnail as the "Current" thumb, but that same thumb is not actually displayed anywhere else.

I have tried to do a rebuild by clearing my textures database and Thumbnails folder, but have had no success.

Any suggestions? I would prefer to not have to rescan in everything again.
At a guess it could be the difference between "my movies are in separate folders" and "my movies are all in the same folder"?
I have my movies set up with a "one movie per folder" structure, and a standard scan to add them into the library did get their thumbnails.

For TV shows, however, the main series thumbnails are not being automatically set correctly. Any tips for making that work correctly?
I think I may have figured it out a bit better.
The issue only occurs if I go to a TV shows source in File mode and then hit "Info" on a show that isn't already scanned in. For whatever reason, doing that results in the series thumb not being set.

I just did a scan by going up one layer, selecting my TV show source and doing "Scan For New Content" in the context menu. Doing it THAT way works as expected, thumbs are set.

Pretty weird, can anyone confirm this? Step to reproduce:
-Backup and / or clear your video database
-Navigate to and Set Content on a source with TV shows in it
-open that source in File mode.
-highlight a show and then hit "i" or select "Show Information" from the context menu
-After the show is scanned, you should be presented with the info screen for the show, with no thumbnail set.
-You can also see the missing thumb by visiting the show in Library mode
happens with music thumbs too
Interesting! Sounds like a genuine bug. Can anyone else confirm?

Just as an aside, I use MySQL for my database back-end, and I was forced to completely rebuild the database to get things working properly after the update. I tried exporting the database to a file from XBMC, then clearing the database, updating XBMC, and re-importing the database, but that didn't work for some reason. Clearing the database completely and repopulating it by scanning stuff back in worked without an issue.
Works fine here.