Kodi Community Forum

Full Version: Special characters broken after db upgrade
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
HI, i just register to report this. I searched for this problem, but couldn't find any reports. If it's there, apologies.

I just upgraded from 10.1 to the latest nightly (on 27th) and after the update all the 'ő' and 'ű' letters show up as question marks in the movie info and titles. It also tries to re-scrape movies that has special characters in the path.

This happens with the old movies and the newly scraped ones as well. I use port.hu scraper for the Hungarian plot descriptions.

Is there any way i could still salvage my db somehow without re-scraping everything?

[edit]here is the log: http://pastebin.com/gcbUfK5t

[edit2]Maybe it worth mentioning that this happens with a remote mysql database. I just checked with the default settings (turning of the remote db) and it's not an issue then.
Search the forums for the appropriate locale stuff to do for mysql.
Thanks for the tip. I tried searching, but couldn't find anything related to encoding.

But anyway, i just deleted, then recreated the database, and re-scraped everything. Now it's fine. I still get errors in the log regarding the music database, but i don't use that, so it's not a real problem.