Kodi Community Forum

Full Version: [UBUNTU] No sound HDMI ANY sounds... help plz
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
ER1401 getting no sound under ubuntu.

I also got no sound under OPENElec but I fixed this using alsa mixer and changing the play device to 0,3. Therefore i think i know the problem for ubuntu since i presume its the same one... How can i go about fixing this? All the fixes I've read are long winded and its annoying when I think I know the problem only for the 93983983 step fixes not to work.
have you tried running alsaconf?
Or have you tried running this script? (have allways worked for me)
http://ubuntuforums.org/showthread.php?t=1681577
I did try running alsa and unmuted all the channels.

http://www.openelec.tv/forum/12-guides-t...ounds-work
^
That worked for me under open elec. is there a way to adapt this fix to myself? as far as I'm aware, open elec is a very stripped down linux.
Sorry, i dont really know.
Did you both conf alsa and then activate (not unmute) the correct channels? I think its dont by pressing "X" on the channel while running alsamixer in a terminal
[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

is what i have,.

i want it to play using card 0 device 3. help please!
i tried alsa 1.24 as u linked me to:

cp ../../alsa-kernel/include/ac97_codec.h .
patch -p0 -i ac97_codec.patch ac97_codec.h
make[4]: patch: Command not found
make[4]: *** [ac97_codec.h] Error 127
make[4]: Leaving directory `/opt/Alsa-1.0.24/alsa-driver-1.0.24/include/sound'
make[3]: *** [prepare] Error 2
make[3]: Leaving directory `/opt/Alsa-1.0.24/alsa-driver-1.0.24/include/sound'
make[2]: *** [prepare] Error 2
make[2]: Leaving directory `/opt/Alsa-1.0.24/alsa-driver-1.0.24/include'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/opt/Alsa-1.0.24/alsa-driver-1.0.24'
make: *** [include/sndversions.h] Error 2

***************************************************************************
* alsa-driver-1.0.24 make failed
Dunno what that is but did you sudo?
Any question related to the script is best answered on the thread on ubuntuforums
I fixed it thanks!!

new two problems: MCE remote infrared doesn't work + resolutoon when hooking up to TV is 1024.. it should be 1920
How did you fix it? I've been struggling with this for hours.