Kodi Community Forum

Full Version: [Linux] Another help please with my gt430 and sound over hdmi
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi to all,

this is my config:

debian wheezy + kernel 3.0.0 + alsa 1.0.24 + nvidia (the last) 280. ... + unmuted alsamixer

The card is correctly installed and speaker-test work fine with -D plughw:1,9.

I've tried to create a .asoundrc in my home:
Code:
pcm.!default {
   type plug
   slave {
       pcm "hw:0,3"
       rate 48000
   }
}

and my xbmc:
AUDIO OUTPUT: HDMI
AUDIO OUTPUT DEVICE: CUSTOM - plughw:1,9
PASSTHROUGH OUTPUT DEVICE: CUSTOM - plughw:1,9

but the only thing I can listen is a bad ssshhhh when I play media with dts dd ...

The only thing that I can listen is the "ambient-sound" if I set AUDIO OUTPUT to Analog.

I've played also with modprobe and gstreamer-options...

I've read everything and I'm out of ideas Sad

This night I try with this http://wiki.xbmc.org/index.php?title=HOW...controller
What do you get if you run "aplay -l" ?
Code:
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Code:
~$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
    HDA ATI SB, ALC892 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia
    HDA NVidia, HDMI 0
    HDMI Audio Output

and my correct .asoundrc is:
Code:
pcm.!default {
   type plug
   slave {
       pcm "hw:1,9"
       rate 48000
   }
}
You get sound if it's not DD or DTS?
Are you connected to an AMP or a TV?
SwedishGojira Wrote:You get sound if it's not DD or DTS?
If I play music (mp3) or divx there's no problem... if I play dd/dts movies I get only music or rumors but no voice of the actor...
Quote:Are you connected to an AMP or a TV?
...directly to my tv (LG 50PK760) with hdmi cable (1.4)
Ok. I had this problem also for a while in some of my movies. It comes from the eight channels (7.1) being wrongly mapped for the sound cards.

If you follow the guide you've linked this should all be fixed since you remap the channels correctly in /etc/asound.conf.
Just make sure to change "hw:0,3" to "hw:1,9" for your card.
Tnks, I'll try this night!!! Big Grin
Uff... I've tried the guide on the wiki that I've mentioned but I can hear only a bad rustle...

I think that the problem is in xbmc because the speaker-test on the device is working correctly...

Any ideas?

I've installed xbmc from debian-multimedia package
on ubuntu minimal 11.04 i configured nothing as per /etc/asound.conf and i just changed hw:1,9 and everything worked perfectly.

So what i suggest is to try this on a fresh untouched install and c how it goes

regards John
I'll try to reinstall xbmc, someone that use debian and multimedia repository?
I've reinstalled alsa, configured alsactl init and magically in xbmc is compared:

audio device output: alsa:hdmi:CARD=NVidia

and now the sound is OK...

TNKS & BYeZ
Well I can't say that I have things sorted.....yet.

clean ubuntu 11.04 install, alsa 1.0.23. Asus GT430. HDMI into TV, optical cable from TV to reciver.

no audio AC3 or DTS in XBMC but plays fine from the desktop.

XBMC settings are

Audio Output = HDMI
Speaker Config = 5.0
AC3 = yes
DTS = yes
Audio Ouput = custom
plughw:1,9
Passthrough Output Device = custom
plughw:1,9

This setup gives me "audio device failed to initialize" when playing a file

aplay - l
Code:
[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

.asoundrc and /etc/asound.conf
Code:
[email protected]:~$ cat .asoundrc
pcm.!default {
   type plug
   slave {
       pcm "hw:1,9"
       rate 48000
   }
}

any help would be appreciated.
I use debian, but I think that your problem is thet alsa not yet updated... maybe you could try the patch for ubuntu ?
ok.....so all i've done (from memory) is disable the onboard audio in the bios and aplay -l now gives me
Code:
[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

i haven't touched my .asoundrc, and it'll be wrong as it will have the device in the old position as plughw:1,9 where as it's now 0,9, due to the onboard being disabled.

My main query is how do i tell if DTS passthrough is working??

I have xbmc audio as
Audio Output = analog
Speaker Config = 2.0
AC3 = nothing
DTS = nothing
Audio Ouput =gf108 high definition audio controller
Passthrough Output Device = nothing

now where as before i'd get no sound when playing a DTS/AC3 movie...i have sound, and it's via the hdmi.

checking the audio whilst playing the movie it says it's playing DTS but is there anyway of knowing?
Image