Kodi Community Forum

Full Version: XBMC set up to start with windows but automatically minimizes itself
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have XBMC in the startup folder (I am running Windows 7 64-bit). When my computer starts up, XBMC comes up, but immediately minimizes itself. Any ideas on how to stop this? I am using my PC exclusively for XBMC and I only want it to start up on XBMC.

thanks!
By default XBMC uses a DirectX mode that is fast, but that won't share the display with any other app. When another app grabs the focus it forces XBMC to minimise.

What you're seeing is almost certainly due to an app putting an icon in the system tray (the small icons at the bottom right by the clock) and that grabbing the focus. It will be something that is running when Windows start e.g. anti-virus software, printer monitoring software, etc.

The fix is to make XBMC delay a few seconds before starting. This allows the other apps to settle down so they don't grab the focus after XBMC has started. To do this right click the XBMC link in the Startup folder and on the shortcut menu choose Properties. In the properties dialog the Target field will contain something like:

"C:\Program Files (x86)\XBMC\XBMC.exe"

Modify this to be:

"C:\Program Files (x86)\XBMC\XBMC.exe" -d 10

i.e. append -d 10 to the Target. This causes XBMC to delay for 10 seconds before starting. You can decrease or increase the number 10 as appropriate. Experiment to find the minimum delay that still avoids XBMC being minimised.

Alternatively figure out what is starting and grabbing the focus and disable it, though this is easier said than done.

JR
jhsrennie Wrote:By default XBMC uses a DirectX mode that is fast, but that won't share the display with any other app. When another app grabs the focus it forces XBMC to minimise.

What you're seeing is almost certainly due to an app putting an icon in the system tray (the small icons at the bottom right by the clock) and that grabbing the focus. It will be something that is running when Windows start e.g. anti-virus software, printer monitoring software, etc.

The fix is to make XBMC delay a few seconds before starting. This allows the other apps to settle down so they don't grab the focus after XBMC has started. To do this right click the XBMC link in the Startup folder and on the shortcut menu choose Properties. In the properties dialog the Target field will contain something like:

"C:\Program Files (x86)\XBMC\XBMC.exe"

Modify this to be:

"C:\Program Files (x86)\XBMC\XBMC.exe" -d 10

i.e. append -d 10 to the Target. This causes XBMC to delay for 10 seconds before starting. You can decrease or increase the number 10 as appropriate. Experiment to find the minimum delay that still avoids XBMC being minimised.

Alternatively figure out what is starting and grabbing the focus and disable it, though this is easier said than done.

JR

thanks a ton, it works!