Kodi Community Forum

Full Version: Sound only works if i play a mp3 file first.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello
I have xbmc live on minimal ubuntu.
I can not get the sound to act properly. I should have sound via HDMI.

Code:
[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[email protected]:~$
I only get sound on hw1,7 with speaker test.
So i
This is my current configuration (After many trial and errors):
Image

Alsaconf doesnt find any soundcards...
Code:
[email protected]:~$ sudo alsaconf
Building card database..
ERROR: modinfo: could not find module snd-opl3sa2
ERROR: modinfo: could not find module snd-cs4236
ERROR: modinfo: could not find module snd-cs4232
ERROR: modinfo: could not find module snd-cs4231
ERROR: modinfo: could not find module snd-es18xx
ERROR: modinfo: could not find module snd-es1688
ERROR: modinfo: could not find module snd-sb16
ERROR: modinfo: could not find module snd-sb8

I have tried the alsa update script.
The computer i have comes with a ubuntu dist, where the sound works, but its very modded and awful to use since i only want xbmc.
is there anyway i can retry alsa settings from there?

The weird thing is that i can play an audio track, that i have sound everywhere...

Any ideas? Please!